Blender 3D: Noob to Pro - Beginner Tutorials/Print version

From Wikibooks, the open-content textbooks collection

Table of Contents

Learn to Model

- Learn to Model
  - Beginning Tips
  - Quickie Model
  - Quickie Render
  - Mesh Modeling
    - Modeling a Simple Person
    - Detailing Your Simple Person I
    - Detailing Your Simple Person II
    - Creating a Simple Hat
    - Putting Hat on Person
    - Mountains Out Of Molehills
    - Creating Models With Photo Assistance
    - Modeling a Gingerbread Man
    - Penguins from spheres
    - Die Another Way (dice modeling)
    - Die Easy (dice modeling — revised Die Another Way)
    - Model a Silver Goblet
    - Simple Vehicle
      - Simple Vehicle: Wheel
      - Simple Vehicle: Seat
      - Simple Vehicle: Rocket Launcher
      - Simple Vehicle: Body
      - Simple Vehicle: Some Assembly Required
    - Model a Low Poly Head
    - Edit Mode HotKeys Review
    - Object Mode HotKeys Review
- Curve and Path Modeling
  - 2D Image (logo) to a 3D Model
  - 2D Image (logo) to a 3D Model Part 2
  - Modeling a picture
  - Using Bones
- Materials and Textures
  - Quickie Material
  - Quickie Texture
  - Procedural Textures
    - Creating Basic Seawater
    - Texturing Basic Seawater
    - Mountains Out Of Molehills 2
    - Light a Silver Goblet
- Basic Carpet Texture
- Procedural Eyeball
- Image Textures
  - The Rusty Ball
  - Creating Pixar-looking eyes
- UV Mapping
  - Quickie UV Map
  - UV Map Basics
- Every Material Known to Man
- Modeling Keyboard Shortcuts
- Beginning Modeling Final Project

**Lighting**

- Beginning Lighting
  - Adding Lamps
  - Shadows

**Rendering**

- Render Settings
  - Output Format Options
    - OSA
  - Looking All Around - Panorama Settings
  - Other Important Render Options
  - YafRay Render Options

**Animation**

- Basic Animation
  - Lattice Deformer
  - Bouncing Ball with Lattice
  - Creating Basic Water animation

**Particles**

- Particle Systems
  - Making Fire
  - Furry
  - Rug

**Soft Body**

- Soft Body Animation
  - Simple Cloth Animation

**Blender Game Engine (BGE)**

- Game Engine Basics
  - Your First Test
  - Build a skybox
Other

- Match Moving
- High Dynamic Range imaging (HDRi)
  - Creating a Light Probe
- Create a Clayman
- Organic Modeling
- Blender FAQ

Beginner Tutorials

So you've come to learn the Blender, eh? You've made a great choice. This is one of the most powerful 3D animation and 3D creation tools out there, especially if you're short on cash. Learning how to use Blender can be a daunting task, so don't give up! But with the help of this wikibook, you can someday become a power-user and put those Maya folks to shame.

If you ever get stuck for some reason in a tutorial, there are a number of places you can turn for help. The best way to get help is, with an Internet Relay Chat (IRC) client such as X-Chat (http://xchat.org), connect to irc.freenode.net and talk to blender users in the following channels:

- #blenderwiki (irc://irc.freenode.net/blenderwiki)
- #blender (irc://irc.freenode.net/blender)
- #blenderchat (irc://irc.freenode.net/blenderchat)
- #blenderqa (irc://irc.freenode.net/blenderqa)
- #gameblender (irc://irc.freenode.net/gameblender)

If you can't get help there, click the "discussion" tab at the top of the page that you're having trouble with, and explain your problem on that page. Wait at least 24 hours for some help.

If you're still not getting help, try asking for help in the BlenderArtists.org forums (http://blenderartists.org/forum).

Tutorial Syntax

As you go through these tutorials, you will find yourself running into cryptic codes quite often. These codes refer to keys you need to press on the keyboard and buttons on the mouse you need to press. They are pretty standard throughout the Blender community at this point. You may wish to print this page for quick reference throughout this book.

Keyboard

Special/Function

<p>| ALT | the Alt key on the keyboard |</p>
<table>
<thead>
<tr>
<th>CTRL</th>
<th>the Ctrl (Control) key on the keyboard</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMD</td>
<td>the Command key on the keyboard (Macintosh, the one with the apple drawing)</td>
</tr>
<tr>
<td>F1 through F12</td>
<td>the F1 through F12 keys on the keyboard</td>
</tr>
<tr>
<td>SHIFT</td>
<td>the Shift key on the keyboard</td>
</tr>
<tr>
<td>SPACE</td>
<td>the Spacebar on the keyboard</td>
</tr>
<tr>
<td>TAB</td>
<td>the Tab key on the keyboard</td>
</tr>
<tr>
<td>ENTER</td>
<td>the Enter key on the keyboard</td>
</tr>
<tr>
<td>ESC</td>
<td>the Escape key on the keyboard</td>
</tr>
</tbody>
</table>

**Alpha-numeric**

<table>
<thead>
<tr>
<th>AKEY through ZKEY</th>
<th>the corresponding letter on the keyboard</th>
</tr>
</thead>
<tbody>
<tr>
<td>0KEY through 9KEY</td>
<td>the corresponding number on the keyboard (above the letters) on the keyboard—<strong>not</strong> on the numberpad</td>
</tr>
</tbody>
</table>

**Numeric pad**

| NUM0 through NUM9 | the corresponding number on the numberpad—**not** on the keyboard above the letters ('*Num Lock* usually needs to be enabled') |
| NUM+ and NUM− | the corresponding key on the numberpad |

Note that in Blender, there is a big difference between the numbers on the number pad of your keyboard, and the numbers along the top of the keyboard: they are actually different keys, thus mapped to different functions.

**Note for laptop users:** you should be able to use the numlock function on your keyboard to convert the 7-9, U-P, J-;, and M/- keys into a numeric keypad.

- On most modern Windows laptops there is a blue *Fn* key near the left *Ctrl* key. Hold that and press the blue *NumLk* (usually *F11*) key. If not, see your owner's manual. If your laptop does not have some way to emulate a numeric keypad, you can use the *Emulate Numpad* function built in to Blender. Point at and drag down from the bottom edge of the "File", "Add", "Timeline" menu bar; to pull out a new panel. One of the buttons on that panel is "System and OpenGL". Click the "Emulate Numpad" button, to make your regular keys on top of the keyboard behave like ones on a number pad.
- For Mac laptops, by default the F6 key without any modifiers turns on Keypad lock, wherein the right hand alpha keys emulate a numeric keypad. However, depending on your settings, you may need to hold down the FN key while pushing F6. You must be sure to use FN-F6 again in order to restore normal keyboard operation. You might find it a bit more convenient to instead hold the [fn] key on the bottom left of the keyboard to momentarily shift the keys to their number pad function.

**Note for Windows 2000/XP users:** do not press right Shift five times in a row as it turns on the Windows Sticky Keys. Doing so will mess up the ability for your keyboard to recognize commands. If the box for sticky keys appears, press cancel. If you don't need the accessibility features, you can disable sticky keys: go to Start → Settings → Control Panel; select Accessibility Options, and for each of the options, StickyKeys, FilterKeys, and ToggleKeys, (1) clear the "Use ..." checkbox, and (2) press
the "Settings..." button and clear the "Use Shortcut" checkbox.

## 2-button or 3-button Mouse

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMB</td>
<td>the left mouse button</td>
</tr>
<tr>
<td>RMB</td>
<td>the right mouse button</td>
</tr>
<tr>
<td>MMB</td>
<td>the middle mouse button or mouse wheel; if you have a 2-button mouse, use ALT+LMB to emulate the middle one</td>
</tr>
<tr>
<td>SCROLL</td>
<td>refers to scrolling the wheel of the mouse</td>
</tr>
</tbody>
</table>

**ALT+LMB tips:**

- If this key combination moves the current window (there's a conflict with your window manager), then use CTRL+ALT+LMB or MMB instead.
- If you are running Linux + KDE, then right-click on the main Blender window, select *Configure Window Behavior*, go to *Actions → Window Actions* and in the *Inner Window, Titlebar and Frame* section, select the Modifier key to be ALT and set all the select boxes beneath it to *Nothing*.

**Note for Gnome users:** it is suggested not to use the *Find Pointer* function in Gnome's mouse settings. If your mouse pointer is being highlighted when you press and release the CTRL key, go to *Mouse* in Gnome's *Desktop Settings* and uncheck the box under *Find Pointer*. Otherwise it will impair your ability to use certain functions such as *snap to grid* or using the lasso tool.

## Apple 1-button Mouse substitutions

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Substitution</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMB</td>
<td>MB</td>
</tr>
<tr>
<td>RMB</td>
<td>CMD+MB</td>
</tr>
<tr>
<td>MMB</td>
<td>ALT+MB</td>
</tr>
</tbody>
</table>

**Note:** While Mac OS X natively uses both the *Control key* and the *Command key* to emulate the RMB, recent Blender versions for Mac OS X use only the *Command key* for RMB, and the *Option* key for MMB. This behavior is also noted in the OS X Tips file that comes with the Mac version.

## Path menu

```
SPACE → Add → Mesh → UVsphere
```

means:

hit SPACE and, in the menu that comes up, choose Add then Mesh then UVsphere.
The Blender Windowing System is a treat. I know, it looks like some sort of space-ship control panel and you have never seen anything like it. Once you learn it, however, you'll wish all your programs worked this way. Move on to the next page to learn more.

An Interface, Divided, Will Surely Stand

The Blender interface can be a bit intimidating at first, but don't despair. We will explore the power and flexibility of the Blender windowing system, and how to adapt it to suit your needs, one step at a time. First, we're going to talk about manipulating the 3D Viewport and the Buttons Window.
Go ahead and open Blender if you haven't already. You'll hopefully be presented with something that looks a lot like this. You should be able to see two major divisions. There are actually three, but the third one is hidden. We'll talk more about the hidden one later.

**3D Viewport**

This top larger portion is the 3D Viewport window. It allows you to see and manipulate the 3D objects in your 3D scene.

**Buttons Window**

This section on the bottom is the Buttons Window. The buttons in the Buttons Window will allow you to manipulate the 3D objects you see in the 3D Viewport in many different ways.

The 3D Viewport's grid represents Blender Units (BU). A BU can be as large as you would like it to be: an inch, a centimeter, a mile, or a cubit. A BU lets you decide the scale.

**Window Headers**

Every window has a window header. The window header can be at the top of a window, at the bottom of a window, or hidden. Let's take a look at the window headers for our 3D Viewport and our Buttons Window.
The header for the **3D Viewport** is highlighted in **red**. Notice that it's actually at the bottom of the 3D Viewport, and not at the top.

The header for the **Buttons Window** is highlighted in **blue**.

The **active window** is the window that will respond to what you type on the keyboard when you're using keyboard shortcuts. One of the windows in Blender will be active at all times.

Making another window active is simple: simply move the mouse over one of the windows to make it active! Try changing the active window by moving your mouse rapidly between the **3D Viewport** and the **Buttons Window** now. You'll notice that the window's header lights up when it becomes active.

## Changing the Window Type

There are many window types other than the **3D View** and the **Buttons Window**, and you can easily switch any window to any other window type at any time.
Resizing Windows

Resizing windows is easy and fun.

step 1
Hold your mouse over the border between the two windows that is indicated by the red box below, and the mouse pointer will change to up/down arrows (or a hand on Mac OS X).

step 2
Click the border with the LMB (meaning Left Mouse Button) and drag up and down.

step 3
Once you've decided where to resize to, release the LMB.

You'll notice that as you increase the size of one window, you decrease the size of the other. Blender
does not allow the windows to overlap, as they would in other programs. This is why Blender's interface is known as a **non-overlapping window interface**.

## Splitting Windows

Splitting windows is just as simple as resizing them, and will give you two windows of the same type.

**step 1**  
Click the same border that you did last but this time with the **RMB** (**Right Mouse Button**).

**step 2**  
A menu will then appear. Choose **Split Area** from the menu.

**step 3**  
You'll see a preview line appear that will follow your cursor. Try dragging your mouse over both the 3D Viewport and the Buttons Window. You'll notice that this preview split line will follow you from window to window.

**step 4**  
You can finalize where you want to split by simply pressing the **LMB**. You should then have two windows where before there was only one!

Splitting a window on a vertical division will give you two windows stacked vertically. Splitting on a horizontal division, as we have done, will give you two windows side-by-side horizontally.

## Joining Windows

Rejoining two split windows is just as easy as splitting them. We'll rejoin the window we just split.
**step 1**
Click on the border you just created with the RMB, and choose **Join Areas** from the menu.

**step 2**
An arrow will then appear so that you can indicate in which direction you would like to join the windows. As you move your mouse from the left window to right window, the arrow will change directions.

Join the windows in either direction for now with the LMB.

Joining to the left means that the window on the left will be erased, while joining to the right means that the window on the right will be erased. Keep this in mind when joining different window types.

---

**Next Page: The User Preferences Window**

*Previous Page: Blender Interface*

---

The User Preferences Window

---

**Next Page: The Buttons Window**

*Previous Page: Blender Windowing System*

---

**Showing the User Preferences Window**
The first window we’ll teach you in detail is the **User Preferences** window. This window is mostly hidden by default, because most of the time you won’t need all of its contents. Only the **header** at the top of the main window, (outlined in **red**) is visible here.

### step 1
To make the **User Preferences** window visible, you just need to resize it. You do that the same way that you resized the other windows in the previous tutorial. Click with the **LMB** on the border along the top of the 3D Viewport, and drag.

### step 2
Release the **LMB** to resize the windows. You should then have the entire **User Preferences** window visible!
Configuring and Saving Your Preferences

Setting Up Auto Save

The first thing you'll want to do is enable **Auto Save**. **Auto Save** will help you avoid the loss of important work in case Blender crashes, your power is cut off, etc.

**step 1**
To show the **Auto Save** options, click the **Auto Save** button (outlined here in blue).

**step 2**
Next, adjust the **Auto Save Settings**:

- **Auto Save Temp Files** - enabled by default, this turns the Auto Save system on and off. Leave it on.
- **Minutes** - how often should your work be auto-saved? (recommended 15 to 30)
- **Open Recent** - use this to recover your work if Blender crashes.
- **Save Versions** - how many versions of the file should Blender auto-save? (recommended 1 to 3 for space reasons)

Adjusting The Theme

Clicking LMB on the "Themes" button will show a drop-down menu in the top left of the user preferences window which can be used to select different themes. Below this are buttons labeled "Add" and "Delete" that can be used to (surprise!) add and remove themes. Note that the delete button does not appear for the default theme. The other controls that appear in the user preferences window while the themes button is active are to adjust the parameters that are specific to the current theme. Many more than the default 2 themes exist, check out the Blender Theme Repository at http://www.graphicall.org/themes/

More Undo Levels
The next thing that we want to do is take a look at the **Undo Settings**. By default, Blender will remember 32 of your previous actions in memory and allow you to undo all the way to that point. If you have a good computer with a lot of memory, you might want to increase that limit (up to 64), while if your computer is old and sickly, you may consider decreasing it to 10 or 20.

**step 1**
To show the **Undo Settings**, click the **Edit Methods** button.

**step 2**
The **Undo Settings** will then be visible. Use the **slider** to change the number of steps to any number (between 0 and 64). Keep in mind the amount of memory your system has, as we discussed above. Too many undo steps can slow your computer down, but the more you have, the easier it is to go back to a previous spot.

**Emulating the Numpad**

By default the Numpad keys control the 3D viewport, while the normal numeric keys change the view layers. Emulating the Numpad, in effect, allows the user to control the 3D viewport using the normal numeric keys on the keyboard. This replaces the default function of the keys, but does not affect the Numpad.

This is useful for computers/laptops where there is no physical Numpad available.

**step 1**
Navigate to the 'System & OpenGL' tab (outlined in blue) to open the menu.

**step 2**
Click on the 'Emulate Numpad' button (outlined in red) to enable it. If it is already in this darker shade of green, it is already enabled.

**Saving Your Preferences**
Finally, you may want to keep your preferences as the default preferences whenever Blender starts up, unless you prefer to set them up everytime.

**step 1**

Expand the **File** menu. To do so, click on the **File** button on the User Preferences window.

**Step 2**

Click on the **Save Default Settings** button in the **File** menu to save your preferences.

**Alternative**

Alternatively, you may press the **Ctrl+U** keys' combination to achieve the same purpose.

---

**Next Page: The Buttons Window**

**Previous Page: Blender Windowing System**

The Buttons Window

---

**Next Page: The 3D Viewport Window**

**Previous Page: The User Preferences Window**

**What's with all zee buttons?!**
The Buttons Window is one of the most powerful tools that Blender has. When you have objects selected in the 3D viewport, there will be a number of operations you can perform on the objects by pressing the buttons in the Buttons Window. For example, suppose you have modeled a person. People have different skin colors, eye colors, hair colors, and more, so you will create a material to make the person appear as you would like it to appear. The buttons window also handles sky color, render settings, animation, and a whole lot more.

There are many groups of buttons available to you in the Buttons Window. The buttons outlined here in red allow you to change the type of buttons that are currently being displayed. Click several buttons and notice the entire Buttons Window changes when you choose a different type.

You can only display one type of buttons at a time in your Buttons Window. This may seem like a limiting factor, but keep in mind that you can create as many different Buttons Windows with your interface as you would like and they can all be displaying different buttons, giving you quick access to anything you need to do.

**Mini-Windows**

You’ll notice that within the Buttons Window there are Mini-Windows (i.e., panels) such as those outlined here. Many manipulations can be performed with these windows, but for now we will only teach you the most important two.

The first thing you can do is click the top of the Mini-Windows with the LMB and drag them around. Try it! Also, try dragging and dropping them onto other Mini-Windows to make them join together (as tabs). You can separate the tabs into individual windows again by dragging the active tab over to an available space.

**Button Types**

**Logic Buttons**
Here we have selected the first buttons type, the Logic Buttons. We won't be using these buttons much for a long, long time. They are for use with the Game Engine.

**Script Buttons**

These permit connecting various events in Blender to scripts, thus extending Blender's functionality. Scripting itself is an advanced topic.

**Shading Buttons**

The Shading button set allows you to apply and manipulate colors and textures on your objects, and control lights and world settings. When you press this button (or the F5 key) you will see five additional buttons appear. These are for lights, general material settings, textures, radiosity, and world settings (handy for giving your renders a quick background). Pressing the F5 key will cycle through these buttons.

**Object Buttons**

You can press F7 to cause the Object Buttons to appear. It should be noted that these are not the same buttons that appear when you choose Object Mode in the 3D Window. Some tutorials may refer to pressing the F7 key to change to “Object Mode,” and some will say you should press the Tab key to change to **Object mode**.

The Tab key changes from **Edit Mode** to **Object Mode** in the 3D Window, and F7 changes the Buttons Window to show the **Object Buttons**.

**Edit Buttons**

These are buttons used to edit objects in edit mode. You can press F9 to get the edit buttons. To get to edit mode (In the 3D View window) Press **TAB**

**Scene Buttons**
Basically these are for rendering (taking pictures) and animating (making movies). We'll get back to these.

Next Page: The 3D Viewport Window
Previous Page: The User Preferences Window

The 3D Viewport Window

Next Page: Other Windows
Previous Page: The Buttons Window

The Blender 3D Viewport Window is where you will be spending most of your time. Blender 3D gives you 100% control of how you're seeing your world. Here are a few things you can do to learn how to use the 3D Viewport.

Rotating the view

Here you'll be able to fly around your 3D scene, rotating the planes as you see it. You'll see that the default object is actually a cube, and half of it lies above the X-Y plane, and half below it.

- Make sure the 3D Viewport window is active by placing the mouse pointer anywhere inside of it.
- Hold down the MMB (Middle Mouse Button) and drag the mouse from side to side and up and down.
- Hold ALT+LMB for the same effect (on some Window-managers on Linux this won't work, it'll only move the Window. You can change this behavior in most cases in the Window Manager's settings)
- To rotate so that "upwards" stays "upwards", use CTRL+ALT+SCROLL

NOTE: if you have your own setting for the MMB in mouse configuration, you must reset this to use the MMB as a real Middle Mouse Button (no Doubleclick or something else). Otherwise you must use the alternate ALT+LMB for the same effect.

- If you're using a tablet pc or a graphics tablet, holding the ALT key while dragging your pen around will achieve the same effect.
- The middle mouse button can be emulated on most Windows machines by simultaneously clicking the left and right mouse buttons. You'll need to set this up in the mouse settings in your Control Panel.

NOTE: for single button mouse users make sure that Emulate 3 Button Mouse is on in the View & Controls menu

It's a cube! Holding down the MMB is the quickest and easiest way to rotate your view and get a new perspective on things. Right now you're looking at the cube in what's known as Wireframe Mode. Pressing ZKEY (yes, on your keyboard, the 'Z' key) will toggle back and forth between Wireframe Mode and Solid Mode. Pressing NUM5 while NUM LOCK is on will toggle between Orthographic and Perspective (perspective looks more natural). This does not affect how your final product will appear, only the way you see your scene while you're creating it.

As you move the view around, you will see that there are three objects in your 3D scene by default:

<table>
<thead>
<tr>
<th>Object</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
</table>

18 de 140

10/09/07 17:13
<table>
<thead>
<tr>
<th>Icon</th>
<th>Camera</th>
<th>The camera location and rotation will determine what you will see at render time. To see in your 3D viewport what the camera will see, activate that window by pressing <strong>NUM0</strong> (remember the <strong>0KEY</strong> is different). You may need to make sure <strong>NUM LOCK</strong> is on on your keyboard. To switch out of the camera view, drag the <strong>MMB</strong>.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lamp</td>
<td>A lamp is simply a light source. It will not be rendered, but the light it provides to the scene will be rendered.</td>
<td></td>
</tr>
<tr>
<td>Cube</td>
<td>This object will be rendered. The camera should be pointing at the cube so that you will see it at render time.</td>
<td></td>
</tr>
</tbody>
</table>

Later you will learn more about how to use each of these.

**[NOTE: If you are using a keyboard which doesn't have a numpad, e.g. a laptop, see laptop commands below.]**

Holding the mouse over your 3D Viewport and pressing the **NUM7**, **NUM1**, and **NUM3** buttons will bring you back to perfectly aligned top, front, and side views respectively. Pressing **CTRL+NUM7**, **CTRL+NUM1**, and **CTRL+NUM3** will result in displaying the bottom, back, and *other* side views, respectively. Try each of these views, and watch the camera and light move around with respect to your new viewpoint (make sure your **NUMLOCK** is on. Otherwise, this will not work).

Similarly, holding the mouse over a viewport and pressing **NUM2**, **NUM4**, **NUM6**, and **NUM8** will rotate (by 15 degrees, which is customizable in the user preferences under "View & Controls") the view down, left, right, and up respectively.

The object the viewport orbits around can be changed to a new object by first selecting it with the **RMB** and then pressing **NUM** (the period key on the numpad) or **NUM** (the comma key on the numpad) on some keyboard layouts.

**[NOTE: selecting an object with the RMB will only work if your viewport is set to 'Object Mode'. Press the TAB key to toggle between 'Edit Mode' and 'Object Mode'.]**

Again, remember in Blender that there is a big difference between the number keys on your numberpad and the number keys along the top of the keyboard. For example, **NUM7** refers to the number 7 on the numberpad, while **7KEY** refers to the number 7 that's above the **YKEY** and **UKEY** on the standard US keyboard. If you accidentally pressed **1KEY**, **3KEY**, or **7KEY** during this step and it appears that everything disappeared, you have been changing the layer that you are viewing instead, press the **'key** (backtick key -- on US keyboards, this is the key to the left of the **1KEY**) to return to viewing all the layers, or press the **1KEY** to get back to viewing layer 1 which should have been originally active.

**[NOTE: the 1KEY through 0KEY and alt-1KEY through alt-0KEY switch layers. Hold shift to select more than one layer. 'KEY selects all 20 layers. Layers will be covered later.]**

**For laptop users: the num lock**
As previously mentioned in this tutorial, recent laptops (some PC and all recent Mac) have a set of regular keys (from M in the lower left to 9 in the upper right) with additional markings corresponding to a regular numpad. This behavior can be toggled with F6 or the key labeled num lock; this may require pressing FN+numlock key, for example FN+F11 on many notebooks. If nothing else works, or as an alternative, you can temporarily activate the numpad behavior by holding the FN key (lower left corner of the keyboard) and using the keys as a numpad until you release FN. This allows convenient use of the numpad camera controls without interfering with the normal use of that set of keys. Also you may pull down the User Preferences window, at the top (menu bar window), choose the "System and OpenGL" button, and click on "Emulate Numpad" to use the normal numbers as if they were the number keys on the pad (NUM0 == 0KEY at that point).

For simply rotating around the object, press Alt+LMB and drag.

If you envision using your laptop for this kind of work, or indeed any work involving numeric data inputting, it may be worth investing in a USB Numeric Keypad, as Blender uses the numeric keypad quite a bit. Prices range from between $15 to $20 for a basic keypad.

**Panning the View**

To pan the view, you have your choice of alternatives:

- **SHIFT+MMB**
- **SHIFT+ALT+LMB**

—and move your mouse. Alternatively, if you have a scroll wheel you can use SHIFT+Scroll to pan up and down and CTRL+Scroll to pan left and right.

You also have choice of keyboard alternatives:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+NUM8</td>
<td>NUM:</td>
<td>Up</td>
</tr>
<tr>
<td>CTRL+NUM4</td>
<td>CTRL+NUM6</td>
<td>Left</td>
</tr>
<tr>
<td>CTRL+NUM2</td>
<td></td>
<td>Right</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Down</td>
</tr>
</tbody>
</table>

Panning is an important skill to master; try it now.

Note that you must press **SHIFT before MMB**, otherwise your view will rotate instead of panning.

Also note, that in Windows XP the simultaneous pressing of **SHIFT+ALT** is sometimes used to switch the keyboard layout (for example QWERTY becomes AZERTY and vice versa). So when you find your keyboard layout all messed up, press **SHIFT+ALT** again to switch back to the correct keyboard layout. When desired, you can disable this key sequence: Windows Control Panel → Regional and Language Options → Languages (tab) → Details (button) → Key Settings (button) → Change Key Sequence (button) and uncheck the **Switch Keyboard Layout** checkbox.

Using **SHIFT+MMB** instead is recommended.

**Zooming the View**

Zooming in and out the view is also important. Again, Blender offers you several ways to do what you need to do:

- If your mouse has a scroll wheel, **scroll** it.
- **CTRL+ALT+LMB** and scroll up and down (not left or right)
Try these all out. Can you see this being useful?

Pro Tip

- If you can, find a mouse with side buttons. Anything like Microsoft's Intellimouse, or Logitech's Mediaplay, that have back/forth buttons, will do. Map those buttons to the MMB. This makes camera control feel a LOT more intuitive (plus it frees up a finger).
- Laptop users may also be able to configure the trackpad to act as a scroll wheel and middle mouse button while another mouse is plugged into the computer. Something like this can be achieved on a Mac by enabling "Use two fingers to scroll" in the Keyboard and Mouse preference pane.

Placing the 3D cursor

As with an ordinary text cursor (the vertical line that indicates where you type), the 3D cursor is the insertion point for new objects. It is represented as a red and white circle. It is just an 'editing point' in the 3D environment.

Click the LMB to the right of the cube, half-way between the edge of the window and the cube. The red and white circle (the 3D cursor) moves to where you clicked. Orbit the view again and notice that the 3D cursor marks a point in 3D space.

In any given rotational perspective, the set of possible 3D points where you can place the cursor is defined by the plane of your screen. If you're looking at the standard plane straight-on (meaning the standard plane is exactly parallel to your screen), you will place the cursor at the same height above or below the standard plane no matter where you click. Don't worry, you'll understand this point soon enough.

A more interesting experiment is to rotate the standard plane so the left end is farther away from you (and thus farther away from the plane of your screen) than the right. In this view, placing the cursor on the left will put it more toward the front of the plane, and placing it on the right will put it more toward the back.

Make sure the 3D View is in "Orthographic" mode by clicking "View" and selecting "Orthographic", and then try the following exercise: put the 3D cursor inside the camera (the pyramid-shaped object situated to the bottom left from the cube by default in top view). Be sure to view the scene from different angles to make sure the cursor is in fact inside. Now put the cursor back inside the cube. Make sure you are in object mode and that the '3d Transform Manipulator' is off. This ensures we can move the '3D Cursor' into the cube without selecting the cube by accident. To toggle the '3d Transform Manipulator', click the small index finger button in the 3d View Window/Bar, or use the keyboard, CTRL + SPACE. Toggle it a few times to get the hang of the difference.

If you're finding this difficult, try this: Press NUM7 to get to the top view and click on the position at which you want to place the 3D cursor. This will set two of the axes of the cursor precisely (X and Y), but the Z could be above or below the point you want. To fix this, press NUM1 to get to another view, and click again on the position to place the cursor at. With these two clicks, Blender will have all the 3 coordinates of the cursor position and you will have placed it exactly.
This exercise is important to get the feel for since it represents one of most fundamental actions involved when working in a 3D space from a 2D output device (your monitor). The most simple and straight-forward way in which to accomplish this exercise is as follows.

1. If you're not already in "Object mode", change to it. This can be changed through the pull down option in 3d viewport's window header bar or by hitting TAB to toggle between "Object mode" and "Edit mode".

2. It is also a good idea to make sure the "Use 3d transform manipulator" option is disabled. This should be represented by an icon, located on the 3d viewport's window header, that is shaped like a pointing hand. It can also be toggled by hitting CTRL+SPACE.

3. Hit NUM7 to change to top view. This can also be accomplished through the view menu.

4. Click between the cube and camera using the LMB.

5. Hit NUM1 to change to front view. You could optionally hit NUM3 to change to side view instead. It doesn't really matter which one (at least not for this exercise). The main point is that you need to be able to have 2 different views, that intersect each other, since we're working in a 3d space. For instance, viewing from top and then from bottom wouldn't be of much help to figuring how high up from the "standard plane" the 3d cursor is going to end up. Again, these views can also be selected through the view menu if you prefer that method.

6. Click between the cube and camera with LMB again.

7. Now you can use rotate the view around to see how it turned out.

For the part where you are to get your cursor into the middle of the cube, just follow steps 3 through 6 again. Except this time, you'll of course be LMB clicking inside the cube, instead of between camera and cube, during step 4 and step 6.

### Adding and Deleting Objects

Make sure you are in Object Mode. If not, press TAB. When an object is selected, the TAB key switches between the edit and object modes. A status bar at the top-right of the user preferences window will indicate the current mode by displaying 'Ob' or 'Ed' depending on the currently toggled mode. Another way to check which view you are in is to check the bottom of the 3D view.

Also, remember to reactivate the '3d Transform Manipulator' if it's still toggled off from the previous step.

Click RMB (Cmd+LMB on Mac) on the cube to be sure it's selected. Press the XKEY or DELKEY to delete it. A window will prompt you to erase object. Click "Erase Selected."

Make sure you have your cursor in the center of the cube before deleting it. See the previous section (in the reader's notes) if you don't know how to do this.

The reason for having your cursor in the center of the cube is that any object you add to the scene will be located where your cursor is.

To add an object, use the Add menu located in the menubar above your 3D View window. Why not add a monkey? Choose Add > Mesh > Monkey. [If you prefer the monkey to be facing frontwards, make sure to be in FRONT view (numpad 1) before adding the mesh]
A new object will be added, and you will be in what's known as Edit Mode. Press **TAB** to get out of Edit Mode, then **C**-**KEY** to center the screen on the cursor (where the monkey appeared). Press the **Z**-**KEY** to toggle the 3D Viewport between solid and wireframe modes. Zoom in and out for a closer look (scroll the **MMB, NUM+**, **CTRL+MMB**, or **ALT+CTRL+LMB**).

Next Page: Other Windows

Previous Page: The Buttons Window

Other Windows

Next Page: Learn to Model

Previous Page: The 3D Viewport Window

Just when you thought that you were getting the hang of the Buttons window and the 3D Viewport window, there are several more windows to learn about. Have no fear; we will gently guide you through this book and teach you about these windows as the need arises. For now, you only need to know one of them to be aware of your many options.

In the 3D viewport window, you'll see a button on the header all the way to the left that has a grid on it (if not, click on a window separator with the **RMB** or **MMB** and choose "Add Header"). That button allows you to switch window types. Click on it with the **LMB** and you will see a number of different window types to which you can change. Try some of the different window types; you will learn about their relevance in time.

Change the window back to the 3-Dimensional Viewport before moving on to the next tutorial.

Next Page: Learn to Model

Previous Page: The 3D Viewport Window

Learn to Model

Learn to Model

Next Page: Beginning Tips

Previous Page: Other Windows

The most basic part of 3D development is modeling, because this is where you create content, or 'models'. Creating 3D models is fun and sometimes challenging.

On the next page, you will take the first step in learning how to model. If you're excited, great! But if you're scared, don't worry; it starts out very easily. Give yourself time and patience; Pixar and Dreamworks will still be in business when you're ready for them!

Next Page: Beginning Tips

Previous Page: Other Windows

Beginning Tips

Next Page: Quickie Model
These are some basic tips that are often asked for in one form or another. Sometimes it is in reference to something completely different, but the basic methodology will work.

**Starting with a box**

Tutorials will often start with the default cube you see right after opening Blender. Here are two ways to reset the scene without quitting the application:

- **Ctrl-X** (while holding the Ctrl key, press the X key);
- or select *File -> New* from the menu.

Then, you will see a prompt box asking **OK?** under your mouse pointer. You can confirm that you want to erase your current scene by clicking **Erase All** (or move the mouse around to dismiss it).

The cube shows as a square in the 3D viewpoint. If you rotate the view with **MMB [Middle Mouse Button]**, you'll see it is actually a cube. It is selected by default.

**Note:** You can change the default scene (and return to a personalized one when clicking on **Ctrl-X**). Just modify the scene and arrange dialogs to suit your needs, then click *File > Save Default Settings*. Your current scene will now be used as the default when you click *File > New*. This is very handy indeed. To return to factory defaults, you can delete the file which contains those settings: **.B.blend** in your home directory. Starting from version 2.44, a new *Load Factory Settings* item is available from the *File* menu.

**Subdivision Surfaces**

Subdivision surfaces, or subsurfing, is a common technique in 3D modeling. It uses a mathematical process of simulating a curved plane in space according to the placement of control points, or vertices. What this means is that you can create an object with a smooth surface that is easily controlled by relatively few vertices.

**Adding a Subsurf modifier**

First, select the cube. Now choose the *Editing* panel set:

- click on the icon in the panel list:
- or press **F9**.

(If you're not seeing a bunch of windows in the button view panel, such as *Link and Materials, Mesh, Multitiers, Modifiers, Shapes*, then there's a good chance you haven't got the cube itself selected. It's all context-sensitive. So the *Editing* panel will display items pertinent to whatever you've got selected.)

Then find the *Add Modifier* button in the *Modifiers* panel (scroll with the mouse wheel to find it). Pressing this button will pop up a list of available modifiers, from which you should select *Subsurf*. Older versions of Blender had a *Subsurf* button in the *Mesh* panel.
You'll see a Subsurf panel appear inside the Modifiers panel (see picture), and the cube in the viewport will take on a rounded look as the modifier's default settings are applied.

**Tweaking the subdivision levels**

Among the options in the Subsurf panel you will find two important options: *Levels* and *Render Levels*. The higher you set *Levels*, the more times the smoothing algorithm will be applied, and the smoother your mesh will look. *Levels* only affects the cube in the 3D view; you must use *Render Levels* to specify the number of levels used when rendering.

Try increasing *Levels* from 1 to 2 and see how the cube deforms.

---

**But I want a box!**

Often, you will want to render with your model having some sort of subsurf turned on. Face it, most things in real life just do not have super sharp edges. It is often the case that objects in the real world will have some sort of softer edge on it (unless it is a knife edge, or a block of material that has been machined in the shop!). It is just this fact that is often overlooked by people starting out in 3D: CG can sometimes look *too perfect*, resulting from impossibly sharp, clean, and well defined edges.

This effect can be fixed by telling Blender that we want our cube to retain more of its original shape. We'll do this using a tool called **Edge Creasing**. Each edge in a Blender model has a crease value associated with it, which is used to tell the Subsurf modifier how sharp we want that edge to be. By default, all edges have a crease of 0, which is why our cube has lost all its sharp edges.

**Show subdivision surface's cage**
Now, remember what we said about the Subsurf modifier remembering our original cube shape? Press **TAB** to go into edit mode and you'll see that the original cube has come back to haunt us as a wire frame around the smoothed cube.

Before we fiddle with the creasing, set the Subsurf Levels up to **3** so you can see the effect more clearly.

**Choose an edge to crease**

In the 3D View, enter Face mode:

- by pressing **CTRL+TAB** (choose **Faces**);
- or clicking on this icon: △.

Select one of the sides of our wire cube with **RMB** (this can be done by clicking near the dot in the centre of the face). You'll know when it's been selected because the other faces will change colour to grey, and the face you've selected will be highlighted.

Note that, although we are in Face mode, it is really the edges that we are creasing; selecting a face is just a quick way of selecting its four edges.

**Crease selected edges**

Now press **SHIFT+E** and your mouse will be tied to the cube with a dotted line. Move it gently left and right to see the effect it has on the mesh.

Click **LMB** (left mouse button) to apply the changes, or **RMB** (right mouse button) to cancel creasing.

**Finally build a real box**

Either cancel the above edge crease or start from scratch to get back to our simple subsurfed cube. Then press the **A** key twice to select all faces. Crease them with **SHIFT+E** like before, until your cube looks like the image on the right.

Press **TAB** to cancel out of edit mode. Behold: your smooth cube.

**Note for beginning users**: where the SubSurf option makes your model a lot smoother, it also skews the base mesh you are calculating from. This can cause large amounts of duplicate vertices and in many cases, very messy meshes when they aren't being SubSurfed. Be very careful when using this option, as it can cause problems down the road if you're not watching your source mesh. This form of surface calculation can also skew skins, making an object very hard to skin later on.
is something you will not run into for a long while in this tutorial, but it is a concern to keep in mind.

Quickie Model

Selecting objects

Start with the default scene. It has three objects: a cube, a light source and a camera.

The cube is selected: pink outlines indicate the selected objects. You can select or deselect all objects by pressing A, the mouse pointer being inside the viewport. Select a single object by right-clicking on it (RMB or CMD+LMB on Mac).

AKEY - Toggles between selecting all or selecting none.

RMB - Selects a single object

Edit Mode

Right now you're in what's known as **Object Mode**. In **Object Mode** you can move the cube around the 3D environment in relation to other objects. With the cube selected, hit **TAB**. This puts you in what's known as **Edit Mode**.

**Note:** if instead of the cube you've selected the lamp or the camera, you won't be able to go into Edit Mode (Cameras and Lamps are edited differently).

In **Edit Mode**, you can change the shape and size of the cube. You could turn the cube into a puppy... or at least some day you'll be able to.

**TAB** - toggles in and out of Edit Mode of the selected, active object.

Selecting vertices
Now that you’re in Edit Mode, you have access to the individual vertices. Vertices are control points that you can connect to create edges and faces. Edges connect two vertices, and faces connect three or more vertices.

Vertices show up as pink dots when they’re not selected, and yellow dots when they are selected.

If all the vertices are yellow (selected), press AKEY to deselect all vertices (as seen above, this key toggles selection depending on the current mode). Go ahead and hit RMB (CMD+LMB on Mac) over one of the vertices and you should see it change to yellow, which means that it is selected.

If all you see is a big blue dot:

- Make sure the 3D transform manipulator is off; if not: depress the hand button on the header. You'll know it's off when the icon showing the 3D axes disappears.

If you cannot select a vertex:

- Hit the ZKEY and make sure you are in transparent mode.
- If you can't get the cursor over the vertex, adjust your mouse/trackpad's tracking speed to minimum.
- Make sure you're in vertex select mode: if you can only select faces or edges, either press CTRL+TAB to select Vertices or click on the Vertex select mode icon as shown below.

![Image](image1.png)

Now try rotating the view to see what's actually going on. You can hold ALT key and drag (while holding the left mouse button, move the mouse) to rotate your view. If instead, it moves the Blender window, drag with the MMB (without holding the ALT key).

**ZKEY** - Toggles between drawing the scene in wireframe and solid mode.

**CTRL-TAB** - Opens the selection mode menu.

**ALT+LMB or MMB** - Rotates the view

**Moving vertices**

With a vertex selected, press GKEY and move your mouse around: you should see the selected vertex moving with the pointer! Click the LMB to drop the vertex at the current spot, or press ENTER or SPACE key. While moving, you can cancel the move and drop the vertex back where it came from by pressing RMB (CMD+LMB on Mac).

You can also grab a selection using the mouse by holding RMB (CMD+LMB on Mac) and dragging it around: release the button at the desired spot. Then, clicking on the same button cancels the move.

Now use the MMB to rotate the view around to see the incredible impact your small change has undoubtedly made.

**GKEY** - "Grabs" the current selection and allows you to move it around with the mouse. Use LMB, ENTER, or SPACE to drop it in place. Use RMB or ESC to cancel the move.
Extra Practice

Video Tutorial on Edit Mode [1] (http://www.youtube.com/watch?v=LL-cYoTQ14Q)

Next Page: Quickie Render
Previous Page: Beginning Tips

Quickie Render

Next Page: Mesh Modeling
Previous Page: Quickie Model

If you haven't completed the previous tutorial, (the Quickie Model tutorial), do so now. Keep the same file open from that tutorial because we will be using it here.

A **render** is the creation of a picture from the camera's point of view, taking the environment's effects on your scene into account, and generating a realistic picture based on your settings. This first render will finish very quickly, but you'll find that as your 3D scenes become more complex, the rendering can take a very long time.

Rendering the current scene

Now that you've created your first model, undoubtedly you'll want to render it. Rendering is quick and easy. Make sure you're in object mode (press **TAB** if you're not), put the mousepointer in the 3D view window and press **F12**! On Macintosh OS X 10.4 and Gnome you can use **ALT-F12** to avoid the Dashboard and the Gnome Search Dialog, respectively.

You can also use the menu: **Render > Render Current Frame**.

Then, you can interrupt the rendering at any time by pressing **ESC** while the rendering window has the focus.

(If you've accidentally put the render window behind the main window, you can get it back several ways: you can use the Windows taskbar or, under Windows and most other operating systems, you can use **ALT+TAB (CMD-~)** (tilde) on Mac).

This is a relatively quick render. It can be cleaned up a bit but it will give you a good idea of what your model currently looks like. Feel free to use the **F12** key as often as you would like.

**Note:** If your cube is completely black, you may not actually have a light source in the scene. Some versions of Blender don't create a lamp (source of light) by default, and you'll need to add one. To add a lamp, enter object mode (**TAB**) and then press the spacebar while your mouse is over the 3D window. Select **Add > Lamp** which will give you a choice to add several different types of lamps. Remember to place the lamp in position where it is not inside the cube. This can be achieved using the **RMB** and pressing **G**.
**F12** - Starts the rendering from the active camera.

## Saving a render

At some point you will probably want to save your renders. Above the 3D Viewport, select *File > Save Image...* or just hit **F3**. A menu with a directory list will appear; the upper text line denotes the directory and in the lower one you type the name of the image, like "myfirstrendering.jpg". Note that earlier versions of Blender (before 2.41?) will not add the ".jpg" extension automatically if you leave it out.

**F3** - Opens the *Save Image* dialog (if an image has been rendered).

### Next Page: Mesh Modeling

*Previous Page: Quickie Model*

Mesh Modeling

### Next Page: Modeling a Simple Person

*Previous Page: Quickie Render*

Mesh modeling is the most common type of modeling in all of Blender-dom. If you did the Quickie Model tutorial, then you’ve already participated in mesh modeling. A mesh is simply a collection of vertices that define a three dimensional object. This exercise will further help explain mesh modeling.

1. Get a piece of paper and a pencil.
2. Draw three dots that are no more than 2.5 cm (about an inch) apart roughly in the shape of a triangle in the center of the paper.
3. Each one of these dots is called a **vertex**. (The plural of vertex is "vertices")
4. Now connect two of the dots with a line segment. The line segment is called an **edge**.
5. Draw two more edges so that the three vertices are all connected. You should now have a triangle drawn on the paper. Fill the triangle in. This is called a **face**.
6. Now draw another vertex (dot) on the paper. Connect it to two of the vertices (dots) you previously drew. You have another triangle. Fill it in to create another face.

Could you imagine doing this same sort of activity in 3D space? Essentially, mesh modelling is just that. The details are on subsequent pages in this tutorial.

You can keep filling up the paper with more vertices, edges, and faces if you want. You may want to try and create something interesting with your triangles. Blender also supports faces with four vertices (called quads), but faces with five or more (so-called N-gons) cannot be created.

*Look closely at a 3D video game character some time. Believe it or not, every part of the character is created from little triangles joined together (of course, the triangles are much harder to see in newer games using more detailed technology).*

When you're creating your models, remember that the whole point of having edges and vertices is so that you can have control points in 3D space for your faces. When the scene is rendered, only the faces will be seen. Any edges or vertices not connected to a face will not appear.
Modeling a Simple Person

Next Page: Detailing Your Simple Person 1
Previous Page: Mesh Modeling

Now, we will create a simple character, learning about selection and extrusion along the way. Extrusion is one of the most widely used modeling tools available.

Creating a New Project

Start with the default scene (as explained here). You should have your default beginning cube.

Reminder:

- Select the cube with RMB (CMD+LMB on Mac).
- Drag with the MMB (ALT+LMB on Mac) to have a look at the scene from different angles.
- Press NUM1 to go back to the front view.
- Toggle between Edit Mode and Object mode with TAB; the option button shown on the image below tells what mode you are in at any given time:

![Mode button/indicator]

Selection Methods

This section proposes five methods for selecting the default cube's top four vertices. The image on the right shows the view rotated a bit with the correct vertices selected.

Before we start, make sure the Limit selection to visible button is on. You'll only be able to find this button when you're in Edit Mode. It is not available in Wireframe Mode: hit ZKEY if you cannot find it. It'll appear on the bottom of the 3D View window, far right, just before the Render button.
'Note:' In Blender 2.42 for Mac OS X running on a MacBook, there is a display problem with the box and circle selections: the selection box and circle do not appear on screen (this is valid for both the Intel and the PowerPC versions).

The default is Object Mode. The cube should be selected; switch to Edit Mode then proceed.

### 1. Box Selection

This tool draws a square that you resize to frame the top four vertices (or dots).

1. Deselect all vertices by pressing the AKEY;
2. Press the BKEY to activate what is known as the Border Select Tool (it starts as two dotted lines).

Now, when you click and hold LMB and move the mouse cursor, a selection border will appear. When you release the mouse button, the vertices that are inside it will be selected. Select the top four vertices. If you made a mistake, you can start again after hitting A KEY to deselect the selected vertices. Make sure all the vertices are deselected (pink, not yellow) before trying the next method.

**BKEY** - Activates box-select tool.

### 2. Circle Selection

1. Deselect all vertices by pressing the AKEY;
2. Press the BKEY twice to activate the Circle Border Select tool.

A circle appears around the mouse cursor. You can resize the circle with SCROLL (the mouse wheel) or alternatively use the NUM+/NUM- or PgUp/PgDn keys.

- Select vertices either by dragging with LMB or clicking at several places.
- Deselect vertices by clicking or dragging with the MMB (or ALT+LMB).

To adjust your selection, note that SHIFT+RMB toggles a single vertex selection.

**Note:** If ALT + LMB moves the current window, then to deselect a vertex use CTRL+ALT+LMB or MMB instead.

The Circle Border Select tool will be active until you press RMB, ESC or SPACE.

**BKEY+BKEY** - Circle Select. If you press BKEY a second time after starting Border Select, Circle Select is invoked. Use NUM+ or NUM- or MW to adjust the circle size. Leave Circle Select with RMB or ESC.

### 3. Lasso Selection

Like many graphics programs, Blender 3D has a lasso selection tool.

1. Deselect all vertices by pressing the AKEY;
2. Hold **CTRL+LMB** and draw a circle around the vertices you want to select. Release the LMB when you're done.

To deselect with the lasso, use **CTRL+SHIFT+LMB**.

**4. One By One Selection**

You can also select the four vertices one by one.

1. Deselect all vertices by pressing the **AKEY**;
2. Select a single vertex with **RMB** (**CMD+LMB** on Mac);
3. Select additional vertices by holding **SHIFT** while pressing the **RMB**. Clicking again on a selected vertex deselects it.

**5. Face Selection**

In addition to those vertex selection methods, there is yet another option: on the right of your viewport header you can see selection modes. Choose the **Face select mode** (the triangle with a dot inside) and select the top face of the cube with the **RMB** (**CMD+LMB** on Mac). Then switch back to **Vertex select mode** (the four dots in a diamond formation). As you will see, all four vertices forming the top face are selected (this is also called "selection transformation").

Alternatively, with the mouse pointer in the 3D viewport, you can hit **CTRL+TAB** and select **Vertices** or **Faces** mode from the popup menu.

**Learning Extrusion**

The pictures below are in orthographic view. Depending on Blender's version, the default view is either perspective or orthographic. If you need to switch to the orthographic view, press **NUM5** (or choose it from the menu, as shown in the picture). Also remember that **NUM1** restores the front view.

**Region extrusion**

With the top four vertices selected (which will appear like the top two in your screen), hit the **EKEY**. Choose **Region** from the popup menu, then move the mouse: four -new- vertices attached to the four that were previously selected are moving around with the mouse pointer. You can drop them in place with **LMB, SPACE, or ENTER**.

**Notes:**

- In Blender 2.42a and 2.43a, you may not have the **Region** option; so just ignore choosing region and continue.
- If the menu doesn’t popup, you are probably in face selection mode. Move back to vertex selection mode by clicking the right icon.
- If the popup menu only presents the **Only Edges** and **Only Vertices** choices, you probably have not selected four vertices that make up a face. (It can also happen when some of the vertices are doubled: try selecting all vertices while in **Edit Mode** and hit the **WKEY** to show up the **Specials** menu, then choose **Remove Doubles**; it can also be accessed through the **Rem Doubles** under the **Mesh Tools** tab).
**EKEY - Extrude selection**

**Starting with a simple leg**

More likely than not, wherever you extruded the vertices to is not the right spot for this tutorial. Hit the **UKEY** or **CTRL+ZKEY (CMD+ZKEY Mac)** to undo your last edit. You should see just your original cube with the top four vertices selected.

Now hit the **EKEY** again. Again, choose Region. This time, as you're moving the extruded vertices around, hold down **CTRL** and you'll see that they will only move to certain spots. This is called **snapping**. The vertices **snap** predetermined positions. We'll talk more about snapping later, but for now, set the vertices in the right spot so that it looks like two cubes of equal size stacked on top of each other.

Repeat the process until you have five boxes of equal size stacked on top of each other. And that, my friend, is a very simple leg!

**Hint:** Don't stretch one box all the way to make the desired shape - You must create all stacked boxes in sequence, or you won't get the nodes (a more detailed mesh) that are required.

**And now, the pelvis**

Hit **AKEY** to deselect the current vertices. Select the four vertices in the upper right corner of the shape. You may want to rotate your view a little with the **MMB** to see them all. Then extrude twice to the right.

**Drawing the other body parts**

The same trick is repeated over and over to build the rest of our simple body.

You may want to switch to Face select mode to select the four vertices of a face with a single click. This way the extrusion tools will automatically extrude a region, so you won't have to choose the **Region** option each time you extrude a face.

At this point your model might get too big to fit in your view. You can pan the view by:

- either holding **CTRL** and pressing NUM4, NUM8, NUM6, NUM2,
- or holding **SHIFT** and dragging with **MMB**.
Now, check that all is well: toggle on solid mode by hitting the **ZKEY** and examine every body side. If some faces are missing, it’s easy to fix. To create a face from four vertices, select them and press the **FKEY** (or choose the *Mesh → Make Edge/Face* menu from the viewport header).

### Adding the head

**Important note:** make sure you’re still in Edit Mode (pictured) when adding the head. If you’re not, the head and the body will not be part of the same object and changes on the body won’t affect the head, which is required in the next section.

Select a point just above the top of the neck using the **LMB**: the red and white circle is the cursor. To adjust the cursor’s position, switch between the top, front and side views (using the **NUM7**, **NUM1**, and **NUM3** key respectively). You can also use the snap tool: press **SHIFT+S** to bring up the snap menu and select *Cursor → Grid*.

Once you’re happy with the position, press the **SPACE** key to bring up the popup menu. Select *Add → Icosphere*. In some Blender versions you may have to choose the subdivision number. Just click **OK**. You should now have a small sphere at the top of the body. To make it more proportional to the body, resize it with the scale tool:

- either select *Mesh → Transform → Scale* from the viewport menu,
- or just press the **SKEY**.

If you deselect the head and then decide that you want to move it or resize it again, select one vertex of the head, then click *Select → Linked Vertices* (or use **CTRL+L**). All the head’s vertices will then be selected again, and none of the body’s. Then press **GKEY** to grab and move the head, or **SKEY** to resize it. Hold down **CTRL** as you move it around if you would like it to snap to the grid.

Don’t forget that you are in 3D; use the MMB to move your point of view around to make sure that the head really sticks in the neck.

*Note:* to make your character more realistic, add Blender’s monkey head instead of the icosphere. The path is: **SPACE** → *Add → Monkey* (don’t forget to do it in Edit Mode).

### Summary: Keys & Commands

These are the keys and commands used on this page:

<table>
<thead>
<tr>
<th>Key</th>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Key Combination</td>
<td>Function</td>
<td></td>
</tr>
<tr>
<td>-----------------</td>
<td>----------</td>
<td></td>
</tr>
<tr>
<td>RMB or CMD+LMB</td>
<td>Select an object</td>
<td></td>
</tr>
<tr>
<td>NUM1</td>
<td>Go to front view</td>
<td></td>
</tr>
<tr>
<td>TAB</td>
<td>Toggle between Edit Mode and Object Mode</td>
<td></td>
</tr>
<tr>
<td>BKEY then LMB and drag</td>
<td>Box selection</td>
<td></td>
</tr>
<tr>
<td>AKEY</td>
<td>Toggle between Select All and Select None</td>
<td></td>
</tr>
<tr>
<td>BKEY BKEY (pressed twice) then LMB and drag</td>
<td>Circle selection</td>
<td></td>
</tr>
<tr>
<td>CTRL+LMB and drag</td>
<td>Lasso selection</td>
<td></td>
</tr>
<tr>
<td>RMB then SHIFT+RMB</td>
<td>One-by-one selection</td>
<td></td>
</tr>
<tr>
<td>(click the vertex/edge/face selection buttons)</td>
<td>Change the selection mode</td>
<td></td>
</tr>
<tr>
<td>CMD+TAB (CTRL+TAB in Windows)</td>
<td>Change the selection mode</td>
<td></td>
</tr>
<tr>
<td>select vertices then EKEY</td>
<td>Extrude</td>
<td></td>
</tr>
<tr>
<td>CTRL while extruding</td>
<td>Enable snapping</td>
<td></td>
</tr>
<tr>
<td>MMB or ALT+LMB</td>
<td>Rotate the 3D view</td>
<td></td>
</tr>
<tr>
<td>ZKEY</td>
<td>Toggle wireframe/solid view</td>
<td></td>
</tr>
<tr>
<td>FKEY</td>
<td>Make Edge/Face from selected vertices</td>
<td></td>
</tr>
<tr>
<td>NUM3</td>
<td>Side view</td>
<td></td>
</tr>
<tr>
<td>SHIFT+SKEY</td>
<td>Snap cursor or selection to the grid</td>
<td></td>
</tr>
<tr>
<td>GKEY</td>
<td>Grab the current selection and move it</td>
<td></td>
</tr>
<tr>
<td>ZKEY (or XKEY or YKEY)</td>
<td>Constrain motion to the Z (or X or Y) axis</td>
<td></td>
</tr>
<tr>
<td>SKEY</td>
<td>Change the scale (size) of selection</td>
<td></td>
</tr>
<tr>
<td>SPACE</td>
<td>Brings up the menu</td>
<td></td>
</tr>
</tbody>
</table>

**Next Page: Detailing Your Simple Person 1**
*Previous Page: Mesh Modeling*

Detailing Your Simple Person 1

**Next Page: Detailing Your Simple Person 2**
*Previous Page: Modeling a Simple Person*
This tutorial uses the simple person model from the previous tutorial. If you didn't do it, go back and do it now---or find it pre-made just for you here (http://www.nusoy.com/blender).

If your model does not appear to be solid, it is currently being drawn in wireframe mode. For this tutorial, you need it to be drawn solid. Return to Object Mode (TAB) and press the ZKEY to see the model in solid mode.

**Subsurfaces**

You should already have the "Editing Panel" displayed in the "Buttons Window". If not, click on the "Editing" button (shown pressed in the image on the right) or press F9 to have the Editing Panel displayed. On Macintosh OS X, use CMD+F9 to avoid engaging the Exposé window effects. Note that the "Editing panel" is a different thing from "edit mode"; don't confuse them. Depending on whether you're in "edit mode" or "object mode" the "Editing Panel" will display different tabs. With the object (your man) selected (RMB) press TAB to view how the available buttons in the panel change.

First of all select the model. We're going to turn on subsurfaces, or Subsurf.

To enable Subsurf, you must go to the "Buttons Window" → "Editing Panel" (F9) → "Modifiers" subpanel → click "Add Modifier" → "Subsurf" from the list. You should immediately see your model change to look more round and less edgy. New options for "Subsurf" are now shown in the Modifiers subpanel. You may also perform this action by pressing SHIFT+OKEY while in object mode.

Note that the "Modifiers" subpanel will be displayed in both "edit mode" and "object mode".

To enter a value on a bar you can:
- click on the left or right arrows on either side of the bar to add or subtract a unit.
- click in the middle of the bar and enter a value with the keyboard.
- Hold down LMB and move your mouse to the left or right while hovering the mouse cursor over the number.

What just happened? Each face was just divided into four smaller faces that are progressively angled, which has helped soften the sharp edges of the model where faces touch each other. Click the horizontal bar labeled "Levels" and change the value to '2'.

The model will change again because each of your original faces is now divided into 16. If you change the value to '3' each plane will be divided to sixty-four smaller planes, but don't do it unless you've got a computer that you're sure can handle it (newer computers should be able to handle it pretty easily). Note that subdivisions work with base 4, i.e., Level: 1 yields $4^1 = 4$ divisions; Level: 2 yields $4^2 = 16$ divisions; Level: n yields $4^n$ divisions.

Notice the other bar labeled "Render Levels" below the "Levels" bar? That controls how many subdivisions to do at rendertime, while the value we've been changing handles the number of subdivisions while working in Blender. Before moving on, set the first subdivisions value to 2 and the rendertime subdivisions to 3.

A Modifier is defined as the application of a "process or algorithm" upon Objects. They can be applied interactively and non-destructively in just about any order the user chooses. This kind of functionality is often referred to as a "modifier stack" and is found in several other 3D applications. The x in the upper right of the subsurf modifier will remove the modifier from the modifier stack. The arrows at the left of the x will move the modifier (and its effects) higher or lower in the modifier stack.
The Optimal Draw button removes the extra wireframe lines which display as a result of having additional geometry. This button is especially useful to clarify and speed up the display of densely subdivided meshes. The blank roundish button towards the top of the Modifiers panel, just to the left of the up and down arrows, applies the modifier to the editing cage. Press this button now to remove the translucent, boxy cage, so you can edit the smooth mesh in the next parts of the tutorial. [EDIT: You actually need the boxes for the next section of the tutorial, so DON'T press this button yet, just note its function and remember it for later]

**Note:** You have the option of pushing the button to see its effects, but do NOT keep the button pushed down before the next step. Editing the body of the simpler person will not allow you to edit the simple person as the instructions explain. And avoid use of the apply button unless specified otherwise.

Troubleshooting: If one or two of your sides don't subsurf, try selecting all vertices while in edit mode and typing **W**key to display the "specials" menu, select **Remove Doubles**. Another way to remove doubles is to select your object, press **A**key to select all vertices, and click "Rem Doubles" under the "Mesh Tools" tab in your buttons window. You can also change the limit of how far Blender should look for vertices that are close together.

Unless you have a good reason, don't press Apply on a Subsurf modifier; if you do, the modifier will be applied to the mesh. While this is useful for some modifiers, for Subsurf this will add many extra vertices and is generally not needed.

**DO NOT APPLY THE MODIFICATION OR YOU WILL NOT BE ABLE TO CONTINUE TO THE NEXT PART OF THIS TUTORIAL**

**Noob Note:** You can undo this modification by pressing CTRL+Z twice.

For a complete modifiers documentation go to http://wiki.blender.org/index.php/Manual/PartII/Modifiers

For a complete subsurf modifier documentation go to http://wiki.blender.org/index.php/Manual/PartII/Modelling/Modifier/SubSurf

For a complete subsurfaces documentation go to http://wiki.blender.org/index.php/Manual/Subsurf_Modifier

**Smooth Surfaces**

Subsurfaces do a good job of smoothing out objects and creating good curved surfaces. However, even with subsurfaces the model does not appear completely smooth; at this point it even appears scaly.

If your person is in wireframe view, hit **Z**key to change it to solid view. In Edit Mode, hit the **A**key once or twice so that all the vertices are selected (if you're not in Edit Mode, select the object and press **TAB**). Find the button that says "Set Smooth" (the center-right button inside the "Links and Materials" subpanel in the Editing [F9] panel) and click it. You will see the Blender smooth out the rough edges where faces were touching before. Next to it is the button labeled "Set Solid." Click it as well. You will see the simple person go back to the solid rendering. The simple person looks better smooth, so click the "Set Smooth" button again. (more information about this at [2](http://en.wikipedia.org/wiki/Flat_shading) and [3](http://en.wikipedia.org/wiki/Gouraud_shading)).

You need to keep this file open for the next several tutorials. Move on to the next page.
This tutorial uses the simple person model from the previous page. If you didn't do it, go back and do it now or find it pre-made just for you here (http://www.nusoy.com/blender).

**Starting with the right modes**

Up to this point, you've been selecting vertices and manipulating them. In the first chapter, we touched on selecting faces. In fact there are three selection modes: vertices, edges and faces.

Make sure you're in:

- **Edit Mode** (TAB),
- **Solid Mode** (ZKEY),
- and **Edges select mode**: press CTRL+TAB, a menu will come up where you can choose Vertices, Edges, or Faces, then choose Edges. The three selection modes can also be selected with the statusline buttons shown on the right.

**Note for KDE users (not 3.5.6):** CTRL+TAB changes the desktop so you will have to use the statusline buttons instead. (Older versions of Blender do not have this feature. Instead, just select all vertices connected to the edge you want to select).

It is important to remember that depending on the selection mode you're in (vertices, edges, or faces), moving or otherwise manipulating your selection will cause connected vertices, edges, and faces to be moved as well. This is because you cannot separate faces from edges or edges from vertices.

**Scaling with axis constraint**

We want to position the 3D cursor between the hips of the simple person, then use that cursor for scaling.

First, make sure:

- everything is deselected (AKEY or Select → Select/Deselect All from the viewport's menu),
- you're in perspective mode (NUM5 or View → Perspective menu),
- the manipulator is on (switch on the hand button).

Our goal is to place the cursor as shown in the picture below, that is at the center or the two selected edges (instead of snapping it to the grid as we did when adding the head):
**Troubleshooting:** if you do not see the cubes around your person, make sure you are in Edit Mode as explained in the introduction. In case you played with the Subsurf modifier, you may have to uncheck the Apply modifier to editing cage during Editmode box, just on the left of the Move modifier up in stack button (^). If it still doesn't work, try deleting the Subsurf modifier (the X on the right, above the Apply button) and adding it again (Add Modifier -> Subsurf).

**Selecting two hip edges**

By default, when editing in solid mode, the vertices, edges and faces that are on the back side of the model are not visible or selectable. This can be toggled by clicking the *Limit selection to visible* button (pictured). Toggle it on and off a few times and observe how the edges of the wire cage appear and disappear as you click. **Disable it for now,** to show the hidden edges.

Now, select one of the edges just above the hips of our person, where the legs connect to the torso: an edge of one of the cubes to the left or right of the model's pelvis (RMB). Notice that the 3D transform manipulator jumps to the edge you selected. Now select the edge on the other side of the pelvis (SHIFT+RMB). The 3D transform manipulator should jump halfway between the two edges.

**Troubleshooting:** If, instead, it jumps to the second selected edge, change your Rotation/Scaling Pivot to Median Point.

**Scaling the hips**
Choose the scaling manipulators: **CTRL-SPACE** and select Scale (or use **CTRL-ALT-SKEY**). Since the Transform Orientation is set to global, the manipulator's orientation is the same as the world's orientation shown in the lower left corner of the 3D View pane. Make sure Proportional Edit Falloff is set to Off (as shown). The axes are colored R-G-B for X-Y-Z, i.e., the X-axis is red, the Y-axis is green, the Z-axis is blue.

It's important to note that in addition of the global XYZ axes, each individual object has its own XYZ axes. We'll get into that in the next section.

Grab the red cube-shaped handle and drag it with LMB to symmetrically widen up the selection along the selected X-axis. While scaling, press CTRL to snap to the grid or ESC to abort the current manipulation. When it comes to scaling in Blender, 1.0000 means 100%, 0.6000 means 60%, and so on. Scale up to 2.

**Note:** you cannot scale along the Z-axis, as the current selection's Z-dimension is zero — if you want to symmetrically lift the hips, switch back to Translate Manipulator Mode (**CTRL+ALT+GKEY**).

### Drawing the armpits

We'll now use the 3D cursor instead of the selection's center: bring up the Mesh → Snap menu (**SHIFT-SKEY**) and select Cursor → Selection (**KEY4**). This will move the 3D cursor to the location of the manipulator.

Now, set the 3D Cursor as Rotation/Scaling Pivot. Since the 3D Cursor was positioned to the selection's center, the manipulator's behavior stays the same.

Select the two edges under the arms where they connect to the torso. This time, the manipulator does not jump to the selection but stays at the 3D cursor.

Make sure you are in Scale Manipulator Mode (**CTRL+ALT+SKEY**) and form the armpits using the square handles on the manipulator: says 2.0 along X and 1.1 along Z.

**Notes:**

- It is easier to select the edges by rotating the view around the world's X-axis with View → View Navigation → Orbit Down (or **NUM2**).
- For better visual comparison to the width of the hips, switch to View → Orthographic (or **NUM5**) before scaling along the X-axis (the red one). You can now scale along the Z-axis (the blue one), as there is a distance along Z between the selection and the pivot.

### The belly and the chest
Now, deselect all and select the belly cube (use one of the methods described here). This time, use the Scale Tool instead of the scaling manipulator:

press the **SKEY** to choose the scale tool;
and then **SHIFT-ZKEY** to lock the Z-axis. Now, the scale tool is constrained to the X and Y axes (i.e. the selection is not scaled along the Z-axis) and those axes are drawn through the pivot in a bright color;

scale the belly using **LMB**.

Continue with selecting different sections of the torso and scaling them to your liking, exercising above scaling methods.

*Note that just like you can constrain scaling to the X, Y, or Z axis by pressing XKEY, YKEY, or ZKEY, you can constrain movement to an axis as well. Press the GKEY and then press the appropriate axis key. As you work on the arms, be sure to use the different viewing angles so everything is correct (**MMB** to rotate, **NUM1** for front view, **NUM3** for side view, **NUM7** for top view). Also, be sure to use **CTRL+ZKEY** to undo if you mess something up.**

## Modeling the arms

When you've got the basic shape of the torso, move on to the arms. We'll start by making him holding his hands up.

First, make sure you're in **Edit Mode**; if not, select the figure and press **TAB**. Also, make sure you are in **Vertex select mode** (**CTRL+TAB**). Now, select the 8 vertices at the end of one arm (the hand cube).

Press the **XKEY**, and choose **Vertices** in the popup menu. Suddenly the box disappears, and at the end of the arm, there's a hole! Don't panic. We'll fix that in a moment.

At this point, your person should look like this one:
Select the top four vertices of the last "arm box" (by pressing **BKEY** and dragging the box around the 4 vertices of the cube) and extrude them up three times by pressing **EKEY** and **CTRL** to create three boxes the same shape.

**Newbie note:** this looks more natural if you extrude 1 square using **Rotate Manipulator Mode**, and 2 squares using **Scale Manipulator Mode**.

We'll now to fix the hollow elbow. Simply select the four vertices at the gaping hole (turn on **Limit Selection to Visible** mode to make it easier), and press:

**SPACE → Edit → Faces → Make Edge/Face** (or **FKEY**)

Notice that the hole was covered by a face.
Then, choose the **SPACE → Edit → Faces → Set Smooth** option to make it a smooth face.

Do the same with the other arm. Make sure to deselect all the selected vertices from the first arm (**AKEY**). It is important to follow the steps in the same order to end up with identical arms. If you're having troubles with the other arm, you can undo all the arm work and redo every step simultaneously on both arms.

**Troubleshooting:** if the surface of the model swells out where you added the face to cover a hole, use **CTRL-Z** to undo the face. Try selecting all the hole vertices (or even select the whole figure) and choose: Mesh → Vertices → Remove Doubles from the viewport menu, and try to add the face again. If it still looks strange, then without undoing it, select the whole figure with the **AKEY** and use **CTRL-N** to recalculate the normals.

## Modeling the legs

First switch to the **Face select mode** (choose from the **CTRL+TAB** menu, or click the triangle icon).

Select the two bottom faces of the feet (the soles): use **RMB** and hold down **SHIFT** when selecting the second one. Each face comes with a small square denoting the face center that turns orange when selected, while the outline is highlighted in yellow.

Then, subdivide them: **SPACE → Edit → Edges → Subdivide** (or, from the viewport menu: **Mesh → Edges → Subdivide**).

Now, switch to the **Edge select mode** (**CTRL+TAB**) and clear the selection (**AKEY**).
Select the bottom front edges making the toes (RMB, then **SHIFT+RMB**). You should end up with four edges selected.

Switch to the side view with **NUM3** and press the **GKEY**. Now move the selected edges away from the legs as far as you like: drag with **MMB** for orthogonal movement and drop them with **LMB**.

Pressing the **YKEY** will also restrict movement along the Y-axis only, however orthogonal movement can be easier.

Congratulations! We now have feet!

---

**Modeling the head**

When you've got an acceptable shape for the legs, you should do something about that head. A little too spherical, isn't it?

- Press the **AKEY** to clear your selection.
- Place the mouse cursor over the head and press the **LKEY**: this selects the closest edge, face, or vertex, as well as all edges, faces, or vertices that are linked to it. The faces for the head and the faces for the body pass through each other; however, none of the vertices in the head are linked to any of the vertices of the body via an edge or a face.
- Place the 3D cursor in the middle of the head (**SHIFT-S, Cursor → Selection**) or just set Median Point as Pivot (**CTRL-**). Then press the **SKEY** and scale on the Z-axis (blue handle of the 3D manipulator) in order to get a better shape. I think 1.5 is enough. Without using the 3D manipulator, remember that you need to press the **ZKEY** to restrict the scaling to the Z-axis only (in both cases, **CTRL** snaps the values).
- After elongating the head, you may find that it is too low or too high. To fix this, press the **GKEY** (to move it) and the **ZKEY** (to restrict the movement to the Z-axis). Play around with it a little until you like the result.

**Note**: another course of action would be to put the cursor (and thus the 3D transform manipulator) at the underside of the head. That way the neck will keep the same length, while you can scale the head at will.

---

**Next Page: Creating a Simple Hat**

**Previous Page: Detailing Your Simple Person 1**

Creating a Simple Hat

**Next Page: Putting Hat on Person**
This tutorial uses the simple person model from a previous tutorial. If you didn't do it, go back and do it now—or find it pre-made just for you here (http://www.nusoy.com/blender). Alternatively, if you just want to make the hat without putting it on a person at the end, you can go ahead and do that without having completed the other tutorial.

Adding an object

The first step to hat-making is editing a simple mesh circle.

Setup

- use the orthographic view (NUM5);
- get a sideways view of the model (NUM3);
- if you're starting with the simple person model, pan the view (SHIFT+MMB) to place the scene center a good distance above the simple person's head;
- make sure you're in Object Mode (TAB) to add the hat as a separate object.

Now, place the 3D cursor on center of the view (LMB) and snap it to the nearest grid node (SHIFT+SKEY then Cursor → Grid).

Create a circle

Do SPACE → Add → Mesh → Circle, with 12 vertices. In the latest Blender version the default is 32 vertices but you may use the arrows to set it back to 12: click the arrows to change, or click and drag left or right, or click on the number and type a new one.

After the circle is added, you will automatically be placed in Edit Mode. The end result should be something like the picture (if you're in vertex mode). If the circle's too small, you may want to zoom the scene.

We now have a selected circle. In the bottom left corner of the viewport, you should see the name of the selected object: Circle.

Deleting a selection

Switch to Edge select mode (CTRL+TAB) and have only the three edges selected as seen in the picture (AKEY to deselect all, then click RMB; hold down the SHIFT key when selecting the second and the third ones).

Delete these edges by pressing XKEY → Edges.

Creating the hat profile
Now switch back to Vertex select mode
(CTRL+TAB → Vertices), and try to make the line
to look something like what's shown to the right:

- **AKEY** to select/deselect all vertices
- **RMB** to select/deselect a vertex
- **SHIFT+RMB** to select/deselect multiple
  vertices (or **BKEY** to use the Border select
  tool)
- **GKEY** to move a selection (hold down **CTRL**
  while moving to use snapping)

**Notice:** Be sure that the Proportional Edit Falloff button is off
(orange is on; gray is off). You can
toggle this control with the **OKEY**. We'll learn more about proportional edit in a later tutorial, but for
this step, it should be off, meaning that you have full control on each vertex separately.

**Spinning the hat**

To make a hat out of this curve, we'll use the Spin tool to create a
surface of revolution.

**Note:** the Spin tool, like some other Blender operations, works
differently based on the rotation of the 3D view you are on: it will
rotate the polyline around the axis that is perpendicular to the
plane of the active 3D view and that passes through the 3D cursor.

**Setup**

Make sure the 3D cursor is placed exactly at the rightmost vertex:

- select the rightmost vertex (**RMB**),
- then choose **SHIFT+SKEY** and Cursor → Selection.

Then select the curve to spin and choose the rotation axis:

- select all the curve vertices using your favorite method (**AKEY, BKEY, etc...**),
- choose the top view (**NUM7**).

**Spin the curve**

Switch to the Editing panel (**F9**, or **CMD+F9** for Mac users). In the Mesh Tools tab, locate the Spin,
Spin Dup and Screw buttons and fill the fields as indicated below:

| Degr: 360  |
| Steps: 12  |
| Turns: 1   |

**Noob Note:** There are 3 similarly named tabs [Mesh], [Mesh Tools] and [Mesh Tools 1]. You want to
look under [Mesh Tools], not the others.

Now hit Spin to create a surface of revolution around the Z-axis.
**Troubleshooting:** in case you have more than one 3D window open, your mouse cursor may change to a "?” sign: additionally click on the window in which you want to perform your rotation (the top view window).

**Note:** the rotation axis is parallel to the Z-axis because we chose the top view.

**Final touches**

We’ll now extrude the hat front to make an eyeshade:

- use the top view (NUM7),
- choose **Edge select mode** (CTRL+TAB),
- then select the four frontmost edges of the hat (RMB for the first one, and SHIFT+RMB for subsequent ones),
- finally extrude the selection (EKEY → **Region**): drag them down; you can press the YKEY to limit the extrusion to this very direction.

**Now it's time to subsurf**

In the **Editing** buttons, from the **Modifiers** panel choose: **Add Modifier → Subsurf**. Rotate the view around and you will notice that your hat has a "split at the seam". Because of the **Spin** tools options we chose, there are several pairs of vertices that share the exact same spot in 3D space which produce those subdivision seams. To solve this issue: in **Edit Mode** select all vertices (AKEY) then choose **WKEY → Remove Doubles**.

Now all our seams will display correctly, since you’ve removed the unnecessary overlapping vertices in the mesh. Whew! You now have a lovely new hat! Pat yourself on the back, good work! You can neaten it up a little more by hitting **WKEY → Set Smooth** to give it a nice smooth finish.

If you do not remove doubles, your hat will look like this:

Keep this simple person/simple hat file open because you’ll need it in the next tutorial.

**Next Page: Putting Hat on Person**

**Previous Page: Detailing Your Simple Person 2**
Putting Hat on Person

This tutorial uses the simple person model and hat from a previous tutorial. If you didn't do it, go back and do it now---or find it pre-made just for you here (http://www.nusoy.com/blender).

Once you have created the hat, and are satisfied with the 'form' of it, now it's time to change the rotation, location, and size of the whole object in 3D space. Switch to Object mode and select the hat.

Rotation

First, change the rotation of the object. To change the rotation of the hat, press RKEY. Now you can move your mouse around to change its rotation. It will rotate on a different axis depending on what viewpoint you are rotating it from. The rotation axis will always be perpendicular to your viewpoint, so it looks like you're rotating a 2 dimensional image. Press the RMB, or ESC, to bring you back to the original rotation.

When you press the RKEY, you are actually entering a rotation mode that can be altered by further key strokes. For instance, pressing the YKEY after the RKEY will rotate the hat about the Y-axis.Pressing the ZKEY will rotate it about the Z-axis, and the same goes for the XKEY. By pressing the ZKEY, YKEY, or XKEY just once, you will rotate the object in relation to the scene. If, however, you press the same key twice, it will rotate in relation to its origin, giving you an XYZ arrow pointer that displays the angle of the origin.

Important to note is that the shape will rotate around its origin, or center point, indicated by a small, pink dot that was created when you created the shape. It should be in the center of your vertices, but if it isn't, there are a couple of ways to get it back. One is to go into edit mode, select all vertices, and move them around the center point. Another is use the LMB to put the cursor where you would like the center point, go into object mode and press the "center cursor" button in editing panel (F9). Or you could hit SHIFT+SKEY, select Selection → Center. The final method is to click on the Editing button (F9) and click either the Centre or Centre New button. The Centre button will automatically move the object's vertices to the dot, and the Centre New button will move the dot to the center of your vertices.

Hit the NUM1 on the numberpad to get the front view. Hit the RKEY, followed by the ZKEY and move your mouse. This will rotate the hat perfectly around the Z-axis. Hold down the CTRL button so it only rotates in 5 degree increments and click the LMB when you come to the correct position. (Do this with the X- and Y-axis if needed).

Alternatively, you can click and drag the LMB in a circular motion around the object, to "draw" an arc. This is called a mouse gesture and has the same effect as pressing the RKEY.

Location

After you have the hat in proper rotation, you will want to move it to the proper position. You do this the same way you move an individual point. Press the GKEY (for "grab") and move the mouse. Pressing the X, Y, or Z key will have a similar effect as it did with rotation, restricting the movement to the X, Y, or Z axis. Pressing the MMB while moving will also restrict the movement. Pressing the RMB will reset the object to its original position, without making any changes.

Alternatively, you can click and drag the LMB in a straight line to activate moving the object. This is another mouse gesture and the same as pressing the GKEY.
Size

You may discover that the hat is too big, or too small, for the person we created. No problem, we'll just change the size. You do this by pressing the SKEY, for "scale". You can scale the object just along its X, Y, or Z axis, making it thinner, shorter, fatter, or wider.

Alternatively, you can click and drag the LMB back and forth from the object to scale it. Start at the object, move your mouse a little away from it, then drag back to the object to draw a line and go back over it. This is, you've guessed it, a mouse gesture as well and the same as pressing the SKEY.

So, just remember:

- **SKEY** is for Scale mode
- **RKEY** is for Rotation mode
- **GKEY** is for Grab (Move) mode

And, once in a mode:

- **XKEY** limits to the X-axis (width)
- **YKEY** limits to the Y-axis (height)
- **ZKEY** limits to the Z-axis (depth)
- **pressing XKEY, YKEY, or ZKEY** a second time will change the reference of that limit from your current view (default) to the center of the object.

Putting it on

Once you have the hat in position, you will want to "put it on". To do this, we make the man the 'parent' of the hat. What this means is that, when we move the hat, we just move the hat. However, when we move the man, we move the man AND the hat.

Save your work before doing the following because the program may crash and be unusable if you accidentally press PKEY instead of CTRL + PKEY. (Note: PKEY starts the Blender game engine. If you do accidentally press PKEY, ESC should stop it and bring you back.)

Make sure that you are in object mode and the hat is selected. Hold down shift and select the man by pressing the RMB. Both the man and the hat should now be selected. Hold down CTRL and press PKEY and select "make parent" in the confirmation box to make the man a parent to the hat. Now you
will see a line from the hat to the man, indicating that the man is the hat's parent. If you move the 
man, the hat will move along with him. Otherwise if you only move the hat, the man will stay at its 
place. Don't forget to pay attention to the order of your selection. The first selected object becomes 
the child of the second one.

[Noobie Roy comments:]

If you've been struggling to get the head to connect to the body, here's your chance to rectify this.

Select Object Mode.

RMB click on the head to select it.

Then hold the SHIFT key and RMB on the body to select that.

Now press Space... Object... Join Objects (or CONTROL-J). This allows you to join the meshes of two 
selected objects.

---

Now that we've created our simple person, it's time to give him somewhere to go. In this tutorial we'll 
create a mountain range using a few simple, and handy tools.

Start off with a new project, using File → New, or hit CTRL+XKEY. If you have a default cube or 
plane just delete them now (select them with RMB and press XKEY).

**Creating a simple plane**

Our first step is to create a large plane that we'll use for the 
ground and grow our mountains out of.

- Press on NUM7 to enter top view. This way our plane will be 
  lying flat when we create it.
- Click LMB where the axes cross. This will be the center of the 
  plane we will add.
- Now add the plane with SPACE → Add → Mesh → Plane. This 
  will be our canvas.
- Scale the plane up by about 15. First put the mouse close to 
  the center of the plane and press SKEY and drag the cursor 
  away and watch the numbers in the bottom left of the 3D 
  Window. Hold CTRL to increment by 0.1 for a more precise 
  measurement. Alternatively, to enter the exact amount 
  yourself press SKEY, then simply type 15 and hit ENTER.
- Now we need to add some vertices to work with. In the buttons window, make sure we have the 
  Editing buttons open (or hit F9 in the buttons windows to switch there). Under Mesh Tools hit 
  the Subdivide button 4 times. Alternatively, in the 3D View window you can press WKEY and 
  select Subdivide (Or just hit ENTER).
First mountain

Now that we have the ground, it's time to start growing our mountains.

- Make sure you have nothing selected (AKING).
- Select a random vertex with RMB. I usually start at the one that is 4 down from the top, 4 in from the left (the 4th vertex if you count the edges).
- Change to the side view with NUM3.

- Press OKEY to change to proportional edit mode or use the button which shows a grey ring on the header of the 3D View. The button will change its color to orange. You can also use SPACE → Transform → Proportional Edit
- Once you've turned proportional edit mode on, another button appears to its right, the falloff button. Select Smooth Falloff here. Alternatively you can use the menu on the header of the 3D View (Mesh → Proportional Falloff → Smooth) or, using SHIFT + OKEY will switch between Sharp and Smooth Falloff (in versions prior to 2.37) or cycle through all 6 falloff types (in versions 2.37 and up) while using the Proportional editing tool.
- Press GKEY to grab the vertex. We should now have a circle surrounding the vertex, this is our radius of influence. Basically any vertices inside this circle will be affected by any changes to the vertex itself.

- Use the Mouse Wheel or PAGE_UPKEY and PAGE_DOWNKEY to adjust the radius of influence to include just over 2 vertices on each side of our selected vertex. (Depending on your version of Blender, you may need to use ALT + NUM+ and ALT + NUM- and may need to hold down the LMB while using the Mouse Wheel to adjust the radius of the influence. On Mac, hold the "fnKey" down and hit "page-up" or "page-down"). In 2.41 you must 'grab' the vertex first - only then can you alter the sphere of influence.

- Move the vertex up about 8 units on the Z-Axis. Do this by dragging the cursor up a little, and press the MMB; this should restrain the movements along the Z-axis. Now use CTRL to move it precisely. Alternatively you can use ZKEY to restrain movements to the Z-Axis and type 8 and hit ENTER. In older versions of Blender you may need to hit the NKEY before typing the number 8.

Newbie Note: First add a fractal of about 60 (see bottom of page in naturalness) to the area of the soon-to-be mountain. Then choose random falloff to make your mountains look Super Professional.

Congratulations, we just created our first mountain. Now it's time to see what other things we can accomplish with the proportional editing tool.

Peaks vs. hills
The 2.37 and onward releases offer 6 types and 2 modes of proportional editing. The previous release only has 2 of these types: Smooth and Sharp Falloff. We'll take a look at the difference between these two now.

- Change to top view again with NUM7. You'll notice that now your "mountain" looks like a few differently shaded squares in the grid; you're looking down on shaded tiles, but in the Z axis, they're all still perfectly aligned with the original grid.
- Select another vertex away from the first. Let's say 4 from the bottom 4 from the right (counting the vertices on the edges).
- Change back to the side view with NUM3.
- Select Sharp Falloff from the menu on the bar of the 3D View. Alternatively, using SHIFT+OKEY will switch from one to the next of the 6 proportional editing modes while using the Proportional editing tool.
- As before, move the vertex up 8 units on the Z-Axis (Note: The radius of influence will still be the same size as when we last used it).
  - GKEY
  - ZKEY
  - Type 8 and hit ENTER

Now we can see the differences between the sharp and smooth falloff. The same number of vertices are affected in both cases; only the degree to which they are affected is different.

The different proportional editing modes can be selected from the box immediately to the left of the proportional editing type box. The mode box contains three options: Off, On, and Connected. "Off" means that proportional editing will not be used. "Connected" means that only vertices linked to the selected vertices will be affected by the radius of influence. "On" means that all vertices will be affected.

Noob Help: I do everything you say and the radius circle dosent show up how will I get it to show up? Here is a picture. [IMG]http://i191.photobucket.comalbums/z148/purgarus/help.jpg[/IMG]

**Shaping the world**

Now that we've created a couple of Mountains, it's time to see how we can use proportional editing to shape them.

- First make sure we're in side view (NUM3).
- Then on the smooth falloff mountain, the first one we created, select the vertex that is immediately down and left from the topmost point.
- Press RKEY to rotate, and hold CTRL and rotate everything by -90. Alternatively, use RKEY, NKEY, and type -90 and press ENTER

Feel free to play around with scaling or rotating from different view points.

[Noobie Roy says: Huh?? I don't understand what I'm supposed to be achieving here. What is
supposed to happen when I rotate? As far as I can see, nothing at all happens. Can you maybe show us a before and after screenshot? Or maybe explain in more detail? Thanks!] [Noobie Sean says: Ray, you made the mountains by using proportional editing with grab/move. Moving one vertex moved its neighbors, within the proportional circle. Rotate and scale also use proportional editing to rotate or scale about the selected vertex much like the grab/move operation.]

**Smoothing things out**

Now that we have a couple of budding mountains, you probably think they look kind of choppy. Sure they would be good if we were making an 8-bit console game, but we're working with 3D here, we want things to look sharper (or maybe smoother) than that. There are a couple of approaches to this. The first is to use more vertices when we create our plane. And I won't lie, it works. But it's also a HUGE resource hog. It would take your home computer hours of work just to keep things updated, let alone run it. So instead, we fake it. The easiest way to do this is to turn on *SubSurfaces* (we saw this in Detailing Your Simple Person 1.) For our purposes, let's set the subdivision (*Levels*) to 2. Also, ensure our SubSurf algorithm is set to *Catmull-Clark* (this is the default setting).

Now, you'll notice that with SubSurf on, we lose a lot of hard edges that we had, essentially we have no sharp corners anymore. I don't know about you, but to me that doesn't make for a very interesting mountain range. So to restore our corners, we are going to use *Weighted Creases for Subsurfs*.

- First turn off proportional editing with the **OKEY**, and ensure we're in side view with **NUM3**
- Next, while still in edit mode, change to *Edge Select* mode with **CTRL+TAB** and select *Edges*. Alternatively press *Edge Select Mode* button at the bottom of the object window.
- Under the *Edit buttons* under *Mesh Tools 1* ensure that *Draw Creases* is selected. (Mesh tools one may be off the screen, if so, use the scroll wheel when over the Edit Panel to reveal it.
  - **Noob note**: *"Mesh Tools 1" is a separate panel from "Mesh Tools."*
- On our Sharp Falloff mountain, the second one we did, select the two edges on the right. *(see image below)*
- Press **SHIFT+EKEY** or **SPACE → Edit → Edges → Crease SubSurf**, then move the mouse away from the edge until the edge *Crease* reads 1.000 in the 3d views header. If moving the cursor there seems to be impossible, just hit 1 and enter.

As you move the cursor away from the edge you will notice two things. The first is that the edge becomes thicker as we move from it; this is showing how much of a crease we have (with *Draw Creases* turned on). The second is that you will notice the subsurfed mesh moving closer to the edge as the sharpness increases.

**Naturalness**

Push **CTRL+TAB** and select vertices. Then go into front view **NUM1** and select the second vertex from the top in the center, then go into side view **NUM3**. Push **GKEY** and drag the vertex inwards,
not too far or your mountain will come out of itself on the other side. Just bring it in enough to make a small indent.

Then grab the top vertex and pull it down a small amount. You will notice that there is a small "crunch" in your mountain.

Don't forget to select all, press **WKey** and hit the **set smooth** button to smooth everything out.

OK, so your mountains are starting to shape up. But they still look a bit too neat. You could spend time moving each individual vertex but the chances are your model will still lack the natural feel. What we need is some chaos. Thankfully this is quite easy to accomplish. Firstly select the vertices that make up your mountains, all of them and a few around the base (box and circle select will make this easier). Select a few vertices between the mountains too. Next we use something called fractals. Fractals are chaotically (ie randomly) generated variables. In short you can use these variables to give your mountains a "wobblly" look. Fractals are located in the Mesh Tools section of your edit buttons (next to Noise, Hash and Xsort). Click it and you'll be asked for a value. This value is the strength of the fractal. 1 is very low and will barely change your model. 100 is very high and will twist your models into very odd shapes indeed. Have a play with different values until you find one that you like. Around about 15-30 should do it. Hit OK and hey presto, your mountains have been transformed from clinical neatness, to lumpy chaos.

- If you make too many fractals, your computer will slow down. However, the more fractal you add, the more bumpy and realistic it looks!

**Noob Note**: Repeatedly using the fractal tool seems to rapidly multiply the amount of vertices on your canvas. I suggest using the tool once, and if the result isn't satifying, undo the result (**CTRL + Z**) and try it again with a different fractal strength. Even after undo, your selected vertices remain selected.

---

(Under Construction [TO DO: finish me])

---

**Adding your guy with the hat**

To insert your guy with a hat, you can simply go to **file > append or link**(shift+F1).

- Then select the file from the previous tutorial.
- You will then see a list of objects you can insert or 'append'.
- First go into the 'Object' folder. Unless you renamed him/her, your person will probably be named “cube.” Select it.
- Make sure that 'Append' button is pressed; otherwise you will not be able to scale or translate, or edit your model at all. (The 'Link' button will link a copy of your object into the current scene, and will update any changes when you reload the file. Unfortunately, this includes location and size, so we will not use it right now.)
- Press 'Load Library' to place your guy into the mountain scene. Please note, the Load Library button is top right. Confusingly, there is some text bottom left that says Load Library as well, but isn't clickable.
- Repeat the process to get the hat (probably named “circle”). To reset the parental relationship, see the instructions at the end of the previous tutorial. To scale them to the appropriate size, go to object mode by pressing **TAB** (unless of course you are already there). Select the object you want to resize, then press the **SKEY** and use the cursor to scale as you see fit. To undo any mistakes, use **CTRL+Z**.

**Noob Note**: To import the file once you have the list select the item, i.e. cube, and in the bottom right
select "Active Layer" that will append it to your current proj when you click "Load Library" your work should be visible now.

Creating Models With Photo Assistance

The first tutorial is about using guide images to place vertices in their proper places in 3D space. The second tutorial is on how to take good reference pictures. These tutorials assume that you have completed all previous tutorials.

Making A Pyramid

*Note: I believe that this section is incredibly frustrating to new users and that you should come back to this section after finishing the whole modeling section. But if you wish to do it you still can.*

First we are going to create a pyramid the easy way. Then we are going to show how to use different viewpoints and images as a guide to place vertices correctly in 3D space.

You should have the default cube. If not, start a new project.

- Go into Edit Mode (if in Object Mode, press *TAB*).
- Select side view (*NUM3*).
- Make sure no vertices are selected by pressing *AKEY*.
- Go to Box Select mode (*BKEY*) draw a box around the top vertices of the box
- Merge vertices by Pressing *ALT+MKEY* → *At center* and the top of the box is merged to a single point
- Unselect all vertices (*AKEY*).
- Box select (*BKEY*) the bottom 4 vertices
- Hollow out the bottom of the pyramid by deleting the bottom face *XKEY* → *faces* (remember that if you want to change to face select mode press *CTRL + TAB* → *faces*)

Now that we have the pyramid the easy way, let's learn how to use photos as references to build models. First, unselect all the vertices by pressing *AKEY*. Next, select the bottom four vertices of the pyramid and delete them with *DEL* or *XKEY*. The only vertex left will be the vertex which makes the tip of the pyramid. This will be used later.

Window Layout

Split the Main 3D view window in to 4 windows. Explained in guide: Noob to Pro/Blender Windowing System.

Change the point of view in each window so that they end up like this:

**NUM1 NUM7**
**NUM3 NUM0**
Reference Pictures

Make a picture of a white square and of a white triangle in the GIMP, Paint :) or some other image editor.

**Read the following section carefully:**
Make sure that the **drawing** of the square is **square** and not just rectangular. Make the triangle the same width and height as the square. Make sure the apex of the triangle is directly above the midpoint of its baseline.

**Suggested method of construction #1:** Make the square. Save it, but keep it open. Delete everything except the middle line. Make the triangle from the lower corners (ends of the baseline) and make sure the new two lines meet exactly above the midpoint of the baseline. Make sure the triangle is visible against a black background as shown in the image. Save as a new file.

**Suggested method of construction #2:** Download the black and white triangle image on the right of the screen and use that, make a square by filling it white and resaving it.

**Suggested method of construction #3:** (if you are using Photoshop): make a square selection of "n by n" size, remember the value of "n". Fill it with white color and save. To create a triangle of needed properties make a rectangular selection of same (n by n) size, on a blank sheet, click RMB on your document, choose "Transform selection" option in the pop-up menu. Once you are in "Transform selection" mode, right-click the blank image again. This time the pop-up menu would be different. Choose "Perspective" from it, and with LMB drag one of the two top vertices toward the other. Once the vertices meet (in the top-center of the image), exit the transformation mode, and fill the resulting triangular selection with white.

Note for Gimp users: turn on the grid (View->Show Grid, View->Snap to Grid), use the rectangle select with a fixed aspect ratio of 1:1 (in the tool options panel) to select a square that you can flood fill. For the triangle, use the node tool to draw a triangular path, convert to selection (Select->From Path) and fill it. Or you could just use Inkscape...

Save the files to a place that is easy to access. Blender only supports the TGA, PNG, and JPG image formats.

Background Images

Load the white square into the **NUM7** window by going to the 3D view window and pressing **View -> Background image** (click on the icon of a file) find your file and click "select image"
Load the white triangle into the **NUM1** and **NUM3** windows.

If necessary, zoom out so that you can see the whole picture.

Now you have a guide for making a pyramid.

If you can not see the picture, switch to Ortho view by hitting **NUM5**

**Side One**

The vertex that is left will be the topmost point of the pyramid. Use the **GKEY** to move the vertex around. To get it in the right spot, line it up at the top most point in the **NUM1** and **NUM3** windows. If you look in the **NUM7** window the vertex should appear to be in the center. Make sure to keep the vertex highlighted for the next step.
(note: it might be helpful at some point to zoom in and use the X,Y and Z movement restriction)

Now, we are going to place more vertices in the scene. Since we want to have the new vertices connected to the first one, we will make sure the first vertex is selected and use **CTRL** and click **LMB** to create a new one. In the **NUM3** window, place a vertex on the lower left edge of the triangle by holding **CTRL** and clicking there. This should create a line between your 2 points. If needed, use **GKEY** to line it up in that window and also at the lower right point in the **NUM7** window.

Next, with only one of the vertices selected, in the **NUM1** window place a vertex on the lower left edge
of the triangle using the same method. Line it up in that window and at the lower left point in the **NUM7** window.

Now, select your 3 vertices (use **AKEY**) in the **NUM1** window and press the **FKEY**. You should see a triangle appear.

**Side Two**

Press **AKEY** to deselect all vertices and select the vertex at the top of the pyramid again. Repeat the process from Side One to make the next side. Place a vertex in each of the other corners of the square using **CTRL** and **LMB**. Line them up in two different views with the corners of the triangle and square. Make sure only the top vertex and the two new vertices are selected and type **FKEY**. This will fill in a face opposite of the first face in the pyramid.
Sides Three and Four

To fill in the other two sides select the top vertex and the corners on a side where there is no face yet. Again, use FKEY to fill in a face. Repeat this for the last side to have all four sides created.

Bottom

In the NUM7 window select all four corners and make a face. You should have a solid pyramid! Now, select all 4 faces and hit X faces.

Taking the Best Reference Photos

Remember what I said about turning a cube into a puppy? We'll do that now.

Step One: Get the pictures of the model

[note: The images here do not line up. Some need to be rotated, and others do not match in size. They will be kept so that you can get the "real feel" for this project.]

If you have a puppy and a digital camera, take three pictures of the cute little rascal, and upload them. If you don't have a puppy, any object or small animal will do. Ideally, the photos will be looking straight down at the top of the puppy, a side view, and a front view, and, most importantly, the puppy should be
in the same pose in all three photos! Or at least close to the same pose... we all know puppies don't stand still very long.

You could use two mirrors. One is placed next to the puppy at 45 degrees to the camera and 45 degrees to the puppy. Another is placed above the puppy, also at 45 degrees to the camera and 45 degrees to the puppy. This produces three images, one of the puppy **NUM1**, one of its reflection seen 90 degrees to the right **NUM3**, and one of its reflection seen from overhead **NUM7**. Take the photo from a long distance away with a zoom lens to get close to an orthographic projection (http://en.wikipedia.org/wiki/Orthographic).


Using your favorite image editor such as PhotoShop or the GIMP, the images need to be down-scaled to a reasonable size (I made mine 512x384), and then matched to each other. To match them, draw construction lines (pulled from the rulers above and to the left) on the left view for example to pick out key features. I picked the tail, front of back foot, eye level, tip of the ear, front of the nose:

I found when I picked out these features that this first image needed to be rotated slightly. That completed, I proceeded to scale, rotate and shift the other two views (top and front) until they matched fairly well as layers on top:
Once I had the proper results, I saved the resulting images, and these are the ones we will use in Blender.

The results are the files you'll need for Step Two:
Just right-click and save them some place where you can find them to load them into Blender for Step Two. You may notice the photos aren't perfect, but we'll use them just to show how you should deal with your real photos. When you are creating your own pictures to import, note parallax (http://en.wikipedia.org/wiki/Parallax). In this example, parallax is present, and we'll attempt to compensate.

**Step Two: Get the Picture into Blender**

Getting the image into blender is the easy part. The more difficult part will be creating the mesh, but first things first. Create a new file (File -> New) to see the familiar default objects. Don't bother deleting the cube, we'll end up using it. Split the 3D Viewer into four views and assign them the following cameras. (Noob note: To split move the mouse to the border of the view. When the cursor transforms into arrow, right-click and choose Split Area)
Num 7 Num 3
Num 1 Num 0

Each window will show you different XYZ coordinates with the Num 0 view being what your object will look like to the camera object.

Now that the screen is set up, let's load the images. In the top left viewport (XY), click 'view' on the viewport's header (the menu at the bottom). From the menu provided, select 'Background Image ...'. A small window will appear.

Click the 'Use Background Image' button and several more buttons will appear. Now click on the folder icon located to the right of 'Image:'. A new full-viewport window will appear. Explore this window a bit and end up selecting the image file of the wolf from the top view. What you should get is the picture of the toy wolf from above with the default cube on top of it. Rotate your view of the cube. The picture disappeared! But don't worry - the picture is still there. Press Num 7 to realign the viewport and see the picture again.

Noob Note: Be sure to be in orthographic view Num 5 or else you won't see the picture.

Now load the front view of the wolf into the Num 3 viewport (YZ) as you did the top view. Repeat the procedure and load the side view of the wolf into the Num 1 viewport (XZ). As a note, each picture is specific to the viewport it was loaded into. When you switch between axes views, the picture will not change. Try this out by changing the top left viewport to Num 3 and Num 1. Return the viewport to Num 7 before continuing.

Noob note: I can't seem to get the views to line up properly. When I start modeling the wolf in the side view, it doesn't show up correctly in the top view. If I try to rotate the top view, the wolf goes away.

The pictures are now loaded into the Blender viewports. If you look at the pictures on the grid, you may notice that the front view of the wolf isn't quite center. That is okay, Blender has a way to fix it.

Move your cursor over the Num 3 viewport and press Shift + SpaceBar, this expands the current viewport(Num 3/ front view) to a full screen view, then open the Background Image window for the front view again. Notice that there are picture manipulation options available. One of these includes picture offsets. Click on right side of the 'X Offset: 0.00' to increase the offset to 0.20. The picture will be shifted over slightly so now the wolf is more centered. Press Shift + SpaceBar again to return to the four viewport view you created earlier.

Figure 2.2.1 Viewport picture setup
The setup work is now done! Let's start on actually making the wolf model.

Reader Note: If, like me, you weren't paying that much care to how your "wolf front view pic" was aligned from left to right earlier on during the gimp editing phases, then you may need to use a different 'X Offset: ' value than '0.20' that the author recommends. If that is the case, then just use some appropriate alignment value to center it visually as best you can. Hopefully this helps with avoiding some potential confusion for other readers.

**Step Three: Rough Model Fitting**

This is a brute force model creation using techniques discussed previously in this book. This section is meant to explore and become more comfortable with them. Do NOT try to follow the example to the tee. Your wolf and my wolf will probably not look the same since you may want to add more or have less detail.

WARNING: If you are following this book all the way through, and are just getting started with blender, the following step (step 3 as a whole that is) may likely take several hours to complete. The best strategy is to take breaks, be patient, and with time you'll figure out the best way to go about this step.

The rough fit stage requires either some planning or on-the-spot decisions. Think about where the wolf will have parts of its body flex or require parts jutting out.

The first step is to create a blocky wolf. Start out with a column of blocks using the extrude face command (select face, **EKEY**). Don't worry about snapping the vertices to the grid since we are working with an organic figure.

**Figure 2.3.1** Body column formation
The next step is to split the ears and legs off of the body. Do this by subdividing the appropriate faces. Save often, and if you make a mistake, go ahead and use the undo option (CTRL+Z). Also, if you find yourself looking at redundant faces, combine them (FKEY).

**Figure 2.3.2** Appendage formation

If you are having trouble with this, try mousing over the perspective window (the one you designated with Num 0) and using the MMB to rotate the view so that you are looking at the underside of the wolf. Click on the face underneath the wolf that is alongside his front legs (use the side view to check this). We are going to subdivide this face in order to grow legs off the new faces. To subdivide, press the WKEY and choose subdivide. You will see that the face has been divided into four. Take one of these faces and extrude it as many times as is necessary to make the right leg. Then do the same again for his left leg. Use the pictures as a guide.

Doing the ears is similar, except instead of working underneath you will start with the face on top of
the wolf which is directly over the ears. Select this face and subdivide it once. Deselect everything using AKEY, then select one of these four faces and extrude it upwards once to make an ear. Do the same for the face alongside it to make the other ear.

Finally, extrude the tail end of the wolf one more time, so that your wolf has as many divisions as the picture above.

Let's start refining the model starting with the tail. Try putting your viewports in wireframe mode by pushing Z, it may make things much easier. Line up the vertices over the wolf in each viewport by lasso selecting multiple vertices (CTRL LMB, Drag). then move to the right location with grab (GKEY).

**Figure 2.3.3 Working on the tail**

Continue onto the hind legs of the wolf. It is trickier to manipulate the legs so keep rotating a viewport to look at the model from multiple perspectives. Remember that we are working in three dimensions.

**Figure 2.3.4 Working on the hind legs**
Continue working up along the wolf fitting the blocks to the pictures. If you have problems seeing the picture because the model is in the way, let’s hide the model. In Edit Mode, select the entire model by **AK** or by pressing **L** when you have the cursor over the model. Simply pressing **H** will hide the selected items. To unhide the view, use **ALT H**. By hiding and unhiding the model, or parts of the model, you should be able to keep using the picture as a guide.

Once you have the first pass done, you’ll notice that the model just won’t fit all three pictures correctly. This is due to parallax. The most obvious example is the side view. The four feet should be level, as they are all standing on a flat surface. Since they are not, we’ll just ignore some of the aspects of each picture and continue with the model. (This is a helpful example to show what you need to consider when taking your own pictures.)

**Figure 2.3.5** Completed rough fit
Attention: The top right Viewport is said to be "NUM 3 - Side" but the Picture shows the wolf from the front! So care and change the picture with the left window at the bottom or change the Viewport settings.

Reader Note: this is because for the pictures to line up correctly the front has to be in the side viewport and the side has to be in the front viewport.

**Step Four: Refining the Wolf Model**

Now that the rough fit is done, let's smooth out the wolf. Add a Subsurf modifier and set the Levels to 2. The wolf will now be smoothed, but we want to add some of the hard lines back into the model. This may be accomplished with creased edges.

First, turn on the view creased edges by toggling the 'Draw Creases' button in the Mesh Tools 1 window. Enter Select Edges or Select Faces mode (CTRL TAB). Highlight the edge or face you want to crease and press **SHIFT + EKEY**. Use the mouse and pull away from the center until the Crease value is close to what you want. A value of +1.000 will give you the sharpest look and is useful for places such as the bottoms of the paws. When an edge has been creased, the edge will be highlighted in yellow (positive crease) or black (negative crease). These highlights are shown due to the 'Draw Creases' button being turned on.

In this example, I creased edges along the paws, tail, ears, and nose to give them some sharpness.

**Figure 2.4.1** Creased edges

![Creased edges](image)

The last step is to refit the model to the pictures. You may have noticed that when the model was smoothed, the result didn’t quite fit to the pictures. Now is a great time to tweak the vertices to fit to the pictures or add to/modify the model.

And here is my basic wolf based on three pictures!

**Figure 2.4.2** Final toy wolf model

![Final toy wolf model](image)
Alternative Wolf Modelling

(user comment) I was doing this tutorial and though I'm still a noob at this I thought I could contribute a little to this. I decided only to do half a wolf and then mirror it to create a complete wolf. I started out with creating the silhouette of the wolf body in the side view, and then in front view I started to shape the wolf head, tail and legs...

User Note: If you are attempting this method, I read in a much later tutorial that it is best to avoid using triangles in rounded areas of a Mesh, because they tend to cause artifacts in your model (artifacts are protruding edges or other things that don't look realistic). Apparently, using quads is a much better alternative. Triangles should only be used on flat areas of your mesh if they can be avoided.
And at any rate this is what I ended up with. Not the best wolf ever, but as I said before I’m still pretty noobish.
From this point forward there are multiple ways to do the exact same thing, however for simplicity's sake and so that I can be more detailed I will be using one method (the one which I use) and be using GIMP.

I found it best to size all the photos to a known width, with an easy to find center. (Mine happened to be 850x638 pixels, I don't recommend that but you can choose any size you want really, as long as all of them are the same size). Then drag the construction lines to form a crosshair in the middle of the photo. To do this, click on the top ruler, and drag down to the middle (Exact middle) of the photo, then click on the side ruler and drag across to the middle (Again exact middle) of the photo.

If you are having troubles finding the exact middle of the photo, move the cursor to the very bottom left of your photo and the height of your photo will be listed at the bottom left of the GIMP interface. The numbers are listed in an (x,y) format so you want the first number to say 0 and the second to be the largest you can make it by dragging your cursor. The second number is the height, and half of that is the middle of your photo. You can do the same with the top ruler to find the vertical middle of your photo. Only this time the co-ordinates at the bottom left of the GIMP interface should list the second number (y) as 0, and the first number should be as large as you can make it by moving your cursor (to the upper right of the photo). Once you have your width again half of that will be the middle of your photo.

Then using construction lines put one at the top of your object, and the bottom of your object. Find the "height" of your object by the distance between them. Remove the construction lines from the top and the bottom, and place a new construction line above the horizontal center line by the half of the "height" of your object. Now place a construction line on both sides of your object and find the
“width” (distance between the new vertical lines), then remove those construction lines and place a
new construction line vertically half of the “width”(of your object) to the right of the vertical center
line. Now cut the object out, and drag it so that the point you used as the “top” is on the horizontal
construction line that is above the middle. Then Drag the photo left or right until the right edge of the
object is on the vertical construction line you put in right of the middle construction line.

Now the center of your object is at the center of your photo. This is a very important thing because
when blender loads in the picture you will need this so that all of your pictures match up with each
other 3d. You should repeat these steps with all 3 photos. I also dont recommend doing it in GIMP’s
"layered mode" as that caused more pandemonium for me. I recommend opening each photo in a new
window.

Taking your pictures is the most important part, because if the pictures are not all in the same scale
(object size to photo size) then your photos will not line up and you won’t be able to place a dot on the
same location from front view, side view, and top view.

As a recommendation I would recommend making your first model from a Lego man. That is what I
did and it is very simplistic easy practice. To take my photos I took about 10 minutes to construct a
photo platform for my object. It consisted of a cardboard box with two sides cut out. I covered the
inside area with computer paper. I then used a 2"x4" and a ruler to make sure that the box stayed the
same distance from the camera for all shots, as well as marking where the Lego man’s feet were
positioned inside the box with a pencil. This will provide good pictures, providing you keep the
camera at the same distance and zoom for all three photos.

Next Page: Modeling a Gingerbread Man
Previous Page: Mountains Out Of Molehills

Modeling a Gingerbread Man

Next Page: Penguins from spheres
Previous Page: Creating Models With Photo Assistance

In this tutorial you will learn how to make a simple gingerbread man. In a later tutorial you will be able
to make an animation with this gingerbread man.

In this tutorial we will tie together everything we've talked about up to this point, including extruding,
subdividing and rendering, and throw in basic lighting.

Modelling

First, start Blender. You should see a cube in the 3D View. (scroll with the MMB or press
CTRL+MMB). Make sure you are in orthographic mode: press NUM5 to go into orthographic
mode.

- Select the cube by clicking RMB on it. To review, when an object is a pinkish color, it is selected.
- Now press TAB. When you press TAB it will switch you between Object Mode and Edit Mode. If
  you pressed TAB you will see pinkish dots. The pink dots are called vertices. (You will know if
  you are in Edit Mode if you can see those dots.) When you select vertices with the RMB, they
  will turn yellow.
- Select all the vertices (AKEY once or twice) and then click on the editing tab in the header of
  the buttons window (or you can just press F9) to go to editing.
- Once you are there you will see a new menu at the bottom of the page, click on the subdivide button in the section called Mesh Tools (while all the vertices are selected). You will see that your cube now has more vertices. This tool is used for **dividing** an object so that you can do more complex models. [Note] **In newer versions, you can also hit SPACE and, in the menu that comes up, Edit → Edges → Subdivide.** [Note] You can also press the WKEY, and click subdivide

- Now press **AKEY** to unselect all the vertices, go to the front view (NUM1) and press **BKEY** and drag a square around the top left and middle left vertices or press **BKEY** twice and you will see a circle around your mouse - all the vertices in the circle will be selected by pushing **LMB**.

- Take a closer look on the selected vertices by viewing the model from a different angle (remember that you can use **MMB** to achieve this). If you find that you have only selected two vertices and not six, there are 2 ways of solving your problem. You could hit the **ZKEY** to toggle between wireframe mode and solid mode or you could hit (and deactivate) the Button in the selection mode buttons (**note that this button is shown only if you're in solid mode**). Repeat the previous step and see the difference.
- After selecting the 6 vertices press **EKEY** and select Region. This will extrude the selected vertices. Put the new vertices on the adjacent gray line of the grid one unit to the left (press **CTRL** to snap to grid). Do this two times so that it looks like below (the snapshot has been taken in a front view (**NUM1**)):

- Clear your selection (**AKEY**).

- Now select the other two vertices (six in 3D again) on the opposite side and do the same there as explained above. Now the arms are complete, as you can see in the illustration below.

Now we will do the legs.

- First, unselect all the vertices : use **AKEY**.

- Select the bottom left two vertices, extrude it and put them in between the gray line (the gray
lines in the grid representing the Blender units) and the second gray line below. If holding down **CTRL** you will notice that the two vertices snap to the grid in the background and you won't be able to select in between them, but jump between one and two of them. Press **SHIFT** as well and you'll be able to go in tenths of the units. (You can also just enter the number 1.5 to extrude it 1 1/2 units out. On Mac, enter the number 1, press fn with the key that is right under Lkey and Mkey on Azerty (the one with /:), and press the number 5)


- Extrude it again and put it on the third gray line (or, once again, enter 1.5). It should now look like this:

![Image](http://en.wikibooks.org/w/index.php?title=Blender_3D:_Noob_to_Pro_

- Use the **BKEY** to select the bottom 4 vertices (12 in 3D) of the leg, and use the **GKEY** to pull it out to the left by half a square so that it looks like this

![Image](http://en.wikibooks.org/w/index.php?title=Blender_3D:_Noob_to_Pro_

---

77 de 140 10/09/07 17:13
- Do this again for the right leg.

- Use **BKEY** to select the vertices at the groin (where the two legs join)

- Press **GKEY** and pull it down by 1/2 a square (type **GKEY, ZKEY** and write -0.5 - in older version you have to type type **GKEY, ZKEY** but also **NKEY** and write -0.5 then)

*(I had some problems here, trying to move the vertices. There were too many vertices in the same place, and that creates strange forms. To erase the duplicate vertices on top of each other, you can either select the entire model, or just the vertices you want to clean. Then press **WKEY** and choose Remove Doubles.)*

- Press **TAB** to go out of edit mode (you will know if you are out of edit mode if the vertices are not visible). You are now in object mode.

- Click **RMB** on the object to select it then press **SHIFT + SKEY** and select **Cursor → Selection**. This will make sure the cube you’ll add next will be near where you want it.

- Press **SPACE** and put your mouse on the mesh option and select cube. In others versions, you can also hit **SPACE** and , in the menu that comes up, choose **Add → Mesh → Cube**.

- Press **GKEY** and put your new cube about 1/3 of the way down the neck (to achieve this, you can press **GKEY** and **ZKEY**: enter 1.33).
Now we will make it look more like a ginger bread man by making it thinner.

- Go to side view with **NUM3**.
- Press **SKEY** for scale and press **YKEY** for Y-axis and then move your mouse to the middle until the it is about 0.3 (use **CTRL** for fixed values).
- Remember X-axis is the Red arrow/line, Y-axis is the Green one, and Z-axis is Blue (like RGB video mode).

- In **OBJECT** mode, use **RMB** on the body and press **SKEY** and then **YKEY** and make it as flat as the head.

- Use the **MMB** to spin the view around and examine your handiwork.

At this point, it doesn't look entirely like a gingerbread man, does it? It's a bit too ... chunky. For the
last bit, we’ll smooth it out.

- Make sure you’ve selected the body in object mode.
- Select the editing panel in the buttons window (or hit F9).
- In the Modifiers tab, Add a "Subsurf" modifier. You can also push SHIFT + O
- Set the level of the subdivisions to 2, and the number of render levels to 3.
- You can press the ZKEY to switch back and forth between wire-frame view and solid view.
- (Noob Note: Easiest way to really get a feel for what is going on in the 3d world is to split into four screens and setting each one to num7, num3, num1, and num0 to see all angles and what it will look like at render.)
- In the 'Link and materials' section, select 'Set Smooth'.

(Note that here I had the same problem as before, with superposed vertices. Select all vertices, then press WKEY and select Remove Doubles to clean your model. You will see that it will look much better after removing the extra vertices with Remove Doubles)

![Image of character with wire-frame view]

- Press the ZKEY to return to wire-frame view.
- Now repeat the process above to smooth the head.

![Image of character with smooth head]

Looks a lot more like a gingerbread man, now, doesn’t it?

**Camera Positioning and Rendering**
This guide will show you how to intuitively get the best shot of your 3D scene with no effort!

- Press **TAB** for Object view mode.
- Press **NUM0** to get the Camera View.
- Select the camera by clicking **RMB** on the outermost rectangle.
- Press **GKEY** and move your mouse to adjust the position of the camera (**XKEY**, **YKEY**, **ZKEY** and **CTRL** may be useful here).
- In addition, you can press **NUM7** to get the Top View and press **RKEY** to rotate the camera to the best angle.
- After you are happy with the position, press **F12** to render it.

(user comment) When rotating the camera, I found it much easier to split the view into two areas, and set one view to top (7) and the other view to camera (0).

(user comment) Remember to move the light to a better position, or your gingerbread man could be a little dark.

(user comment) Bring back texturing of the gingerbread man!!!

Penguins from spheres

**Next Page: Die Another Way**

Previous Page: Modeling a Gingerbread Man

Penguins from spheres

**Next Page: Die Another Way**

Previous Page: Modeling a Gingerbread Man

**Setup**

Start with the default scene: it should contain a selected cube. Delete this cube by pressing the **XKEY** and clicking on *Erase selected Object(s)*.

Put the 3D cursor at the scene center: click near the center and snap the cursor to the grid (**SHIFT+S** and *Cursor → Grid*).

**Note**: after deleting the cube you must be in **Object Mode**. If not, switch with **TAB**.
Creating the body

- We start by creating our main body from a sphere. Press **SPACE → Add → Mesh → UVSphere**, then choose 16 segments and 16 rings from the pop-ups.

**Note:** When done, Blender automatically switches to the Edit Mode. This is OK, since we will start editing the mesh now.

We're going to make it look like a penguin body:

- press **NUM1** to switch to the front view,
- choose the scale tool (**SKEY**),
- restrict scaling to the Z-axis (**ZKEY**),
- and move the mouse away from the 3D cursor while holding down the **CTRL** key (this snaps the scale values),
- the current scale shows in the lower left corner of the viewport, click when you've reached 2.000 (**LMB**).

**User Note:** You can also just type **KEY2** and hit **ENTER**.

**Note:** make sure the mouse cursor is not too far away from the sphere when hitting the **SKEY** else you may not be able to reach a 2.000 scale value. The scaling steps are proportional to the distance from the 3D cursor when calling the scale tool.

This is our main body!

Shaping the head

We're going to shape the penguin head from the top of the sphere.

Start by selecting the top two smallest circle segments.

**Note:** selection has been explained in a previous tutorial. Here, the easiest methods are either box selection (**BKEY**) in the front view (**NUM1**) and Limit selection to visible off, or lasso selection (**CTRL+LMB**) in the top view (**NUM7**) and Limit selection to visible on. Don't forget to deselect all first (**AKEY**).

**Reminder:** make sure the Limit selection to visible button is in the right state each time you select vertices, edges or faces. When it's off, selection affects any item, visible or not.

transform manipulators

To turn on the 3D transform manipulator, either push down its button **(JFrame]** or use **CTRL+SPACE** and choose Enable/Disable.

Moving the two selected circles up

Choose the Translate manipulator (red triangle). Go to the front view (**NUM1**). Drag the blue arrow
while holding the **CTRL** key down to move the selected vertices 0.3 units up.

**Note:** you may not be able to snap the extrusion lengths to tenths of units. **CTRL** snaps to the grid size by default: if you can only translate by one unit (1.0), zoom in until the grid divides itself into tenths (**SCROLL**). Some Blender versions allow to snap to one tenth of the current step by holding both the **SHIFT** and **CTRL** keys while moving the mouse.

**Note:** instead of the Translate manipulator, you can use the **GKEY** and constraint the movement to the Z axis (**ZKEY**).

### Rotating the neck

Now switch to the side view (**NUM3**) and choose the Rotate tool (**RKEY**). Move the mouse with the **CTRL** key down to rotate the selection 30 degrees counter-clockwise. Use **LMB** to validate the rotation.

Select an additional ring of vertices by expanding the selection (**CTRL + NUM+**). You can contract the selection by pressing **CTRL + NUM-**. Move these vertices an additional 0.3 units up, then rotate them as previously 30 degrees counter-clockwise in the side view.

[Image of rotated head]

Repeat those steps twice (selection expansion, translation and rotation) and you'll end up with the body seen in the left picture.

That doesn’t really look like a penguin, yet!

Now move all of the selected vertices to the left 0.4 units by pulling the manipulator's green arrow (and of course holding the **CTRL** key down). This straightens out the neck as seen in the next picture.

**Note:** you can also use the **GKEY** and translate the selection by -0.4 as displayed in the bottom left corner of the viewport. Still do this in the side view (**NUM3**).

### Creating the beak

[Image of beak]
Switch to the front view (NUM1), and select the frontmost vertex (the one that originally was the top vertex of the sphere) with the RMB. Then switch to the side view (NUM3) and translate this vertex to the left by 1.2 units using the manipulator’s green arrow or the translate tool.

**Note:** some Blender versions allow moving the vertices from the keyboard with the following sequence: GKEY, YKEY, -1.2, ENTER.

The main body of the penguin is now finished. The next step is to create some flappers for our poor little guy.

### Extruding the wings

We are going to create the wings by extruding faces on each side of the penguin.

Choose the side view (NUM3) and switch to the Face select mode (CTRL+TAB → Faces, or click on the triangle in the toolbar).

![Image](image1)

Now, select two faces that will make up the penguin’s shoulder as shown on the left (select the first one with RMB and the second one holding SHIFT).

Then switch to front view (NUM1) and extrude the selection:

choose EKEY → Region, constrain to the X axis (XKEY), hold CTRL to snap, and move the mouse to extrude the shoulder by 0.3 units.

![Image](image2)

We’ll now extrude the bottom face of this new extrusion. Rotate the view to show it with:

- a MMB drag,
- or several presses on NUM2,
- or CTRL+NUM7 (bottom view).

Press the AKEY to deselect all, and select the bottom face (RMB), switch to front view (NUM1), extrude by 1.4 units down (EKEY and CTRL).

![Image](image3)
Now do the same on the penguin's other side: use **CTRL+NUM3** to view the back side (you can also rotate with **MMB**, or press **NUM4** several times).

### Smoothing the wings

![Edges to smooth](image)

We’re going to smooth out that shoulders and improve the wings. Though this can be done in many ways, we'll only use the merge tool.

Rotate your penguin so that you can see one shoulder from above. Then switch to **Vertex select mode** (**CTRL+TAB → Vertices**). Press **AKEY** to deselect all, then select the two shoulder vertices with **RMB** and **SHIFT**.

Press **ALT + MKEY**, choose *At Center* from the popup in order to merge the two vertices at their center. Finally dismiss the message saying *Removed 1 Vertices*.

Repeat the steps with the two other vertex pairs shown on the left picture, and smooth the other wing. I’m leaving the middle segments for now, else the wing tips will be too pointy.

**Note:** *if you have troubles merging vertices, it comes from vertex duplicates in your mesh. You probably chose Individual Faces instead of Region when extruding the wings, which creates duplicate vertices with neighbour faces. To clean up your model: select all vertices (A) and choose **WKEY** → Remove Doubles.*
I finish off the wings by selecting the two backmost vertices of the wings, and moving them up using the blue arrow by 0.1 unit.

(User comment on using the arrows: I mentioned earlier that the grid snap seemed inconsistent. It now seems that when I've got the 3d manipulators enabled (the arrows), the grid size is 1.0 units. When I have them turned off, the grid size is 0.1 unit. I don't know why, and I haven't found where to change this. The previous picture shows where to turn the 3D manipulators on/off, and which arrow to drag (using LMB) to achieve Z-axis movement.)

(User comment: if you spin the view it becomes 1.0 snapping, go back by pressing NUM1 and you should get 0.1 if not make sure View → Orthographic is checked and not Perspective this can also be done with NUM5)

(User comment: I've had trouble with the three axis arrows. When I click on the 'hand' icon, the three lines come up but with little blocks instead of arrows at the ends, which I believe means that they will scale instead of move. So, I have had to use GKEY for 'grab' and then ZKEY or YKEY or whatever to move along an axis.)

(Note from another user: Next to the hand click the triangle to go to Moving Mode).

(Another user comment (not from the first): Whenever I try using the arrows I always find that I click on something else, so I have to change angle and after that, it's not really worth using it anyway)

**Culling the bottom**

We're going to cut the penguin's lower end, for it to stand up! Select the bottom vertices (bottom vertex and first circle at the opposite of the head) as shown in the picture. There are many ways, this is left as an exercise.

Once you're done, delete them (XKEY → Vertices). Now our penguin is hollow: select all the vertices around the hole, and fill it using SHIFT+FKEY.

*Note: we could have merged the selection instead of deleting the vertices and filling the hole but the bottom wouldn't be flat.*

A nicer way to close the hole (works with convex holes): select the bottom vertex and first circle, extrude it (EKEY), cancel the move (RMB), merge ALT+MKEY → At Center. This leaves a nice, flat circle of triangles. Smartass noob note: first circle... and bottom vertex? Isn't it already gone because it's a hole? Otherwise the circle is smaller and not completely flat.

**Adding the feet**
The next step is to provide the little guy with feet. To do this, we’re going to extrude two of the front faces:

1. choose the front view (NUM1),
2. switch to Face select mode,
3. turn on Limit selection to visible
4. and select the face to the left and right of the middle two faces of the penguin.

Then switch to the side view (NUM3) and extrude the selection by 0.6 units (EKEY → Region, restrict to the Y axis: YKEY).

Keep the selection and look for the Mesh Tools in the Buttons panel. If you can’t see it, press F9 to switch to this panel. Then click on the Subdivide button (at the top, between Short and Innervert).

Now select the three middle vertices (or two edges) vertically at the tip of each foot, and drag them along the Y axis by 0.3 units towards the penguin.

**Note:** if something goes wrong here, you may need to remove double first. As always, to move the vertices, either use the manipulator or GKEY and YKEY sequence.

You should end up with what's shown in the right picture (minus the selection).

The feet look too thick, let’s flatten them a bit. Switch to the front view (NUM1) and select the two bottom vertex rows (Limit selection to visible off, use either the lasso or box selection).

Then choose the scale tool (SKEY), limit its action to the Z axis (ZKEY) and scale down by a factor of 0.4.

The feet still look rather peculiar, so please go ahead and move the vertices around on your own as you like.

**Reminder:** you can use the GKEY and restrict movements to the X or Y axis using the XKEY or YKEY. Try not to move vertices along the Z axis to keep the penguin's bottom flat.

**Extruding a tail**
To complete the penguin, we have to add a tail (the end of the tuxedo):

To go to the back view (CTRL+NUM1), make sure you’re still in Vertex select mode, and that Limit selection to visible is on.

Select the three middle vertices in the second row up from the bottom. Then, switch to the side view (NUM3) and extrude the edges 0.3 units away from the penguin and 0.08 units down (EKEY → Edges), so that the end of the tail is at the same level as the bottom of the penguin.

**User note:** I found it easier to select the centermost, lowest vertex, and move it along the Y axis only. This creates a crude but very effective tail (that doesn't look all that bad when subsurfed).

**Another user note:** to do this correctly (if I'm properly understood previous user) you can also select the two faces in the bottom row (CTRL+TAB→Faces), which are connected to that three middle vertices and their projection on the bottom line, then split them into triangles (SPACE→Edit→Faces→Convert To Triangles or using CTRL+TKEY), then select the right two of them (it was the right quad face before) and flip the triangles orientation (SPACE→Edit→Faces→Flip Triangles Edges or using CTRL+FKEY). So, there will be the five edges connected to the middle point in the second row from the bottom and only three to the vertex, mentioned by previous user. Then just move this lowest, centermost, vertex by Y on 0.4

Press CTRL+WKEY to save your work!

**Subsurfing**
Go to Object Mode (TAB), and make sure the penguin is selected. Then check for the Modifiers toolkit in the Buttons panel. Press Add Modifier → Subsurf.

Look at the penguin now, he’s much smoother. You can alter the levels of the subsurfing if you like, but I’ll settle for level one. Under the Links and Materials toolkit, you can press the Set Smooth button as well, which makes the penguin really slick.

**Note:** you may see some weird effects at the bottom and the tail after subsurfing the penguin. Then, there is an issue with normals: they have to be all pointing outwards. This can be achieved by selecting all vertices in Edit Mode and recalculating the normals outside (CTRL+NKEY). Click on the message to confirm. Note that CTRL+SHIFT+NKEY will turn the normals inwards and that WKEY → Flip Normals flips them.

---

**Extra**

The penguin can be colored or textured, but that will be part of later tutorials!

This is what the penguin (sans tail) looks like, textured and ready. Orbisnitrum

The eyes are there, just not easily visible in the thumb. At the top of the white part, two faces on the chest were subdivided to give the white more of a curve at the top. The faces were selected that were going to be white, and the I used

A pretty basic picture of a penguin. I subdivided the stomach and eyes, but then I also added some eyeballs by making a UVSphere, cutting the top of it off, and then placing it inside of my penguin’s
seperate (P) to make them a different mesh. I used a white material for the chest, black for the body, and grey uv spheres for the eyes. Apparently, an easier way to colour the chest can be found at Multiple Materials (http://www.blender.org/documentation/htmlx4448.html)

please feel free to replace this with your own image of the penguin you made, with comments on how you put your own style into it --Most recent is Bnty 11:35 PST, 19 May, 2006

head. All the colors have specular colors, giving the penguin a slight blue glow under the black.

Next Page: Die Another Way
Previous Page: Modeling a Gingerbread Man

Die Another Way (dice modeling)

Next Page: Die Easy
Previous Page: Penguins from spheres

Introduction

In the following tutorial you will be creating a die. You will use:

- polygon mesh
- face loop cutting
- spin dup
- subdivision surfaces
- subdivision creases
- bevel
- set smooth
- multiple materials
- extrusion
- merge vertices
- remove doubles
- constraints

There are two methods to create the circles for the die: subdivide first and manual sizing. In either case, start with the default Cube.[pic1.png]
Subdivide First

The die needs to have a 3x3 matrix for the colored dots (pips). A quick way to do this is to simply Subdivide the cube twice before doing anything else. The disadvantage may be that the spaces for the pips may not be exactly the size that you want. If not, see the next section: Manual Sizing of Pips.

Manual Sizing of Pips

Step 1

Hit tab to go into edit-mode and select all faces to prevent bevel messing up normals. Hit WKEY → Bevel, Recursion → 1 (you'll see why later) then choose bevel size (hit spacebar for manual input). Bevel of 0.150 is ok.

Note: if you have chosen to subdivided twice the die and to jump to Step 10, put bevel of 0.17 in order to have pip's edges of length 0.34

Step 2

In editmode, go to the Editing tab (F9) and look at the Mesh Tools 1 panel. Turn on Edge Length and note the length of one of the sides of the square faces. This should be 1.7 if the above settings were used.

Button "Edge Length" may be outside the screen so you may need to close another set of buttons before you can get to it.

Or, you can use MMB to scroll over to see the Mesh Tools 1 panel with "Edge Length" button on it.

Step 3
A typical die has a grid of 9 possible positions for the pips and the gap between the pips is the pip radius (or half the diameter). So, there are conveniently 10 units on each edge of the square faces, where the gaps use 4 of the units and the 3 pips use two each. This means the gaps are of size 1.7/10 = 0.17 and the pips (1.7x2)/10 = 0.34.

![Diagram of a die grid and gaps](Medidas.jpg)

### Step 4

Now it's time to subdivide the surfaces of the die according to the mathematics above. We'll do that using "edge loops" - additional edges you can add to existing objects.

- Select axis aligned view: **NUM1**
- Enter loop cut mode: **CTRL+RKEY** (OR **KKEY→1KEY** OR **KKEY→Loop Cut** OR **CTRL+EKEY→Loopcut** OR **CTRL+EKEY→NUM5**)
- Select loops' placement: move the mouse around until you see a purple line going the right direction.
- Enter the number of loops: **9KEY** (OR **NUM9** OR **SCROLL** up 9 times OR **NUM+** 9 times)
- Add the loop: **LMB** (OR **ENTER** etc.) on one of the big faces

Now we just have to get rid of the 2nd, 5th and 8th loops to make the undivided spaces for the marks.

- Select edge select or vertex select: **CTRL+TAB→NUM2** (OR **CTRL+TAB→Edges** OR **CTRL+TAB→NUM1** etc.)
- Deselect all edges with **AKEY**
- Choose a loop to remove (using the BKEY to enter box selection mode and drawing a box around the one you want; this will get the whole loop, all the way around the cube). **Spoiler:** you can also use **Alt+RMB** on an edge to select a loop.
- Remove loop: **XKEY→7** (OR **XKEY→Edge Loop**)

Change views with **NUM3** and **NUM7** and repeat steps as necessary. When you're done, your die should look like the one pictured to the right.
Creating Pips

The die needs the pips added. Everyone knows how the pips on a die look, right?

**Extrude and Merge**

Select one of the faces where a pip would go and extrude the face by hitting EKEY and then ESC. Do not click after hitting EKEY. This actually replaces the first face with another one. Merge the second face by using ALT + MKEY to merge the 4 corners into the center. It will tell you Removed 3 vertices. You should get the following:

Do this for the configuration of the dots on that side. So for example, 5 would look like this:

Notes :

- You could create this pip spot on all 9 spots and copy this side of the die to the other side. The amount of time spent doing all of that may be just as long as doing each side individually. You would need to delete the other 5 faces, copy the dented face 5 times, place each face precisely by rotating and moving, and remove doubles.

**Create Pips**

Select one of the edges of the pips to check the size is 0.34.

Remember the pip radius was 0.17. We need to use this value to lower the centre point of the pips. Select all the 5 centre points at once to save time and move them inwards by 0.17. The side I put the 5 pips on here was the top so I move the vertices inwards by pressing GKEY, ZKEY, -0.17 and hitting ENTER. I then get this:
(user comment) According to step 4 we are still in front-view (NUM1), but then the ZKEY modification gives undesirable result, changing view to top (NUM7) does the trick! This applies to blender version 2.44.

**Smooth Out**

**TAB** out of Edit Mode. If you haven't done this already, hit Set Smooth in the Editing panel and turn on subdivision surfaces
It should look something like this:


In present versions, you just need to use "Add Modifier" on the Modifiers tab (in Edit-mode), to add a SubSurf modifier.
In the image below Levels is set to 3.


**Make Sharp Edges**

On a die, the edges of the pips are usually sharp so we'll use subsurface creasing to do that.

Go back into editmode and with the edge select mode on, select all the perimeters of the pips like so (it may help to turn off subsurf for the moment):
Press **SHIFT+EKEY** to enable creasing and move the mouse until the display says crease is at 1. After pressing **SHIFT+EKEY**, you can then set crease values in the information box that you get by pressing **NKEY** when objects are selected. This can be useful to check if all the edges have the right crease because it gives you the average crease value and if it is less than 1, there is an edge wrong.

### Repeat

Repeat steps 10, 11 and 13 (that is Extrude and Merge, Create Pips and Make Sharp Edges) for all the sides of the die. REMEMBER, a die is numbered so that opposite sides add up to 7. In my example, that means I put 2 on the bottom etc. Once you finish, if you turn on subdiv level 2, you will get something like this:

![Die with pips and creases](image)

### Camera Setup

You can make a test render now to see that the pips are the right size and that the bevel is right. So, turn the subdivision level for the rendering up to 3. To help position the camera so that you centre the die, you can make the camera look at the die by adding a track-to constraint to it. I prefer to track an empty though, because it is more flexible.

Make an empty by going into top down view (**NUM7**) and hitting **SPACE → Add → Empty**. It’s always best to go into one of the set orthographic views so as to align new objects to the axes. If you add something misaligned, just go to the object menu then clear/apply > clear rotation (or **ALT+RKEY**). Because the empty was created at the origin, you might not be able to see it as it is inside the die. Hit **ZKEY** to enable wireframe mode and select the empty. Just move it outside the cube until we get the constraint set up.

To add a track-to constraint, select the camera first then **SHIFT+RMB** the empty and press **CTRL+TKEY** and choose "TrackTo Constraint" from the list. Move the empty back inside the die. You can edit constraints in the object tab (**F7**). Add a couple of lamps (both intensity 1) to get the scene.
Another way to position the camera is by selecting it and then looking through it as you move it. Look through the camera by pressing **NUM0**. Use the **GKEY** to pan across and rotate around the local axes of the camera by pressing say **RKEY, XKEY, XKEY** to rotate in X-axis. To zoom in and out press **GKEY, ZKEY, ZKEY** and then move your mouse forwards or backwards. Another useful keystroke (for pre-2.43 especially) to know is that when you are in camera view, pressing **Gkey** and then **MMB**, movement will be conained to the way you are facing. The **mouse wheel** zoom moves your view towards and away from the camera, without actually moving the position of the camera.

---

**Render**

To render, set the size of the image you want. 800x600 is a decent size so put these settings in the format panel in the Scene tab (**F10**). In the render panel, make sure 100% is selected. If it’s 50%, the render will come out as 400x300. For preview renders, don’t turn on OSA, which is anti-aliasing because it slows your renders down significantly. Try to only use it for a final render.

Another important point is to set the image format. This is done in the format panel. The listbox has a number of image types. I find that png is generally the best because it is lossless and offers the highest compression among the lossless formats. It also supports an alpha channel for transparency. When rendering animation, it is better to render as an image sequence than as a movie because it is easier to edit these and repair broken frames. Quicktime supports loading of image sequences and you can save as a movie using a wide range of compression formats.

To save the render, go to the **file menu → save image** and type in the full name of the image including the extension e.g. die.png.

The output should now be looking something like this:

Image: DieAnotherWay16.png

---

**Color**

**Multiple Materials**
To give it some colour, we will need to use multiple materials because a typical die has pips that are a different colour from the die itself.

In the **Buttons Window** go to the **Editing panel** (F9) again and make sure the die is selected. In the **Links and Materials** subpanel there is a section for materials (the left; the right one is for vertex groups) and the box left of the question mark should read "0 Mat 0" (the first number is the number of material links for this object; the second number is the number of the currently selected material link).

The die may have more than zero materials if you had assigned materials to the object already. By pressing the **New** button add enough materials to make 2 in total.

Go back to the **Shading** panel (F5) and there is a box at the very top of the **Links and Pipelines** subpanel with the number 2 beside it. If there is no such subpanel select **Material buttons** (cycle shading buttons using F5 too). Click this number and select **Single user** in the dialog to make the two materials you’ve just created independent. Use the arrows on the left side of the box to switch materials.

**Note:** There should be at least two materials now. One has the materials initial name the other has a number appended to its name (e.g. **Material** and **Material.001**).

Use the **Material** subpanel to make material 1 bright red by just picking red in the colour picker (the rectangle to the right of the **Col** button) or by setting the RGB sliders (left of the **Col** button). Make material 2 white by doing the same. Or pick whatever colour you prefer and material settings.

**Note:** It is possible that the two materials were not automatically linked to the material links of your die. If so use the **Links and Pipeline** subpanel to link the materials to the respective material links. First select the link then the material.

**Assign Materials**

These colours need to be assigned to the right parts of the die.
Go into **Edit Mode** and turn off subsurf to make selecting easier. Do this in the **Editing** panels (**F9**) **Modifiers** subpanel. Right after the subsurf modifiers name there are three buttons (darkgrey). Press the rightmost to deactivate the modifier in the edit mode.

Now select the inner faces of the pips - if you accidentally don't press **SHIFT**, press **CTRL+ZKEY** or **UKEY** to undo.

**Note:** Here you may find **Lasso Select** useful.

- Make sure you are in **Edit Mode** (**TAB**)  
- Select **Face select** `CTRL+TAB→3KEY`  
- Select **Limit selection to visible** `CTRL+ZKEY` should be the second button from the right in the header of the **3D View**  
- Go through the axis align views and select the faces:
  - Align view: **NUM1** (**CTRL+NUM1, NUM3, CTRL+NUM3, NUM7, CTRL+NUM7**)  
  - For each view, lasso select the pips' faces: hold **CTRL** and drag **LMB** around the pips' middle vertex (no need to press **SHIFT**, **Lasso Select** automatically adds the new faces to the previous selection).
- If all went well you should be able to read **Fa:84-449** in the **User Preferences** right after the Blender version number. (84 = 4*(1+2+3+4+5+6))

Once they are all selected, go to the **Editing** panel **F9** again and in the **Link and Materials** panel select the colour for the pips by selecting the appropriate material link. There is an **Assign** button below - press it to associate the pips' faces with the selected material and it will make the pips white but the die remains red.

Turn subsurf back on (**Modifiers panel**→subsurf modifier→enable in edit mode) and render **F12** with OSA (only put it up as high as you need for the resolution of the image you are rendering).

*(Note from Noob: When I did this it didn't work. Please could the author give better details on WHAT to do and WHICH material to choose)*

*(Note from Noob 2: When i tried this, my pips were assigned with the desired color, but they were not round dots, they became squared. -> Solution: I forgot to crease, see above)*

*(Note: in Blender 2.44 you should use the Assign button in the editing panel (Link and Materials))*

**Extra**

The reason I modelled the die this way is because it is also very easy to change the sizes of the components e.g. the bevel and the pip size. You do this by selecting the vertical or horizontal segments and just scaling them in one axis. Here we will reduce the pip size and the bevel by half.

Go into front view (**NUM1**), turn off clipping and select a line containing pips. Then just scale in one axis e.g. **SKEY**, **XKEY**, 0.5. Remember to have your pivot point set to median:

Image:DieAnotherWayE1.png

Do this horizontally and vertically around the die. You should need to scale 9 times for the pips and 6 times for the bevel:
(Noob note: I find this confusing. what is a line containing pips? does this mean a loop line? Using alt-RMB no longer works to select a loop, but selects a single edge.)

Image:DieAnotherWayE2.png
You may need to add extra geometry once you are satisfied with the sizes of the dots and the bevel so that the edges of the die don't look warped due to the subdivision. You can use face loop cut again for that and add extra lines in the middle of the gap segments.
Image:DieAnotherWayE3.png

Next Page: Die Easy
Previous Page: Penguins from spheres

(user comment) at the top it says that this page needs to be edited to address 2.42 users. I say if you are going too edit this page edit it for a more up to date version of blender namely 2.44

Die Easy (dice modeling — revised Die Another Way)

Next Page: Die Easy 2
Previous Page: Die Another Way

Model a Silver Goblet

Next Page: Model a Silver Goblet cylinder
Previous Page: Die Easy

--noob note This tutorial seems to be missing several steps. Many steps are unclear.]]

Basic Shape

On first pass, the goblet looks like it is composed of a cylinder(s). While it is possible to model the goblet with a cylinder mesh, we can just use a cube. What is the benefit of using a cube? It is faster to make and there are fewer vertices to track.

--Chuey 14:22, 6 June 2007 (UTC) (Noob) Fastest way I use to make any cylindrical object is to first create a cross-section of half the goblet using vertices connected by edges. Then place the cursor on the center vertex and revolve around the center axis (Editing – Mesh Tools – Spin Button) 360 degrees. This allows you to create complex geometry very easily. See Also: The earlier Simple Person Hat Tutorial explained how to do this.

Starting with the default cube in NUM 7 view and Edit Mode, extrude the top face three times. Scale each extrusion vertices to create the first knob. This example scaled E1 and E3 to 0.300 and E2 to 0.700.
Continue extruding up. This design will take 12 total extrusions - 3 to make the first knob + 1 for the stem + 4 to make two upper knobs + 4 for the cup.

After moving and scaling the first 10 extrusions, select the top 8 vertices (shown below). Scale these in along X and Y to 0.900. This will make them only slightly smaller than what will be the outside of the cup. Pull E11 down so that it is level with E10. This makes the rim. Finally, pull E12 down inside of the cube to form a container.

**Smoothing and Defining**

note- after smoothing make sure to flatten the bottom it makes it look better.=)

Time to take the mesh and turn it into a proper goblet. Add a subsurf level 2 to the mesh. Change to Object Mode (TAB) and select the Set Smooth button under Links and Materials. The cube-looking mesh will now look like an object that was created from a cylinder.

We want some of the edges back so return to Edit Mode. Select edges to make more defined and crease them (SHIFT EKEY) to +1.000. I've turned on Draw Creases under Mesh Tools 1 to illustrate which edges have been creased (highlighted yellow) in this example.
Note: Due to the vagueness of this tutorial I had problems trying to follow what was wanted. I got around it by beveling the goblet (for the cup-edge/thickness), and then merging necessary vertex. Here is how it turned-out:

Goblet (http://i88.photobucket.com/albums/k185/captheathmalc/gobletinblender.jpg) Render (http://i88.photobucket.com/albums/k185/captheathmalc/goblet.jpg)

That concludes the creation of the goblet. Save the scene for use in the lighting tutorial. To jump to the relevant lighting section, go to Blender 3D: Noob to Pro/Light a Silver Goblet

Next Page: Simple Vehicle Part I
Previous Page: Die Easy

[Edit by overly excited guy:] Okay, this is pretty much just because I wanted to show off my work, but also because transparency was really hard to find and really easy to actually do. I don't know if there's a lesson on transparency in this, but I really wanted glass, and I'm impatient. This little bit is for anyone else who's interested in modeling the goblet as glass and is impatient like me. (The transparency is only in render- 3Dview will show it solid regardless.)

The following images show the settings needed, and the final render of my green glass goblet.

In Materials is an Alpha slider- goes from 0.00 (invisible) to 1.00 (opaque). It needs to be pretty low, less than .25, I'd say. Also in the Edit buttons (F5) is a section called "Mirror Transp", for me it's a tab between "Shaders" and "SSS". In here the "Ray Transp" button must be on. The IOR value is refraction rate- the value of glass is 1.51714. Next to that is Depth, determines how deep to apply
transparency. I recommend maxing it to 10, to play it safe.

If you want a shadow, you'll need to create a plain and go into the "Shader" settings for it. Turn on "TraShado", otherwise the shadow will be a flat black one and look all wrong.

Here's the final result:

Simple Vehicle

Next Page: Simple Vehicle: Wheel
Previous Page: Model a Silver Goblet

Overview
The idea of this tutorial is to learn to face a complex project. A vehicle is a nice object to use to test yourself and find new problems.

First, we must understand that a project does not reproduce the real world; a project shows an idea or thought and will result in a final image or video. Whatever does not appear in the final result is unnecessary to include in the model.

What vehicle should we make? Let's go with the classic jeep. This will allow for a lot of doodads.

Let's decide what objects of the jeep model will need to be made - body, wheels, seats, and a rocket launcher for good measure. Objects we can ignore include the engine, which remains hidden under the hood. There are many additional objects you can make such as seats and steering wheel to customize your jeep.

### Techniques

You should already know how to:

- Make a mesh
- Navigate the viewport
- Extrusion
- Create, edit materials

This section will recap and introduce:

- Forming faces
- Subsurfing
- Merging vertices
- Object naming

### Pre-constructed

For our premise, envision jeep tires. They're not too sleek but rather rugged for all kinds of terrain. We need a tire that can handle any obstacle in its way.

If you want to skip making a tire from scratch, take an existing model you can find the tires at: "http://www.e2-productions.com/bmr" released under the Blender Artistic License.

Choose one, reduce the hole and enlarge the bump.

### Model from Scratch

Start with the viewport in XZ coordinates (NUM1). Add a tube (Space > Add > Mesh > Tube)
specify the number of vertices to use. This example we'll use 32. (If you are using Blender version 2.43, add a cylinder **(Space > Add > Mesh > Cylinder)** and un-click the "Cap Ends" button.)

Now scale the tube to a size of 4. With all the vertices selected, extrude the individual faces into the circle (Make sure to select INDIVIDUAL FACES not Region). Hold **SHIFT CTRL** while extruding the faces until the sides come in -1.300 units, or just type in -1.3 and hit enter (in older versions of blender hit **NKEY** first)

(A Noob: - In v2.43, we have to set ratio, so it should be -0.13)
(Another Noob: I think he means radius 4 and really -1.3 my version is 2.44 ) (Noob: its just extrude -1.3 thats it, no confusion.

Rotate around the model and you'll notice the outside of the tire doesn't yet exist. Let's remedy this. Go back to **NUM1** view.

(A Noob: Note that this looks exactly like a fan rotor or a paddle wheel. Something to remember if you ever need to model one.)

Invert selection **(Space > Select > Inverse)**
Press **FKEY** to create the missing faces
Select **auto**

**NOTE:** In Blender 2.42a pressing F gives a menu with Make and Clear options. Choosing Make
Now it's time to make the tire look like a rugged tire. Apply a subsurf of level 1 or 2 to the mesh. The tire will now look like a bead necklace. [Edit:] If not, remove doubles.) A little creative use of creases will restore our tire.

Turn off the Limit Selection to Visible. Enter select edges mode and bring up the circle selection tool (AKEY to unselect all, then BKEY twice). Use the scroll wheel to change the circle selection size to be in the center of the tire, between the inside and outside edges. This will select all of the inside edges, as well as the triangles on the side of the tire, as in the picture below. Crease these edges to 1.000 (SHIFT EKEY).

(noob note: DO NOT turn the 'limit-selection' tool on for the above selection.)

The tire is almost done. Let's add a simple hubcap to it. In NUM1 view, add a tube mesh (32 vertices) and scale it up a bit to make it easier to work with. Again, if you are using Blender 2.43[edit:2.44], add a cylinder and make sure the "Cap Ends" button is turned off. (noob note: Scale it to about 1.7, I think) (Note: If you are using Blender version 2.43 it IS NOT necessary to add a cylinder.) (noob note:

Change back to vertices select mode Ctrl+Tab>vertices)

Set the view to NUM3 and pull the tube out of the tire along the Y-axis. Reduce the length of the hubcap to about 0.5 unit. Select the left half of the hubcap vertices and return to the NUM1 view.
Scale these vertices and pull them inward. Keep the vertices selected.

Use extrusion (Only Edges) and then press **ESC**. This will duplicate the vertices and place them at zero, which in this case happen not to be on top of each other.

We'll merge these vertices together to create a flat surface. **ALT MKEY** will bring up the merge window. Merge the vertices at center. Blender will reduce the 32 vertices to 1. Keep the 1 remaining vertex selected, enter **NUM3** view, and pull it along Y into the hubcap.

The final mesh editing is to select all of the hubcap vertices (easiest in the side view), scale up to slightly larger than the hole of the tire, and move back into the tire along Y. (Noob Note: Hold the cursor over the hubcap and press **LKEY** to select all vertices easily)

The last thing to do is to rename the wheel so we can find it easier later. Enter Object mode and select the wheel only. In the Link and Materials subwindow in Editing (**F9**) you'll see the Active Object name box. It should read OB:Tube in the grey box. This name was created because we started with a tube mesh. Click on the button and rename the object to something like 'wheel'. Save your file where you'll find it later and continue to the next step.

Resulting jeep tire:
A Noob: How come when i change the name in links and materials, save, then load it the name goes back to cylinder?

### Optional

Change the materials to make it look like a tire. One object can have multiple colors/textures. Refer to the materials section for an explanation on how to do that.

**Next Page: Simple Vehicle: Seat**

**Previous Page: Simple Vehicle**

Simple Vehicle: Seat

**Next Page: Simple Vehicle: Rocket Launcher**

**Previous Page: Simple Vehicle: Wheel**

### Techniques

You should already know how to:

- Make a mesh
- Navigate the viewport
- Extrusion
- Subsurf
- Crease edges

This section will recap and introduce:

- Loop subdivide
- Small, consistent vertex movement
Basic Structure

The design will be a utilitarian bucket-type seat. Start in **NUM 1** view of the default cube and rename it. Extrude the cube multiple times to make your basic shape. In this example, a 3x3x1 block composes the body with one cube coming out the top for the headrest. The seat is the bottom cube’s front faces extruded out.

To add a little texture to the mesh, we’ll add some cushion seams. Use Loop Subdivide (**CTRL R** or **K > Loop Cut**) and you’ll see the pink selection loop. You can use the **NUM+** key to increase the number of loops made at the same time. Press **NUM+** 3 times to form 4 loops and **LMB** the center column of blocks. You may also find it easier to add them one at a time in the correct place, than inserting them and then moving them.

(To get multiple Loops instead of pressing + just press the number of loops you want in this case "4", this is a fast easy way to achieve this)

Go into ZK view (**Num 1**) and make sure the view is orthographic (**Num 5** to activate/deactivate orthographic view). Place the 3D cursor on one of the sides of the head rest. Set the pivot to 3D cursor and select the two closest loop cuts. Scale it down on the X axis to 0.3. The goal will be to have one vertex go into the cushion and then one come back out to create an indent.

- Noob note: You should remove doubles at this point (**TAB** to edit mode > **WKEY** > Remove Doubles). When I removed doubles before adding the loop cuts, I found that they did not loop around the bottom of the seat correctly, and when I did not remove the doubles at all, I had trouble forming the seams in the next few steps.

Since this is a 3D object, the back seams will move along the Y axis (green) and the seat seam will
move along the Z axis (blue). In overhead view (NUM 7), select the back seam vertices and the front seat seam vertices with a group select command, making sure the Select Only Visible button is off. To move these back just a little, grab them (GKEY), move only along the Y axis (YKEY), and type in a small number using the NUMPAD. For example, type in .05 ENTER.

The next step is to add the horizontal seams. Switch to NUM 3 view and move the seam vertices down using the same method. In this case, you’ll notice that a positive movement will be the wrong direction. To move them down, make the value negative. The correct key sequence is .05 NUM-ENTER. Remember that the minus sign is pressed after the number is entered.

Add a subsurf modifier to the object. Select the edges between the back and seat and crease them. Crease any edges you feel like to create your perfect jeep seat.

- Noob note: If your seat is noticeably misshapen after adding the subsurf modifier, you may just have to delete internal faces in your model. TAB into edit mode, and hit ZKEY to get into wireframe mode. Click the face select button and look for faces that are totally inside the model. There will probably be a couple vertical faces (in YZ-plane) under the seams in the seat. I found a few elsewhere, also. Deleting all these cleared everything up.

Next, resize the seat height and widths.

As a final touch, the seat can be made slightly more concave to look like it would hold a person better.
This final seat renders to:
Techniques

You should already know how to do:

- Previous Simple Vehicle techniques

This section will recap and introduce:

- UVspheres
- Changing object's center

Overview

Two assumptions are going to be made here. One is that the rocket will not be launched in the future (use separate objects if you want to do that). The other is this is going to be a simple, simple design.

If you want to add options to your gun (think sight, trigger), go for it!

One Tube, a Rocket & a Launcher

Start a new file and delete the default cube. In **NUM 1** view, add a cylinder mesh with 24 vertices. We'll use 24 because the default 36 is overkill and will only increase rendering time. Rename and elongate the cylinder along the Y axis. This will be the length of the launcher. We need to add the rocket and the back opening to this.

Extrude the ends (region) - 7 times on one end and 2 on the other. The 7 extrusions will get folded to make the tube and the rocket.

![Image of the tube with extrusions]

We'll start with the easy part. On the end with only 2 extrusions, scale the two end vertices circles to about 0.7 by using the **CTRL** key. Next, move the first extruded vertices back flush with the original ones. Then pull the second extruded vertices inside of the cylinder. What will happen is a tube with thickness will be created on this end.
Now that we know what the tube looks like on one end, let's start the other. Scale the first and second extrusions to 0.7 and make the tube as you did before. Time to fold out a rocket head.

Take extrusions three and four and scale them to a value less than 0.7 (0.5 for example). We are making a cylinder that will fit inside our tube and be coming out.

Extrusions five and six will be the flat head of the rocket. Extrusion seven will bring the tip back to a point so just scale it down to 0.2. Move the vertices along Y to create the shape of rocket you desire.

The Mount

Having a launcher is nice, but we'll need to affix it to the jeep somehow. Let's add a mount to the tube. Think easy. Add a cylinder, scale, and move it to the bottom of the tube.

The easiest way to have a wide range of motion for the launcher is to use a ball joint. We can simulate one by just adding a UVsphere. The default 32 segments and 12 rings will be fine. This creates a smooth sphere. You can think of the number of segments as being the wedges visible when the sphere is viewed as you added it. The number of rings then could be described as the depth of the sphere from that same view.

Resize and place the sphere at the new cylinder arm.
This next step will be important for continuing the tutorial. Get the 3D cursor to as close to the center of the sphere as possible. While the sphere is still selected after creation, you can press **SHIFT + S** and snap cursor to selection, putting it in the exact center of the UV Sphere. Switch to Object Mode. Under either the Object menu or **SPACE** go to Transform > Center Cursor. This should move the large pink dot where the cursor is located. This will give it a new center of gravity around the ball joint, making it easy to manipulate later.

Apply materials or additional items to the object and save for later use.

Do not forget to name the rocket for later use.

**Next Page: Simple Vehicle: Body**

**Previous Page: Simple Vehicle: Seat**

Simple Vehicle: Body

**Next Page: Simple Vehicle: Some Assembly Required**

**Previous Page: Simple Vehicle: Rocket Launcher**

**Techniques**

You should already know how to:

- Make a mesh
- Navigate the viewport
- Extrusion
- Form faces
- Name objects

This section will recap and introduce:

- Deleting and creating edges
Planning

Think about what you want your jeep body to entail. As always, consider where the major sections will need to be made so that you don't have to backtrack later to accommodate your idea. Feel free to make your own body design; here is one I made up.

The Basics

Start a new file. Take the default block and extrude it into your sections along the X axis (NUM 1 view). In this design, the sections are being designed to include the back, flatbed, doors, dashboard, window, and hood, left to right. The window is extruded straight up (older jeeps' windshields aren't slanted), and I decided to add a lower back to later hold the bumper/lights if you wanted to add them.

Widen the jeep body. Use the proper views to make each step easy. The picture examples are not necessarily meant to provide the correct view you should have when editing your mesh. They are meant to show how the mesh should be turning out.

Addition: As a newbie, this step confused me. What it fails to mention is that instead of just widening the body, you need to perform a couple of extra steps to get the basic jeep to look like the pictures:

First, switch to (NUM 7 view). This is a top down view. Use the 'B' key to highlight the top row of vertices, and then reduce the width of the jeep to one square. You then need to extrude this revised jeep twice along the Y axis; once for 4 squares, and then extrude again for one square. This should give you the figure that is shown in the pictures.

Delete the proper edge along the top of the mesh where you want the cab and flatbed to be (XKEY). This will also remove the faces on the top. In vertex select mode, select two vertices (SHIFT RMB is the easiest here) and create an edge (FKEY) to make edges on the inside of the flatbed. The next step is to create faces using the new edges. In this example, 5 faces were made. User request: clarify this step. For example: which 2 vertices were selected to create a new edge? I'm not sure why creating edges is necessary, since I didn't create any, and my model came out fine. Noob observation: You can select the top two boxes where the pickup bed should be and delete them; then you will need to create edges inside the bed and fill them with faces. Alternately, you can select the top two boxes and extrude them into the body of the truck, and then you won't need to do any edge creation.

Guess: I think the problem is that there are no inside faces. The sides of the jeep have no thickness,
just an overhang at the top going in. You need to create four vertical edges and then use them to make the inside faces.

Adding the door: our jeep design will have somewhat of a cheat - no actual door. Before crying foul, many jeeps didn’t have doors to facilitate quick entry and exit. To cut out one door, select the four vertical edges where the door will go. Use the subdivide command **(WKEY)** to cut the edges in half. You’ll notice that the subdividing will also affect the adjoining faces. Do the same thing you did when the flatbed was cut out - removing/adding edges and creating new faces.

This is not a necessary step, but if you want to clean up the look of the model, we’ll get started. In face select mode, select the faces that are going to be combined. Press **FKEY** and a little window will appear titled ‘Make Faces’. Click on ‘Make FGon’ to merge the faces. As you may have guessed, if an FGon face is created and you want to later undo it, select the ‘clear FGon’ option in the Make Faces window.

Go ahead and resize the widths of the bed and windshield. Always move as many vertices or edges at the same time to not only work faster but to make sure they are moved equally. The use of **SHIFT** while moving vertices is very helpful in fine movements.

If you want an object to come to a point such as a wedge from a cube, merge vertices. In this example, the lower back area will be modified. Select two vertices to join together and press **ALT MKEY**. Select the option for your merging. ‘At First’ or ‘At Last’ will probably be the option that will work here. Play around to see what each merge option does. After the merging, Blender will tell you how many vertices were removed.
Extrude the bed surface upward. This is only useful in hiding the tires that we'll add later in the tutorial. Alternatively, you could make two boxes to hide them.

**A Touch of Detail**

Let's add some detail to the model - how about the hood? First thing to do is add some edges to the front of the jeep. Press **CTRL RKEY** to enter Loop Subdivide. A pink loop will appear around the mesh. Put the cursor over the area to get the example picture to appear. When the loop is in the right place, **LMB** click. The place to put the actual cut can now be selected. Do this twice - once for each side. Move and align the resulting edges to form an angle to the front and bring the window vertices in.

*Newbie: I'm having trouble here. When I try to add a loop it gives me an error that reads "could not order loop" and then subdivides the face I tried to add the loop to.*
Extrude the hood surface up a small amount. We don't want it too high, just high enough to catch the light.

Zoom in and select the top-front hood edge created from the extrusion. Drag it out along the X axis. Select the now diagonal face of the hood extrusion. Extrude from it. The result will come out of the surface at a diagonal angle. Take the resulting vertices and move them close to the front of the jeep. **Readers note:** I have no idea what the heck this paragraph is talking about, and the pictures don't help, someone really needs to rewrite this that actually understands what is going on. I advise skipping the hood part because it is hard to understand and doesn't look like it changes much. **Other Reader:** I hope he talks about shaping the hood with the lines from the Loop Subdivide, and then extruding that profile.

The above paragraph briefly explains extruding the Hood of the jeep including a lip that comes over the front. Below are step by step pictures on how I accomplished this;

**Step 1:** In face select mode (**CTRL+TAB-faces**), select the top of the hood and press **EKEY** to extrude it. Only extrude it a small amount.

**Step 2:** Staying in Face select mode, here is the tricky part. Select the small face on the front of the hood you just extruded. Then, hit **EKEY** then **ESC**. This creates a duplicated face on top of the one you selected. Do not click or move the mouse between these two keystrokes.
Step 3: Now deselect the selected face by hitting **A** **KEY**. Then enter Edge select mode (**CTRL+TAB**-edges) and select the top edge of the face you just deselected.

Step 4: Hit **NUM 1** to go to the side view. Now using the red X arrow pull the edge out a little further than you pulled up the hood itself then hit **LMB**.

Step 5: Now rotate just enough so you can see under the wedge you just made. Go back into Face select mode (**CTRL+TAB**-faces) and select the face on the underside of it.

Step 6: Go back into side view with **NUM 1**. Now hit **E** **KEY** to extrude the face a little with the mouse. When it's a good size hit **LMB**.
Step 7: Now make sure the "Select only visible" button is turned off and go into Vertex select mode (CTRL+TAB-vertices). Play around with the vertices pulling them a little closer to the front of the jeep. It's best to select using the box select (BKEY) or the Lasso (CTRL+LMB).

The end result should be an extruded hood with a lip.

Alexwill84 08:23, 27 April 2007 (UTC)

In the topdown view (NUM 7), add a plane. Extrude an edge twice to result in three connected planes.

Pull the sides down to form a trapezoid shape and reduce the width. Once it is in the desired shape, select the three faces and duplicate it. Press SHIFT DKEY and all selected vertices, edges, and/or faces will be duplicated. The copy will automatically be grabbed for moving.
Move the duplicate to the jeep body and repeat the duplication two more times for a total of four fenders.

We'll move on to making a tripod support for the rocket launcher. Add a cylinder mesh with 12 vertices then scale and size it so that it looks like a tube. Once you have it to a size you like, duplicate it twice for a total of 3 cylinders. Rotate two of the cylinders in the **NUM 1** view by **LMB** clicking on the white circle that appears when the cylinder is selected in rotate mode. The picture on the left is an example of the end result.

Change to overhead view (**NUM 7**) and put together the three cylinders so the tops come close together. Now all three can be selected and moved or rotated accordingly.
Move the tripod onto the jeep flat bed. The final steps are to select your materials and rename the object (described in the wheel section). This will complete our simple jeep model.

**Optional Activities**

Feel free to add anything you see fit such as bumpers, guard rails, doors, steering wheel, lights, etc. You can either have them on the same object or separate objects (useful if you want to move them around). Note: If you subsurf the result from this tutorial, you will get a bad looking result, please try not to subsurf the jeep.

Next Page: Simple Vehicle: Some Assembly Required
Previous Page: Simple Vehicle: Rocket Launcher

Simple Vehicle: Some Assembly Required

Next Page: Model a Low Poly Head
Previous Page: Simple Vehicle: Body

**Techniques**

You should know how to:

- Do everything discussed in previous tutorials

This section will recap and introduce:

- Append a file
- Duplicate an object

**Overview**

The objects for the simple vehicle have been made if you have followed all the previous Simple Vehicle tutorials. Putting it all together will come very easy now.
Appending the File

If you have the jeep body file open, keep it open. Otherwise, open the file for the jeep body. In Object Mode, go up to File > Append (about 3/4 of the way down the menu). The find file window will appear. Go to the location where the jeep seat was saved. When the .blend file is clicked, you’ll go into it as if it is a directory.

Here we have the categories of Camera, Lamp, Material, Mesh, Object, Scene, Text, and World. We are interested in the seat object, so click on Object. Now there are three items: Camera, Lamp, and Seat. That is, it will say Seat if you named your object Seat. This is why it is useful to rename your objects, materials, etc. If you forgot to rename the object, it will be called Cube (default for our starting mesh).

What should happen after selecting Seat and the button 'Load Library' is the seat will pop into our file where the 3D cursor was. It will definitely need to be scaled, rotated, and/or moved to the right position. In my example, I rotated the seat about the Z axis -90 degrees by pressing RKEY ZKEY NUM9 NUM0 NUM-.

After placing the seat in the jeep body, let’s make another so we have a seat for the driver and passenger. Still in Object Mode with the seat selected, duplicate it (SHIFT DKEY) and slide it over. After duplicating it, it will automatically go into grab mode. If you RMB or ESC, it will still be duplicated - just sitting on top of the original.

Rinse and Repeat

Append the file again to place the wheel object and rocket launcher in the file. Scale, rotate, move, and duplicate each object accordingly. Depending on the position of your camera, you may or may not have to make all four tires. Remember that the only important parts to draw are those that will be seen!

Set the ball over the tripod. The fun part is rotating the rocket launcher since the center of it has been moved to the ball joint.
The last thing is to apply materials to your objects if you haven't already. I'll point you to the materials section for information on that. I would suggest that the window be assigned a transparent material by making the Render Pipeline wire for example. **User request:** explain in more depth how to make the windshield transparent **User reply:** if you quit out of this tutorial while staying in that section of the book, there is a section called "every material known to man" (its near the bottom of the tutorial list) and there are several kinds of glass there.

The final result of a simple jeep:

---

**Next Page:** Model a Low Poly Head  
*Previous Page:* Simple Vehicle: Body

Model a Low Poly Head

---

**Next Page:** Building a House  
*Previous Page:* Simple Vehicle

---

**How to Model A Low-Poly head in Blender**

This tutorial is designed to teach users to make a low-poly animesque head in Blender.

All of the pictures were made by me as Blender3D screen shots. They are all free for any form of use.  
**NOTE:** *Pictures go from left to right*
Overview

What you need to know:

- Basic Blender controls

Making the Model

Go into the front view (keypad 1) and add a plane.

Select the bottom two vertices (Shift + Right-Click) and press W to bring up the vertex menu. "Select Merge", then "At Center".

Now you have a pointed chin.
Select the top two vertices (use the **BKEY**) and re-arrange them so they make more of a chin shape by pressing the **GKEY** to move and **ZKEY** to constrain the movement to the Z-Axis.

Now extrude (**EKEY**) along the Z-Axis (**ZKEY**) so that you have another area.

Scale it (**SKEY**) so that it's not so cubic.
Now extrude along the Z-Axis again (**EKEY** then **ZKEY**) and scale (**SKEY**) it down a bit.

One last time... (**E** (**Z**) (**S**)

Select the middle vertices (**BKEY**) and press (**WKEY**) to bring up the edit menu again. Subdivide it once.

Now select the vertices above and below, and subdivide them.
Now subdivide these vertices twice. This will help to make the nose.
[User-Comment: To get the model shown in the pictures, subdivide only the bottom vertices you just subdivided again.]

There!

Select and subdivide here, so you can make the eyes.

And rearrange the vertices so they make eye shapes.

Make some eyes

Now select the middle vertex here (right mouse button).

Select these
Extrude it along the Y-Axis (**EKEY**) (**YKEY**) and move your mouse around to change how far it moves.

Now we make the nose. Select these three vertices (Shift + Right mouse button) and press (F) to make a face.

Let's make a nose!

Now do the same to the other side, and you will have the nose's base.

Select these vertices (Shift + Rightclick) and make a face (F). Do this to the other side.

Make a face

Now you have a nose.

Rotate the camera so you are seeing the back. Press **CTL+NUM1**. Also, change to face select mode.

Rotate the camera

You have a nose!
Select the faces behind the nose. (Shift + Rightclick) and press (X). This will bring up the delete menu. Selected "Faces" to get rid of these.

Now select these vertices (above and below(user comment: the one at the bottom of the chin, and the one at the bottom of the nose right above the first one), and subdivide them.

And select all the edges on the outside.

Move the vertices back a bit to give the face more smoothness (G) (Y) and rearrange the chin.

Now select the vertices at the back of the head, using (B).

Extrude these along the y axis (E) (Y)
Ta da!

Now select the back vertices and press (F) to make a face.

and so on....

and so on....

and so on....

now select and subdivide these once (W)

Subdivide these
and these points too.

Now select the middle and move it back (G) (Y).

Finishing it up

And here it is with sub-surfacing. You have finished. Hit (F12) to see the final render.

Next Page: Building a House
Previous Page: Simple Vehicle: Some Assembly Required

Edit Mode HotKeys Review

Next Page: Object Mode HotKeys Review
Previous Page: Model a Low Poly Head

3D View by Mode: All HotKeys | Object Mode | Edit Mode | Pose Mode
Vertex Paint Mode | Texture Paint Mode | UV Face Select Mode
Scripts Window | File Browser | Image Browser | Buttons Window
Outliner | User Preferences | Text Editor | Audio Window
Timeline | Video Sequence Editor | UV Image Editor | NLA Editor
Action Editor | IPO Curve Editor
by Key: . , A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
Relevant to Blender 2.37a

Here's a review of some of the hotkeys you've learned and some you haven't yet. This list is for use in the 3D Viewport in Edit Mode.

Edit Mode HotKeys

The Period Key

- .KEY (on the number pad) - centers the view around the current selection or active object.
- .KEY (on the alphanumeric pad) - changes the pivot point to the 3D cursor. The pivot point is the point where all things meet when scaled to 0, and the point of 0 translation during a rotation transformation. See the menu on the 3D view header, located immediately to the right of the Viewport Shading menu.
The Comma Key

- `,KEY` - changes the pivot point to the bounding box center.

A

- `AKEY` - Toggles between selecting all or selecting none.
- `ALT+AKEY` - changes the current Blender window to Animation Playback mode. The cursor changes to a counter.
- `ALT+SHIFT+AKEY` - the current window, plus all 3DWindows go into Animation Playback mode.
- `SHIFT+AKEY` - brings up the toolbox.

B

- `BKEY` - Activates box-select tool.
- `BKEY+BKEY` - Circle Select. If you press BKEY a second time after starting Border Select, Circle Select is invoked. Use NUM+ or NUM- or MW to adjust the circle size. Leave Circle Select with RMB or ESC.
- `ALT+BKEY` - Select portion of viewing area to only be visible.

C

- `CKEY` - Centers the 3D View where the 3D cursor currently is.

D

- `DKEY` - Brings up a Draw Type menu.

E

- `EKEY` - Extrude selection

F

- `FKEY` - creates segment/edge/face. If two vertices are selected, create an edge connecting the two vertices. If three or four vertices are selected, or two edges are selected, create a face connecting the vertices or edges. If two co-planar faces are selected, join the faces to create an FGon, or dismantle a previously created FGon.
- `ALT+FKEY` - Beauty Fill. The edges of all the selected triangular faces are switched in such a way that equally sized faces are formed. This operation is 2D; various layers of polygons must be filled in succession. The Beauty Fill can be performed immediately after a Fill.
- `CTRL+FKEY` - Flip faces, selected triangular faces are paired and common edge of each pair swapped.
- `SHIFT+FKEY` - Fill selected. All selected vertices that are bound by edges and form a closed polygon are filled with triangular faces. Holes are automatically taken into account. This operation is 2D; various layers of polygons must be filled in succession.

G

- `GKEY` - "Grabs" the current selection and allows you to move it around with the mouse. Use LMB, ENTER, or SPACE to drop it in place. Use RMB or ESC to cancel the move.
- `GKEY XKEY` - Grabs the selection and locks it's Z and Y position. In this mode it will only move along the global X axis.
- `GKEY XKEY XKEY` - Grabs the selection and locks it's Z and Y position on the local axis. In this mode the selection will only move along the local X axis.
- **GKEY YKEY** - Grabs the selection and locks it's Z and X position. In this mode it will only move along the global Y axis.
- **GKEY YKEY YKEY** - Grabs the selection and locks it's Z and X position on the local axis. In this mode the selection will only move along the local Y axis.
- **GKEY ZKEY** - Grabs the selection and locks it's X and Y position. In this mode it will only move along the global Z axis.
- **GKEY ZKEY ZKEY** - Grabs the selection and locks it's X and Y position on the local axis. In this mode the selection will only move along the local Z axis.

**H**

- **HKEY** - Hides the currently selected vertices, edges and faces. They will be hidden only while in Edit Mode.
- **ALT-HKEY** - Unhides vertices, edges, and faces that were previously hidden. Vertices, edges, and faces that are unhidden will be added to the current selection.

**I**

- **IKEY** - inserts a "key". Keys are used for animation.

**J**

- **ALT+JKEY** - converts triangular faces to quads.

**K**

- **SHIFT+KKEY** - knife tool. this doesn't seem to work with nurbs.

**L**

- **LKEY** - Select connected vertices under mouse pointer. (by Noob Lucio Renovato)

**M**

- **MKEY** - Brings up Mirror Axis menu.
- **ALT+MKEY** - Merge selected points.

**N**

- **NKEY** - brings up a Transform Properties mini window.

**O**

- **OKEY** - toggles proportional edit mode

**P**

- Enter the Blender Game Engine

**Q**

- **QKEY** - prompts if you would like to quit the Blender.

**R**

- **RKEY** - allows rotation of the selection. Move the mouse after pressing RKEY to rotate it. Press LMB, SPACE, or ENTER to confirm the rotation. Press ESC or RMB to cancel the rotation.
S

- **SKEY** - begins scaling (resizing) of the selection. Move the mouse to scale larger or smaller. Press **LMB, ENTER, or SPACE** to confirm the scaling. Press **RMB** or **ESC** to cancel the scaling.

T

U

- **UKEY** - undo last edit
- **SHIFT+UKEY** - redo previously undone edit

V

- **VKEY** - Rip - for example, select one edge of a cube, and press VKEY to separate and drag it away from the edges it's attached to.

W

- **WKEY** - Boolean Tools menu [*in 2.41: Specials menu*]

X

- **XKEY** - delete the selection.

Y

- **CTRL+YKEY** - redo previously undone edit

Z

- **ZKEY** - Toggles between drawing the scene in wireframe and solid mode.
- **CTRL+ZKEY** - undo last edit
- **SHIFT+CTRL+ZKEY** - redo previously undone edit

**TAB**

- **TAB** - toggles in and out of Edit Mode of the selected, active object.

**F1-F10 (???)**

- Nothing Really

**F11**

- **F11** - Shows/hides the window with the last render.

**F12**

- **F12** - begins a single frame render based on the Scene settings in the Buttons Window.

**LMB**

- **LMB** - places 3D cursor where you click
- **CTRL+LMB** - places a new vertex at the place clicked. The new vertex will be joined to any previously selected vertices by an edge.
RMB

- **RMB** - selects vertex, edge or face, depending on select mode.

### Object Mode HotKeys Review

### Next Page: Curve and Path Modeling

**Previous Page: Model a Low Poly Head**

---

### Object Mode HotKeys

#### The Period Key

- **.KEY (on the number pad)** - centers the view around the current selection or active object.
- **.KEY (on the alphanumerical pad)** - changes the pivot point to the 3D cursor. The pivot point is the point where all things meet when scaled to 0, and the point of 0 translation during a rotation transformation. See the menu on the 3D view header, located immediately to the right of the Viewport Shading menu.

#### The Comma Key

- **,KEY** - changes the pivot point to the bounding box center.

#### A

- **AKEY** - Toggles between selecting all or selecting none.
- **ALT+AKEY** - changes the current Blender window to Animation Playback mode. The cursor changes to a counter.
- **ALT+SHIFT+AKEY** - the current window, plus all 3DWindows go into Animation Playback mode.
- **SHIFT+AKEY** - brings up the toolbox.
- **CTRL+AKEY** - prompts to "Apply Changes." Size and rotation changes to the model object become permanent.
- **CTRL+SHIFT+AKEY** - prompts to convert dupliverted objects to real objects.
B

- **BKEY** - Activates box-select tool.

C

- **CKEY** - Centers the 3D View where the 3D cursor currently is.

D

- **DKEY** - Brings up a Draw Type menu.

E

- **ALT+EKEY** - Start/stop EditMode. Alternative hotkey: **TAB**.

F

- **FKEY** - In the 3D View, switches to UV Face Select Mode if selected object is a mesh. Pressing FKEY again will bring you back to Object Mode.
- **CTRL+FKEY** - Sort Faces. The faces of the active Mesh Object are sorted, based on the current view in the 3DWindow. The leftmost face first, the rightmost last. The sequence of faces is important for the Build Effect (AnimButtons).

G

- **GKEY** - "Grabs" the current selection and allows you to move it around with the mouse. Use **LMB**, **ENTER**, or **SPACE** to drop it in place. Use **RMB** or **ESC** to cancel the move.
- **GKEY XKEY** - Grabs the selection and locks it's Z and Y position. In this mode it will only move along the global X axis.
- **GKEY XKEY XKEY** - Grabs the selection and locks it's Z and Y position on the local axis. In this mode the selection will only move along the local X axis.
- **GKEY YKEY** - Grabs the selection and locks it's Z and X position. In this mode it will only move along the global Y axis.
- **GKEY YKEY YKEY** - Grabs the selection and locks it's Z and X position on the local axis. In this mode the selection will only move along the local Y axis.
- **GKEY ZKEY** - Grabs the selection and locks it's X and Y position. In this mode it will only move along the global Z axis.
- **GKEY ZKEY ZKEY** - Grabs the selection and locks it's X and Y position on the local axis. In this mode the selection will only move along the local Z axis.

H I

- **IKEY** - inserts a "key". Keys are used for animation.

J K L M

- **MKEY** - move selection to a different layer.

N

- **NKEY** - brings up a Transform Properties mini window.

O P

- **PKEY** - starts the game engine.
Q

- **QKEY** - prompts if you would like to quit the Blender.

R

- **RKEY** - allows rotation of the selection. Move the mouse after pressing RKEY to rotate it. Press LMB, SPACE, or ENTER to confirm the rotation. Press ESC or RMB to cancel the rotation.

S

- **SKEY** - begins scaling (resizing) of the selection. Move the mouse to scale larger or smaller. Press LMB, ENTER, or SPACE to confirm the scaling. Press RMB or ESC to cancel the scaling.

T

- **TKEY** - brings up a Texture Space menu. Allows translation and scaling the Texture.

U

- **UKEY** - brings up Make Single User menu.
- **ALT+UKEY** - opens undo history menu.

V

- **VKEY** - enters Vertex Paint Mode. Pressing VKEY again will switch back to Object Mode.

W

- **WKEY** - Brings up Boolean menu. Choose Intersect, Union or Difference.

X

- **XKEY** - delete the selection.

Y Z

- **ZKEY** - Toggles between drawing the scene in wireframe and solid mode.
- **CTRL+ZKEY** - the single best function of blender: UNDO!!! You can undo almost anything, and the program notifies you when doing a no-undo operation. Note: If Blender claims there are no more steps to undo, hit tab to switch to object mode and try again.

TAB

- **TAB** - toggles in and out of Edit Mode of the selected, active object.

**F1-F11 F12**

- **F12** - begins a single frame render based on the Scene settings in the Buttons Window.
Frighteningly enough, we know what you’re thinking. You’re thinking that mesh modeling is cool and all, but it would be nice if Blender had a better way to create complex smooth 3D objects, right? Ok, so you weren’t thinking that, but now you’re curious about this better way. Good. Move on to the next page to learn more.

Using Bezier Curve to Model a 3D logo from a 2D logo

{Construction on hold, feel free to complete}

The image to the left is used in this tutorial. However, the tutorial is easier to follow using letter/numbers, or simple shapes/curves. Basically we will be using the graphic as a template for a 3d logo, tracing it, then discarding the 2d image.

Set up

You need a 2D logo similar to mine (preferably in JPEG format as Blender understands jpegs fairly well). If you haven’t already done so, open blender and select one of the orthogonal view angles by pressing NUM7, NUM3, or NUM1. At the bottom of the 3D viewport on the left, there are some menus, click View-->Background Image

A small window will appear containing just one button marked use background image; click this button. A few more buttons will appear. One of them says image: and has a small button with a picture of a folder on it; click this button. You are now presented with a file selection screen. Using the navigation techniques from the previous tutorials, find your 2D jpeg image on your computer, click the file in the list once then click the Select Image button at the top right of the screen.

Blender now displays this image in the background of the 3D view for you to trace its outline. The image is only displayed in orthogonal view. If perspective view is enabled, toggle to orthogonal view by pressing NUM5. The image will not be rendered as it is not part of your scene.
Once a background is selected you’ll have a dialog like this one. (Note: This tutorial was originally generated from Blender v2.37. v2.43 has been added - older versions may differ.) The background dialog buttons are described below:

The **Use Background Image** button is a toggle button that turns display of the image on or off. Turning the button off will not clear the settings; it just hides the image. When you turn the button on again, your previous settings are back. Try it - click the button a few times. In v2.43 the equivalent button is the | Use | button.

Image selection is controlled on the row labeled **image:**. There are 2 buttons, a text box, and a final button. The first button **is** used for browsing for an image. The 2nd button **is** for selecting an image from a history list. (This will be empty for the first time. Selecting it now will display the image you currently have selected.) The text box **allows** typing in the file directly. The **button removes the current background image. Version 2.43 is the same with the addition of the **button that refreshes the image or movie, and the **button which shows the number of users of the image block.

The third row is called Texture and will not be used for this tutorial.

The fourth line, labeled **blend** controls the transparency of the background image with a slider. A setting of 0 is completely solid and 1 is completely transparent. You can adjust it by clicking left or right of the knob for gradual changes, clicking and dragging on the slider for rough settings or clicking directly on the **text for numeric entry.

The use of the blend function will become obvious once we start tracing our logo. For now, play around with it, see how it changes the image, and put it back to the 0.500 default.

The fifth line, **size**, controls the size of the image. This size setting is independent of the zoom for the 3D view window. To see how the size works move the default cube off to the side so that you can see both the cube, the background dialog and the background image. Now watch both the cube and image as you change the size. Notice how the image changes size but the cube doesn’t? Now press **NUM+** and **NUM-** to change the view’s zoom. Now both the cube and image change size.

The final row controls the X and Y offset for the image. These controls move the image up and down (Y) or left and right (X). These settings can be useful if you need to reposition the image from the default position. Like the size, these offset values are independent of the view. As you change the offset values the cube you added earlier won’t move. Now scroll the view using by clicking and dragging the **SHIFT MMB** and notice how the cube and image move together?

Once you start tracing the image you won’t be using the size or offset setting. Delete the cube (select it, press **XKEY** and select **All** from the **Erase** menu), and set the size so that the entire image is viewable. Then set both the X and Y offsets to 0. Finally minimize the Background Image dialog. You’ll only need it to adjust the blend setting until you finish tracing.

**Introducing the Bezier Curve**

The Bezier Curve allows drawing graceful, complex curves and only requires a few control points. Specifically, it only requires 4 points for a curve. Two end points and two control points.

For the moment set the blend to 1 on the Background Image dialog. With the center of the 3D view