
Pro/ENGINEER – CAD/CAM Software Tool

Introduction Manual
(Re-written for Wildfire 3)

This manual is designed to give the user a very basic understanding of the
philosophy of the Pro-Engineer Wildfire (ver. 3.0) package and its user interface.
The user is taken through the construction of a simple part, which illustrates a
number of the basic commands of Pro-Engineer, following which the user should be
in a position to explore the many other features within the ProE suite of programs.
Additional support is available in the form of web based manuals and tutorials and
if required more detailed training manuals, contact the Design Office for further
information.
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1 Key

To aid in the use of this handout a number of conventions/fonts/abbreviations have
been used to indicate the difference between keyboard entry, menu titles, menu
items etc. These are listed below:

Font Used Item

Bold/Times: menu item

CAPITALS: WINDOW/MENU TITLE

Italic: Keyboard inputs

Bold/Helvetica: Hint

Abbreviation Action

LMB Left Mouse Button

MMB Middle Mouse Button

RMB Right Mouse Button

Menu items followed by a → indicate that the user should follow the input to a
cascaded or flyout menu. N.B. In many cases the choices required are the default
and therefore do not need to be individually selected.

2 Overview

Pro/ENGINEER (Pro/E for short) is a commercial CAD/CAM package that is
widely used in industry for CAD/CAM applications. It is one of the new generation
of systems that not only offer a full 3-D solid modeller,n in contrast to purely 2-D
and surface modellers, but also parametric functionality and full associativity. This
means that explicit relationships can be established between design variables and
changes can be made at any point in the modelling process and the whole model is
updated.

The method of constructing a model of an object is very similar to that followed in
the production of a physical component. For example the manufacture of the shaped
block in Figure 2 would start with the choice of construction environment, the
selection of a piece of stock material followed by a series of manufacturing processes,
e.g. milling, drilling, welding/sticking. Pro/E has direct analogues for most of these
operations as various types of FEATURES which can be combined to generate a
complete representation of a PART, Pro/E’s terminology for a single component.
Features fall into three main categories, Construction, Sketched and Pick/Placed.
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Construction of a Part

Round/Fillet
(P&P)

Protrusion
(Sketched)

Chamfer
(P&P)

Hole
{P&P} Cut

(Sketched)Slot
(Sketched)

Workshop

Select stock

Material

Cutoff length of

Stock Material

Turn. Mill, Drill, etc

to shape part

ProEngineer

Sketch Initial

Cross-section

Use Protrusion

(Extrude, Revolve etc)

to generate 3-D workpiece

Use Pick and place, 

Sketched Feature

 to create finished part

Figure 1: Comparison of physical and ProE methods of part construction

2.1 Features

2.1.1 Construction Features

These features are purely used as an aid to the construction of the part, a number
of various forms are available the most commonly used are the:

Csys Coordinate systems which aid in the orientation of additional features and the
assembly of the part in to subsequent assemblies. CSYS feature is normally
the first feature in a part definition and is used as the basis for the placement
of all subsequent features.

Datums These are an extension of the idea of construction lines as used on a
traditional drawing. The most used type is a DATUM PLANE which allows a
2-D reference plane to be defined in space. Additional forms include DATUM
AXES, DATUM POINTS and DATUM CURVES. It is normal to add three
DEFAULT datum planes, immediately after the initial coordinate system, to
effectively generate default x-y, x-z and y-z planes.

2.1.2 Sketched Features

These features are so named because they all involve the use of the SKETCHER
mode within ProE, (see below for more details on its use). The main features that
use this functionality are:

Protrusion Using this feature material can be added to/removed from a part by sketching
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a cross-section and then extruding/revolving/sweeping the section to produce
a 3-D solid/cut. A solid protrusion is normally the first non-constructional
feature in a part, and is used to produce the base solid entity of the part. In
the material removal mode the action is similar to a turning, saw or milling
cut.

Rib This allows the user to produce a thin rib or web. This is a limited version of
the protrusion function.

2.1.3 Pick & Place Features

Pick and place features tend to refer to simple or standard operations, e.g. the
production of HOLES, ROUNDS and CHAMFERS. The action to produce the
required effect has been preprogrammed into ProE, thus requiring the user to
indicate the position of the operation on the existing model.

2.2 Modification of Features

The parametric nature of ProE means that the modification of features is relatively
easy, individual features can be selected and the associated parameters/dimensions
changed. However, it should be noted that ProE produces a HISTORY based model
in which features can be dependant on one or more previous features for their
definition, e.g. a chamfer on an edge generated by a cut or protrusion. These
PARENT-CHILD dependencies mean that when a parent feature is modified its
children are automatically revised to reflect the changes. N.B. Care should be taken
not to remove references used by child features.

3 Getting Started

The commands given below initiate ProEngineer Wildfire on the DPO/EIETL
Linux workstations and windows XP/NT/96/98 systems. If you wish to run ProE
on another system please contact your system manager.

Linux Workstations, e.g. DPO Terminals

• Login into the terminal using you usual ID/Password

• Start ProE by selecting START→3D-CAD→proewildfire3 at the prompt

Windows NT/95/98 based Systems

• Close down unused programs, ProE imposes a large load on the system

• Select Start from the main icon bar and then select Proengineer Wildfire3
from the Program submenu. (Alternatively if click on the Wildfire icon on
the desktop if a shortcut exists)
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N.B. Some systems default to starting the PTC Application Manager in response to
the wildfire & command. This is indicated by a small window in the top left hand
window, to start ProE select wildfire3 from the Start menu.

After a few seconds, depending on the load on the system, windows will begin to
appear on the screen when the start up procedure is complete the user will be faced
with a screen display similar to that shown in figure 3.

Figure 2: Basic/Start up Screen Layout
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4 User Interface

4.1 Start-up Display

At startup a single model window is displayed which contains 5 main areas, each
model which is loaded into the system will generate another dedicated window with
the same five functional areas.

1. Menu Bar Ranged along the top of the screen are a number of pull down
menus that access all the functions, many of which are duplcated in secondary
context sensitive menus that appear during normal operation. The general
operation is similar to that found in any windows compliant software. N.B.
When selected the action of the menu item is displayed in the note line at the
base of the main display area.

File File management sub menus - Including the ability to import and export
foreign file formats.

Edit Allows modification/redefinition etc of items and also a restricted ’undo’
function.

View Access to functions to change the display parameters, including
orientation, colour, transparency and resolution. (A number of these
functions are also available on the icon bar, see below)

Insert Gives direct access to the constructional tools, e.g. create holes,
protrusions.

(Sketch) (N.B. Only visible in Sketch mode) Access to functions used while in
sketcher mode, e.g. draw line, align, modify.

analysis Functions to investigate dimension and mass properties of a part. (In
multi-body assemblies, interference information is available here)

Info Information about the construction, parent-child relationships etc of the
current model.

Applications Access to additional PTC applications, see other manuals/help files for
further information.

Tools Access to functions to change the user interface, not normally required
for general use.

Window Allows user to switch input between windows etc. N.B. To change focus
to a particular part window press CTRL-A while the mouse pointer is
over that window.

CUED Menu access to a limited number of CUED/user defined Mapkeys

Help Access to ProEngineer manuals. Select Pro/help followed by Products,
in the web browser to gain access to the online ProE manuals.

2. Icon Bars Icons that mimic the functions found in the pull down menus can
be arranged in three positions below the pull down menus, and to the left and
right of the main window. These can be simmply adjusted by selecting the
RHB or via the Utilities puldown menu.
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Top Menu Bar By default the main file, view/display configuration function icons are
arranged here. Information about a icon’s action can be obtained by
placing the mouse pointer over an icon. ‘Greyed’ icons indicate actions
that are currently unavailable. N.B. During certain operations additional
icons may appear.

Right Side Icon Bar By default this icon bar displays access to the datum geration icons
(identical function to the datum pull down menu see above) together
with a number of sets of context sensitive icons.

3. Message Window This is a scroll-able window in which information on the
system status and prompts for inputs are displayed. If the system is not
responding look at this window as it normally indicates what is wrong.
Typically it is waiting for an user input and the window has been over written.

4. Display/Drawing Window The large blue window is the main window in
which the model or drawing is displayed. When a model is active the display
can be manipulated using mouse/key combinations (see below) and commonly
used commands can be accesed via floating menus (Press the RMB over the
area). N.B. immediately below this window is a line which continuously
displays simple help information, in particular button/menu item actions.
General keyboard input is also shown here, notably mapkey shortcuts.

5. Navigator Area to the left of the main drawing screen that allows
information about the model, directory structure etc to be displayed.

6. Browser Embedded web browser, accessible by clicking on the small arrows
(‘sash controls’) at the righthand edge of the Navigator area.

4.2 Part(/Assembly) menus and Model Tree

As soon as a part (or assembly) in loaded, or a new entity started additional
information will appear on the screen, notably

1. Additional icons in the top and right hand icon areas associated with image
control and feature construction.

In main cases clicking on a top level icon will initiate a series of sub
menus/icons. In many cases Pro/E will make educated guesses as to the users
selection in these menus, to save time moving the mouse the

2. The Model Tree window gives a graphical representation of the method of the
part construction, i.e. the order of Features. The tree can also be used to
select individual or groups of features as a alternative to selection in the
drawing window. This functionality becomes increasingly useful as the model
complexity increases. Features can also be moved in the tree with a simple
drag and drop operation provided there are no parent-child conflicts.

N.B. Quick access to feature modifying functions can be gained via
the RMB whilst over the Model Tree.

The layout and information displayed is user definable via the icons and
pulldown menus at the top of the window.
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You should bear in mind that Pro/E is a specialist package, and the designers who
use it would normally do so full time, after an extended training period: so don’t be
surprised if you find it more difficult to use than other CAD software that you may
already know.

Central to the use of the package is the ability to obtain the best view of the object
you are constructing, e.g. the orientation and the display mode. Access to
commands effecting the display are concentrated under the View pull down menu
and the top icon bar. In addition the orientation can be manipulated with a
combination of the Ctrl/Shift keys and the mouse.

Key/Mouse Action

(N.B. The Ctrl key can normally be released once
the action has been initiated.)

Ctrl - Middle Mouse Button Zoom in/out

- Middle Mouse Button Spin

Shift - Right Mouse Button Translate

4.3 Sketcher

Central to the use of the ‘sketched’ features is the use of the sketcher or sketch
mode. This is basically a complex drawing program which allows profiles to be
drawn that are subsequently extruded/revolved/swept etc through 3-D space to
modify the item being constructed.

Built into the package is knowledge of how things are typically constructed, e.g.
lines are often parallel, similarly sized sketched entities are likely to be identical.
The system uses these ‘Assumptions’ to apply overidable ‘Constraints’ to the
sketch, e.g. vertical/horizontal line, to simplify the drawing the profile.

It should be noted that the assumptions taken by the system are partial dependent
on the screen scale.

• Sketching Tools

The sketcher has many commands/functions that are accessible either from
the SKETCH pull-down menu, via the side icon bar or from context sensitive
floating menus accesed via the RMB. In addition a number are mapped to
standard CUED hotkey sequencies, see below.

The main drawing commands are found in the following sum-menus:

GEOMETRY Mouse Sketch, Lines, Arc, Circle, Rectangle and Point.

GEOM TOOLS Intersect, Trim, Divide, Use edge, Mirror and Move.

SEC INFO information about the sketched entities, including intersect and tangent
points, angles, distances etc.

• Sketcher Assumptions
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The knowledge model underpinning both operational modes attempts to apply
constraints based on the following assumptions about the users intent:

Equal radii and diameters, symmetry, horizontal and vertical lines, parallel
and perpendicular lines, tangency, 90 and 180 degrees arcs, collinearity, equal
segment lengths, point entities lying on other entities, and centres lying on
same horizontal or vertical.
More detailed information on these assumptions can be found in the user
manuals.

• Sketcher Tips

– Keep sketches simple, you can add other features later.

– Use sketcher grid to aid construction (can also set grid snap from the
UTILITIES → ENVIRONMENT menu)

– Do not use Modify, i.e. apply physical dimensions, until a section is
(nearly) complete.
With the intent manager inactive

– Create sketches in steps, and regenerate each step as you progress.

– Use Unregenerate to restore sections to their previous state.

4.4 Mapkeys - Hotkeys/Keyboard Shorts

The complexity of a full function CAD package means that it can be difficult/time
consuming to access a particular command/set of commands. ProE offers a hot key
functionality in addition to the pulldown menus/icons and floating menus to aid
efficiency. There are a set of CUED standard hot key sequences that should be
available on all systems. Most are two character commands that can be most easily
accessed assuming a right hand mouse operation and a left hand on the keyboard.
(See the table at the end of this document)
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Figure 3: Shaded view of the completed worked example.

5 Worked Example: Clamp

This section is a guided tutorial to produce a model of a clamp as shown in figure 5.
The tutorial is laid out in subsections corresponding to the construction of
individual features within the model.

Detailed descriptions are given of the construction of the initial features, as the
guide progresses information is limited to only the new commands being employed.

As in the physical production of an item there is often a more than one way of
construction, with no one ‘correct’ method. The construction techniques used here
have been chosen to show a range of features and their of method of usage rather
than a definitive solution.

5.1 Start ProEngineer

If not already running initiate the system as described in the getting started section,
e.g. START→3D-CAD→proewildfire3.

To change to the directory used to save files select FILE → Set Working
Directory (or use the hotkey option cd) and then select the required directory.

5.2 Creating a part

The creation of a new part involves the generation of a file together with default
coordinate system, datum planes and material properties etc. While this can be
achieved using individual commands (see Appendix A), it is highly recommmended
that the CUED default ‘start part’ is used.
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Use the LMB to select NEW PART icon ( ) on the top menu bar, this will
start an automatic procedure to generate a new part using the default CUED
settings.

After a few seconds a menu will appear prompting for the name of a part, e.g.
clamp, and then press ENTER or click (LMB) on OK.

This will initiate a procedure to set up the default coordinate system and datum
planes (Front, Mid, Top) which will be appear in the main window.

N.B. The brown Datum icons ( ) on the top icon bar can be used
to toggle the display of datum features

In addition to the default datums a number of other part paramenters have been set
by using CUED start-part. If you need to change any paramenter/ use the
additional functionality please refer tot he online help or the manuals.

5.3 Initial Material Feature / Protrusion

Create a base protrusion (stock material) by selecting the Extrude Tool icon ( )
from the right hand icon-bar, this will initiate the ’Extrude Dashboard’
( ) just below the message window.

It is possible to use an exisiting sketch as the basis of a sketched feature, here
however use the internal sketch option by RMB→Define Internal Sketch.

Section Menu

1. Sketch Plane

This will open a SECTION window and a prompt in the message window to
”Select a plane or surface to define sketch plane”. Moving the mouse over the
main window will highlight (in light blue) each of the possible sketch planes.

Using the LMB, select the plane FRONT when highlighted or the Model Tree
window.

Immediately the menu will be populated with default values and also
indicated on the main window.

An arrow indicates the direction of view of the sketch plane
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The direction can be changed using the Flip menu item, in this example any
direction will be suitable.

2. Sketch Orientation The sketchplane can be presented on the screen in any
angle and a preferred orientation can be selected by using the reference and
orientation menu items. In most cases ProEngineer makes an intelligent
guess at the required orientation and therefore the default can be accepted.

In this case choose the defaults, by selecting Sketch.

N.B. Sketch is highlighted on a raised button in the menu and can thus
be selected as the default option in the menu by pressing the MMB
(with the pointer in the main window), see above.

N.B. Standard extrusions can be initiated more simply by using the Ext
1 Side, Ext Revolve and Ext 2 Side, (Extrude 1 side, Extrude revolve
and Extrude 2 sides), from the PART menu. N.B. This requires the
CUED New Part option to have been used.

3. (Dimension References)

Reference Menu

To automatically dimension any entity drawn the system needs a local
dimensioning reference. When the sketcher mode is entered the system
automaticallyselects default references suitable for dimensioning the sketch.
Should you need to chand or add to the references start the REFERENCES
window, from SKETCH→References which lists the entities that have been
choosen as default references and indicated in the sketching window by brown
dash-dot-dot lines.

In this example the default references should be ‘F1(MID)’ and ‘F2(TOP)’
thus select (LMB) Close . Any further drawing on this plane will be
referenced to this temporary coordinate system.
(N.B. It can be useful at this stage to Deselect the Datum Plane icon
to simplify display)

4. Sketching a Section

Using The sketch arc(centre/ends) function accessed via either the arc (4th
icon down) → centre/ends (3rd icon on the flyout menu) or SKETCH → Arc
→ Center/Ends draw a arc centered on the intersection of TOP and MID.
LMB to select circle center, start and finish.
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Figure 4: Initial sketcher mode layout.

Complete a rough sketch of the remained of the profile section as shown in
Figure 5 using the line draw facility. This can either be accesed via the
RMB/flying menu or the icon/menu options as used for the arc.

To delete unwanted items, select the entity (line will turn red) and then
select delete by holding down RMB → Delete. Multiple entities can be
selected by dragging a boundary using the LMB

(Should artifacts be left on the window use VIEW → Repaint, the

Repaint icon on the top menu bar ( ) or the hot-key sequences (CTRL)
+ R or vr) to refresh the screen.

Note :
(a) The pointer has ‘intellegence’ and snaps as it approaches an
intersection/circle centre/line etc
(b)Pressing MMB once while drawing an entity will abort the operation and
return to the standard select option.
Once drawn the system will allocate default dimensions to the entities, which
are displayed in grey. The values are based on the screen resolution/setup and
any previous components of the part.

(It is worthwhile spending some time familiarising yourself with the
sketcher mode - add lines, rectangles etc and then delete them.)

Figure 5: Rough sketch of profile section.

5. Modifying a Sketch Dimensions on the sketch can be simple modified to a
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precise value by double clicking on the screen value and entering the correct
figure at the prompt. A more dynamic, but less precise method of
modification is available by selecting (LMB) and dragging and dropping a
sketch entity, e.g. a line.

6. Redimensioning a Sketch Although the system automatically places
default (soft) dimensions, which are used to generate drawings etc., it often
useful to choose alternative dimensions. In this case an alternative dimension
from the vertical reference to right hand end can be defined using the
dimension function (accessed via the floating menu, side bar icons, SKETCH
menu or hotkey sd (Sketch Dimension)).

To place the dimension select the entities and then place with the MMB, i.e.
select (LMB) the vertical reference, righthand vertical of the section and
MMB to place dimension above the section.

7. Sketcher Exit To exit the sketcher mode select SKETCH → Done or the
‘Tick’ on the side icon bar.

8. Solid/Surface ( )

Leave the default setting of the second and third dashboard icons, e.g. the
”extrude as solid” option (second icon) selected.

9. Profile Depth The left depth icon allows the user to select details of the
extent of the extrusion, here select symmetrical two-side.

Adjust the depth to 32 by chosing one of the following techniques:

(a) Enter value in the field on dashboard

(b) Selecting and dragging the square handle (small white square, on axis) on
the extrusion in the main window. Note it can be difficult to acccurately
choose a value using this technique.

(c) Double clicking, with LMB, on the dimension in the main window and
entering the required value.

10. Verify/Preview ( )

The defined feature can now be temporarily previewed by verify icon ( ),
from the right hand end of the dashboard. If an error exists individual
elements of the protrusion can be modified by re-selecting the appropriate
icon.

11. Exit ( )

Once completed the protrusion can be accepted by selecting the tick ( ).
N.B. Selecting the cross will cancel the generation of the feature.
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5.4 Review/Display

The Protrusion can now be rotated and/shaded to improve the view of the feature.

1. Press the MMB to rotate the model. Use SHIFT and CTRL to zoom and pan.

2. Select Shading, Wireframe etc icons ( )

3. You can also reset the view and repaint it. These options are available by
choosing VIEW pull down menu or from the icon bar ( ) ( ) .

Figure 6: Re-dimensioned profile section.

5.5 Edit Profile Dimensions

There are several ways of modifying a features dimensions

1. Select the feature (Protrusion idxxx) in the Model Tree or drawing screen,
(Highlight protrusion feature in light blue and select with LMB) and the using
the RMB select Edit. The defining dimensions are displayed in the main
window, Select the value to be modified (double click LMB) and enter the
value at the prompt.

2. Again select the required feature and in the flyout menu (RMB) select Edit
Definition which will return to the protrusion dashboard.

Modify the radius to 22, height to 16 and center/end dimension to 60 as shown in
Figure 6. Dimension values are changed from yellow to white when modified.
To action the modifications select Regenerate from the EDIT menu, the image will
animate to the new dimensions.

(N.B. The regenerate function can also be actioned by (a) Using the hotkeys

rg (b) Selecting the Regenerate icon
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5.6 Save Part

Use the FILE → Save function or save icon ( ) the save the part in its current
form.
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5.7 Extruded ’Cut’ using a surface reference

Create the end cutout using the remove material option in the extrude feature( )
to generate the semi-circular cut in the end of the protrusion.

1. Define Internal Sketch RMB →Define Internal Sketch and the select the
end face of the protrusion as the sketching plane, and accept the defaults for
the direction and orientation.

Accept the default dimension references.

Figure 7: Rough sketch of Cut section.

2. Sketch. Using the arc drawing and line drawing functions, as used to define
the extrusion, generate a closed semi-circular section centered on the
intersection of FRONT and TOP, see Figure 7.

Adjust the cut to have a diameter of 25.4mm. (ProE defaults to radius
dimensions)

Select the dimension function (icon, RMB or SKETCH menu), double click
LMB on arc (single click for radius) and use MMB to place dimension. Note
the change in the dimension format and the removal of the soft (default/grey)
dimension.

To modify the dimension value either:

• Single click (LMB) on the dimension to be modified and then use the
EDIT menu or RMB to select Modify. The resulting MODIFY
DIMENSIONS menu allows dimensions to be modified (25.4mm) either
using the writable field or the ‘Thumb Knob’.

N.B. By default the automatic Regenerate option is selected which
causes the sketch to be dynamically updated. When a number of
dimensions need to be adjusted it may be need to unslect this option to
avoid difficulties.

• Double click (LMB) brings up a simple edit box to enter the required
value (25.4mm) ENTER or select ‘Tick’ to modify.

Exit the sketch with ‘Tick’ ( ).
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3. Depth ( ) Accept the default (”Extrude from sketch plane by a
specified depth value.”) and adjust the depth to 20.

4. Cut ( ) Switch from a material extrude to a cut by selecting the cut icon
(radio button down).

5. Preview ( ) Use the Verify/Preview icon to check the cut is correct.

6. Cut (material) Direction ( ) if required, use the material direction
function to swap the side of the section that is cut.

7. Exit ( ) Exit the extrude (cut) tool.

5.8 ‘Both’ sided cut feature

Again use the extrude/remove feature, using the two-sided option, to generate the
hollowed section under the curved section of the protrusion.

1. Section Select the FRONT plane as the sketching plane, and accept the
defaults for the direction and orientation.

Accept the default dimension references. (Deselect Datum Plane icon to
simplify display)

Sketch, using Arc or Circle functions combined with the line function,
(Accessed from the Sketch Menu or RMB or side icons) an approximation of
the cut section centered on the intersection of FRONT and TOP, see Figure 8.

Figure 8: Rough sketch of Cut section.

Tidy sketch using either
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• The trim function (EDIT → Trim → Corner or third icon from bottom
of the side icons) to delete unwanted lines.

• Break the sketched entities at intersections by using the ‘Devide Entity’
tool, on the same fly out menu as trim. Delete the unwanted lines using
select (LMB) followed by RMB → Delete. N.B. Intersections generated
are highlighted with a yellow dot.

2. Dimensions Using Modify and Dimension tools set the cut radius to 18 and
base to flat section to 15. Exit sketch mode with Done or ‘Tick’.

3. Depth Set the extrusion to be a symmetrical two-sided, with a total depth of
24mm.

4. Cut ( ) Switch from a material extrude to a cut by selecting the cut icon
(radio button down).

5. Preview ( ) Use the Verify/Preview icon to check the cut.

6. Cut (material) Direction ( ) if required, use the material direction
function to swap the side of the section that is cut.

7. Exit ( ) Exit the extrude (cut) tool.

5.9 Pick & Placed Hole

( ) Using the hole feature generate the 25mm diameter circular hole through side
webs under the curved section of the protrusion.Figure 9 shows the hole dashboard.

(a) (b)

Figure 9: Hole dashboard. (a) Placement options & (b) Shape Options

1. Hole Placement requires three references the initial placement plane and two
entities to dimension the hole in x/y space.

• Select the side of the protrusion as the placement plane.

• Select the planes MID and TOP as the dimension references and align
the hole by setting both offset Distances to 0mm

2. Feature → Create → Hole initialises the general purpose HOLE generation
menu.
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3. Select Hole Type → Simple Hole

4. Set Hole Dimension → Diameter 24.5 and Depth One Thru All

5. Preview/(Define)/Tick before inspecting the resultant component.

N.B. A note is added to give information about the hole. To switch this off

select TOOLS → Environment and then deselect 3De Notes( ) or

use the hotkey ’3d’.

5.10 Sketched Hole

In addition to a straight sided hole the hole function allows for the automatic
generation of standard holes, e.g. thread and clearance holes, and special variable
cross-section holes. generation of shaped holes, e.g. cone seated pressure seals.

Here the Sketcher is used to generate the basic shape for the hole in the center of
the item. N.B. This is a unique combination of a Pick & Place feature with an
element of a sketched feature.

1. Hole tool Select the hole feature as with the last hole, but select the Hole
Type → Sketched

2. The system produces the sketched hole in a similar manner to a revolved cut
feature and therefore expects a sketch of half the hole profile and a centreline
as an axis of rotation. However, unlike a revolved CUT (or Protrusion) no
references are required. Thus once a sketched hole has been selected a empty
standard sketcher window is initialised.

Start by placing a vertical centreline using a RMB→ Centreline and then
click (LMB) drag to align vertical.

Then sketch the shape of half the hole, see Figure 10. N.B. To change the
default radius dimensions to diameters, select Dimension followed by the
point of reference, the centreline and the point of reference before placing the
dimension with the MMB. This functionality is available in all revolved
features.

Figure 10: Rough sketch of the sketched hole section.
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g Select Tick when complete, and continue the placement process as with a
straight hole.

3. In the PLACEMENT menu select Linear → Done this will now start a
sketcher window in which to define the hole cross-section prior to continuing
with the placement definition.

4. Select the top of the protrusion as the Primary Placement Reference and the
central datum plane (FRONT, Offset Distance 0mm) and the end of the
protrusion (Offset Distance 30mm) as the Linear References.

5. Preview, Update, Tick before inspecting the resultant component.

6. Use the select feature RMB→Edit to change the hole dimensions. Small
diameter, 8, Large diameter, 16, Overall depth 16, Large diameter depth 10.
(Regenerate to update the values)

This function is very similar to the revolved cut!. (Select the generated feature and
RMB→suppress to remove it from calculations. Now try and regenerate the feature
using the revolve/cut feature)

5.11 Protrusion - adding material

The nut retaining surfaces in the sketched hole can be produced using the
Protrusion feature to add material to an existing item. In this case use the sketch +
feature method of construction, i.e.

1. Sketch Item: Select the sketch feature icon and using the base of the large
diameter hole as the sketching plane,

• Select FRONT or Default as the additional reference.

• In a similiar manner as the sketched entities produced above, existing
datum planes, i.e. FRONT and MID, can be used as the sketching
references. However, a simpler and more appropriate reference is the
existing hole, i.e. select the edge or central axis of the sketched hole.

Figure 11: Sketch of the nut retaining protrusion, showing the use of centrelines.
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• Using centrelines set at 30o sketch the three inserts, as shown in
Figure 11. Use the arc and line commands to generate the general shape.
If and error of unclosed section(s) is given on selecting Done/Tick use
Edit → Trim (or icon entry) to join/trim the straight and arc lines.

• Exit the sketcher, notice the sketch feature in the model tree

2. Extrusion: Select the extrude tool and extrude the retaining surfaces using the
predefined sketch. Set a blind depth of 8

3. Preview/(Define)/OK

5.12 Ribs

An alternative to a protrusion for a thin extrusion is a Rib. This is very similar but
only requires the external surfaces to be defined. To produce one of the small
reinforcing webs under the curved section of the clamp, but not aligned to an
existing surface a Rib can be used drawn using and attached datum.

An attached Datum is identical to a normal datum plane but is directly associated
with a feature. It is used here to dimension the rib from the center of the object to
enable the feature to be patterned. N.B. This method of construction is essential for
the patterning of features around a diameter.

1. Select the rib tool

2. Select the option to use an internal sketch

3. When prompted for a sketch plane add a datum using the icons from the
righthand icon bar. These datums are constructed with relation to other
preexisting features, in this example the required sketching plane is
parallel/offset from FRONT. Selecting front will give the option of adding an
offset, 7.

4. Select TOP (or Default) as the second reference plane

5. Specify MID and TOP as positional references

6. Sketch a single line to represent the diagonal edge of the web and dimension
as shown in Figure 12, 7 horizontal, 10 vertical.

7. Accept the sketch and enter a thickness of 2 mm.

Repeat the above construction technique, using FRONT as the sketching plane, to
generate the large rib and dimension as shown in Figure 13. Thickness 2.

5.13 Patterned Feature

Patterning is a very powerful tool that allows feature, or groups of features to be
repeated according to a geometrical rule without having to reconstruct the feature.
It is often used to pattern around an axis, e.g. to generate a set of holes on a PCD.
To generate the second small rib
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Figure 12: Sketch showing the simple definition required for a rib

• Select the pattern tool

• Select the offset dimension from FRONT as the driving parameter, and enter
the increment -14.

• 2 to generate 2 copies of the rib in the pattern.

5.14 Rounds

The Rounds & Chamfer features are normally added as the last constructional
details on an object, as in the physical construction process. This eliminates
unwanted problems resulting from subsequent features removing the reference
edge/surface and also to reduce the computational burden of continuously
displaying complex surfaces.

To add the rounded edges to the clamp, select the round tool icon ( ) or
(INSERT→Round ....) starts the ’round’ dashboard and a message prompt ‘Select
and edge or chain of edges, or a surface to create a round set’.

1. Radius Set the round radius to 1 mm.

2. Edges Although there are a large number of options, accept the defaults and
using the highlight/select function select the two outer edges of the spacer.

24



Figure 13: Dimensions of the large reinforcing rib

N.B. the most recently accepted edge is highlighted in red and is dynamically
adjustable.

3. Review Check, preview and Exit round tool

6 2-D Drawing

Even though the direct link from CAD to CAM (Computer aided manufacture) is
increasingly common there is still a need to produce 2-D drawings, in ProE this is a
relatively painless procedure as the hard work has already been completed in the
model generation. Note that the drawing views are associative. If a dimension is
changed in one view and regenerated, all of the views update and so will the entire
model.

6.1 Laying out a Drawing

6.2 Start a Drawing

To open a new drawing select FILE→New→drawing. Enter the name of the
drawing, e.g. clamp and select OK

The NEW DRAWING menu should now appear, ensure that the default model field
is clamp.prt, ensure the Empty with format option is selected and the format
field is a4 part.frm. Selecting OK will initiate the drawing window and open the
DRAWING and DETAIL menus.
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6.3 First View

To generate and locate the first view

1. Insert View select RMB → Insert Drawing View or INSERT →Drawing
View

2. View Type in the VIEW TYPE menu accept the default values of General
→ Full View →No Xsec → No Scale → Done or MMB.

3. Placement The user is now requested to choose the location for the master
view by a prompt in the message window ‘select CENTER POINT for
drawing view. Selecting (LMB) a position near the bottom right of the
drawing surface will result in a default (isometric) view being placed followed
by the opening of an ORIENTATION window, see Figure 14.

4. Orientate View The Orientation functions can be used to obtain the
direction of a view. Using the CUED start part a number of Saved Views
are available and normally enable the initial view to be placed simply. (You
need to click on the white arrow beside the SAVED VIEWS title to expose the
full menu).

A suitable master view for this drawing is FRONT, select Saved
Views→Front and then Set → OK. (N.B. It is important to select Set
before OK.)

Figure 14: Orientation of the initial drawing view

6.4 Additional Views

Additional views can now be added, with the view orientated automatically. Using
the default menu choices add two more views to your drawing.
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1. Add View Use RMB → Insert Drawing View, ( ) or INSERT
→Drawing View to initiate the generation of new views.

2. View Type In the VIEW TYPE menu accept the defaults (Projection* →

Full View → No Xsec → No Scale → Done) or MMB.

N.B. Once the initial view has been placed the system assumes that
subsequent views are projections.

3. Placement Use the LMB over the drawing area to select the position of the
two views, the system will ensure that the correct projection is shown.

4. Relocate views Using LMB to select a view (highlighted in with a red box)
and then holding LMB down drag the view to the required location. Select
with LMB in a clear area of the drawing to deselect a view. (If the view does
not move deselect the ‘Lock View Movement’ from the RMB context sensitive
menu)

5. Set Display mode Select the Hidden Line display option ( ) on
the icon bar and deselect the datum icons to display a clean drawing. N.B.
No Hidden (and Wireframe) can be used if required.

6. Setting the Drawing Scale To change the overall scale of a drawing double
click LMB on the scale information at the bottom left of the main window. At
the prompt line enter the value you require, 0.4 is a suitable scale for this
drawing.

N.B. Normally drawings scales are limited to multiples of standard
scales, e.g. 1:1 1:2 1:2.5 1:4 1:5 (1, 0.5, 0.4, 0.25, 0.2)

Figure 15: (a) Show-Erase Menu (b) Accept All

6.5 Display Centerlines

Select VIEW → Show/Erase or ( ) to open the SHOW/ERASE window.

Select the axis icon and Show All, see Figure 15(a), confirm ‘Are you sure that you
want to show all?’ and then Accept All
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6.6 Drawing Dimensions

To dimension the drawing use the same ‘Show and Erase’function ( ) as above

(sectionr̃efsec:clines). Select show ( ) and dimension ( ) → ShowAll
→ Accept All.

6.7 Tidy Drawing

The position of symbols and text can be moved using the LMB to select a item
which can then be dragged to the required position. MMB to stop, LMB to exit
move.

A large number functions are available via the RMB context sensitive menus, see
Figure 16, and from the INSERT and FORMAT menus. (See FORMAT →

Decimal Places.. to change default number display and therefore implied
accuracy)

(a) (b) (c)

Figure 16: Examples of context sensitive Pull out Menus, (a) On background (b) On
selection of 1 dimension (c) Multiple dimension selection

Use the functions, details about some are given below, to tidy the dimensioning etc.
(Also see Figure 17)

1. Cleanup Dimensions Multiple selection → RMB automatically aligns
dimensions on a user definable spacing.

2. Move Item to View Single or Multiple selection allows dimension etc to be
switched between views.

3. Flip Arrows Single or Multiple selection allows dimension arrows to be
realigned

4. Properties (Background) Allows sheet/layout to be changed

5. Properties (Single) Change value, format, font etc.

6. Text Style Change text in multiple dimensions etc.
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Figure 17: Example of partially dimensions drawing of the clamp

6.8 Isometric View

The advantage of CAD is that it is relatively easy to add additional views. It is
often useful to add an Isometric view to aid visualisation. To add a general view
select RMB → Insert Drawing View or ( ) Accept the default settings, except
choose General instead of Projection, and Scale instead of No Scale. Place and
orientate the view in a blank part of the drawing, see Figure 17.

6.9 Printing a Drawing

Printing to Postscript printers is relatively easy from Version 20 of ProE onwards:

• select the printer icon or Print from the File pull down menu.

• Select Generic Postscript

• Enter printer command, e.g. lp -dljmr1 for the laser printer on the teaching
system.

For access to large format printers or colour output contact the computer
operators or the Design Office.
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7 appendix

7.1 Part (Assembly) Colour

By default the colour of a part is Grey, however in many cases it can help
visualisation/manipulation to change the colour of the whole or a part of an entity.
As an example colour the bottom flat surface of the clamp red.

Select the APPEARANCES menu, (VIEW →Color & Appearances

7.2 Relations

The parametric nature of ProE allows model variables to be set as fixed values or
written as a function. These Relations can be a algebraic function that is
dependent on another model variable, for example ensure that the diameter of the
hole under the reinforced section of the clamp is the same as the cut in the end:

• Choose Tools→Relations. Read the prompt.

• Select the hole and cut, from the drawing or model tree, to display their
dimensions in symbolic form (i.e. d2, d3, etc).

• Note the symbolic dimensions that defines the hole diameter and cut radius,
e.g d11 , Rd4.

• Select Add from the RELATIONS menu which will open a prompt window.

• Enter the relation d4=d11/2 <CR>

• Comments, which are essential on complex models, can be added to the
relations by prefixing text with /* Clamping diameters equal.

• Further relations can be added to make all feature parameters a function of
one dimension, e.g. clamping diameter. To finish enter <CR> on a blank
prompt line.

• Use Switch Dim from the RELATIONS menu to toggle dimensions between
their symbolic and numeric forms.

• Select Done from the MODEL REL menu → Regenerate.

• If an error in the relations, select Relations → Edit Rel. This will display
the current relations in the text editor. Correct any errors, saved the file and
exit the editor before Regenerating again.

Create a New Part by selecting New from the File pull down menu, followed by
selecting Part and entering a filename, e.g. clamp, followed by OK.
At this stage the Menu Manager (PART sub-menu) and Model tree windows will
appear, it is normal to locate these to the left of the drawing window.
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7.3 Default Csys & Datum Planes

Figure 18: Default Datum Planes

Create default Csys and Datum Planes from the PART sub-menu, i.e.

• Select Feature → Create → Datum → Coord Sys

• Select Feature → Create → Datum → Plane → Default

N.B. It is also possible to insert default planes/coordinate system using the Datum
menu to the side of the main creen. this is available at all times.

Figure 18 shows the resulting screen display. The creation of a new part and datum
plans can be automated by selecting the CUED icon New Part that results in a
similar display but with the datum planes renamed Front, Top and Mid and a
prompt for the part name.

P.J.G. Long
May 12, 2007
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